aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/wide-dhcp/files/patch-ae
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/wide-dhcp/files/patch-ae')
-rw-r--r--net-mgmt/wide-dhcp/files/patch-ae51
1 files changed, 26 insertions, 25 deletions
diff --git a/net-mgmt/wide-dhcp/files/patch-ae b/net-mgmt/wide-dhcp/files/patch-ae
index 98387aad7226..c221d1e92e64 100644
--- a/net-mgmt/wide-dhcp/files/patch-ae
+++ b/net-mgmt/wide-dhcp/files/patch-ae
@@ -1,35 +1,36 @@
---- server/Makefile.FreeBSD.orig Mon Nov 6 16:18:41 1995
-+++ server/Makefile.FreeBSD Fri May 30 22:47:17 1997
-@@ -1,16 +1,27 @@
- OBJ = dhcps.o database.o hash.o ctime.o getmac.o common_subr.o \
+--- server/Makefile.FreeBSD.orig Tue Jun 11 13:05:48 1996
++++ server/Makefile.FreeBSD Wed Apr 22 01:46:55 1998
+@@ -1,13 +1,13 @@
+ OBJ = dhcps.o database.o hash.o getmac.o common_subr.o \
interface.o delarp.o
--LDFLAGS =
+-LDFLAGS = -lkvm
-CC = gcc
--CFLAGS = -g -Wall #-DCOMPAT_RFC1541 #-DNOICMPCHK
+-CFLAGS = -g -Wall -I. #-DCOMPAT_RFC1541 #-DNOICMPCHK
-#CC = cc
-+LDFLAGS = -lkvm
+-#CFLAGS = -g -I. #-DCOMPAT_RFC1541 #-DNOICMPCHK
+-SBIN = /usr/local/sbin
+-LIBEXEC = /usr/local/libexec
+-MAN = /usr/local/man
++LDFLAGS =
+#CC = gcc
-+CFLAGS += -Wall #-DCOMPAT_RFC1541 #-DNOICMPCHK
++#CFLAGS = -g -Wall -I. #-DCOMPAT_RFC1541 #-DNOICMPCHK
+CC = cc
- #CFLAGS = -g #-DCOMPAT_RFC1541 #-DNOICMPCHK
-+SBIN= ${PREFIX}/sbin
-+LIBEXEC= ${PREFIX}/libexec
-+MAN= ${PREFIX}/man
-+CP= /bin/cp
-+RM= /bin/rm
++CFLAGS += -Wall -I. #-DCOMPAT_RFC1541 #-DNOICMPCHK
++SBIN = ${PREFIX}/sbin
++LIBEXEC = ${PREFIX}/libexec
++MAN = ${PREFIX}/man
dhcps: ${OBJ}
${CC} ${CFLAGS} -o dhcps ${OBJ} ${LDFLAGS}
+@@ -15,11 +15,8 @@
+ install: dhcps
+ ${INSTALL} -m 755 -s dhcps ${SBIN}/dhcps
+ cp dhcpdb.pool.5 ${MAN}/man5/dhcpdb.pool.5
+- gzip ${MAN}/man5/dhcpdb.pool.5
+ cp dhcpdb.relay.5 ${MAN}/man5/dhcpdb.relay.5
+- gzip ${MAN}/man5/dhcpdb.relay.5
+ cp dhcps.8 ${MAN}/man8/dhcps.8
+- gzip ${MAN}/man8/dhcps.8
-+install: dhcps
-+ ${INSTALL} -c -m 755 -s dhcps ${SBIN}/dhcps
-+ ${CP} dhcpdb.pool.5 ${MAN}/man5/dhcpdb.pool.5
-+ ${CP} dhcpdb.relay.5 ${MAN}/man5/dhcpdb.relay.5
-+ ${CP} dhcps.8 ${MAN}/man8/dhcps.8
-+
clean:
-- rm -f *~ *.o *core* dhcps
-+ ${RM} -f *~ *.o *core* dhcps
-
- dhcps.o: dhcps.c dhcp.h common.h common_subr.h hash.h dhcps.h
- database.o: database.c dhcp.h common.h hash.h database.h
+ rm -f *~ *.o *core* dhcps