aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix5-frontend/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/zabbix5-frontend/Makefile')
-rw-r--r--net-mgmt/zabbix5-frontend/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-mgmt/zabbix5-frontend/Makefile b/net-mgmt/zabbix5-frontend/Makefile
index ee166658e4ef..41188ad76b45 100644
--- a/net-mgmt/zabbix5-frontend/Makefile
+++ b/net-mgmt/zabbix5-frontend/Makefile
@@ -6,24 +6,23 @@ PKGNAMESUFFIX= -frontend
MASTERDIR= ${.CURDIR}/../zabbix5-server
-NO_BUILD= yes
-NO_ARCH= yes
+USES+= php:web
+USE_PHP= bcmath ctype dom fileinfo filter gd gettext hash json ldap \
+ mbstring pcre session simplexml snmp sockets xml xmlreader \
+ xmlwriter
+
PATCHDIR=
+NO_ARCH= yes
+NO_BUILD= yes
PLIST= ${PKGDIR}/pkg-plist.frontend
-USE_PHP= bcmath ctype dom fileinfo filter gd gettext hash json ldap mbstring \
- pcre session simplexml snmp sockets xml xmlreader xmlwriter
-USES+= php:web
-
-OPTIONS_DEFINE= MYSQLI PGSQL ORACLE
+OPTIONS_DEFINE= MYSQLI ORACLE PGSQL
OPTIONS_DEFAULT= MYSQLI
MYSQLI_DESC= MySQLI backend
-MYSQLI_USE= PHP=mysqli
-
-PGSQL_USE= PHP=pgsql
-
+MYSQLI_USE= PHP=mysqli
ORACLE_CONFIGURE_WITH= oracle
+PGSQL_USE= PHP=pgsql
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}