aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zenpack-libvirt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/zenpack-libvirt')
-rw-r--r--net-mgmt/zenpack-libvirt/Makefile29
-rw-r--r--net-mgmt/zenpack-libvirt/distinfo2
-rw-r--r--net-mgmt/zenpack-libvirt/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-libvirt/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-libvirt/pkg-descr4
-rw-r--r--net-mgmt/zenpack-libvirt/pkg-plist2
6 files changed, 52 insertions, 0 deletions
diff --git a/net-mgmt/zenpack-libvirt/Makefile b/net-mgmt/zenpack-libvirt/Makefile
new file mode 100644
index 000000000000..d314750b49d5
--- /dev/null
+++ b/net-mgmt/zenpack-libvirt/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libvirt
+# Date created: 20 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvirt
+PORTVERSION= 1.71
+CATEGORIES= net-mgmt
+MASTER_SITES= http://zenpacks.zenoss.org/trac-zenpacks/changeset/1002/tags/
+DISTFILES= ${PORTNAME}-${PORTVERSION}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Provides monitoring of virtualization servers through Zenoss
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= libvirt>=0.9.1:${PORTSDIR}/devel/libvirt
+
+WRKSRC= ${WRKDIR}/tags/${PORTNAME}-${PORTVERSION}
+
+USE_ZIP= yes
+ZPACKPREFIX= ZenPacks.community.
+ZPACKGROUP= community
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-libvirt/distinfo b/net-mgmt/zenpack-libvirt/distinfo
new file mode 100644
index 000000000000..2669c5bc5ac4
--- /dev/null
+++ b/net-mgmt/zenpack-libvirt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libvirt-1.71?old_path=%2F&format=zip) = cafc581b1f130caca381bf27d0e1e2b1f3d8ede6b6fd3bb00afeb479ea0acc63
+SIZE (libvirt-1.71?old_path=%2F&format=zip) = 17959
diff --git a/net-mgmt/zenpack-libvirt/files/pkg-deinstall.in b/net-mgmt/zenpack-libvirt/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-libvirt/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-libvirt/files/pkg-message.in b/net-mgmt/zenpack-libvirt/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-libvirt/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-libvirt/pkg-descr b/net-mgmt/zenpack-libvirt/pkg-descr
new file mode 100644
index 000000000000..8cd413cac005
--- /dev/null
+++ b/net-mgmt/zenpack-libvirt/pkg-descr
@@ -0,0 +1,4 @@
+This ZenPack leverages the libvirt API for monitoring virtualization servers
+(e.g. XEN, KVM, etc...).
+
+WWW: http://community.zenoss.org/docs/DOC-4687
diff --git a/net-mgmt/zenpack-libvirt/pkg-plist b/net-mgmt/zenpack-libvirt/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-libvirt/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack