aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagcon/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/net-mgmt/nagcon/Makefile b/net-mgmt/nagcon/Makefile
index 3aaa1f32a8ef..8fcef37912e6 100644
--- a/net-mgmt/nagcon/Makefile
+++ b/net-mgmt/nagcon/Makefile
@@ -10,7 +10,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= rand@meridian-enviro.com
COMMENT= Nagios console monitor
-LIB_DEPENDS= strfunc.9:${PORTSDIR}/devel/libstrfunc
+LIB_DEPENDS= libstrfunc.so:${PORTSDIR}/devel/libstrfunc
PLIST_FILES= bin/nagcon
@@ -20,7 +20,6 @@ CPPFILES= utils.cpp br.cpp nc.cpp pl.cpp
CFLAGS+= -DVERSION=\"${PORTVERSION}\" -I${LOCALBASE}/include
LDFLAGS+= -lncurses -lstdc++ -L${LOCALBASE}/lib -lstrfunc
-NO_STAGE= yes
do-build:
${CC} ${CFLAGS} -c -o ${WRKSRC}/${CFILES:C/\.c//}.o ${WRKSRC}/${CFILES}
.for f in ${CPPFILES}
@@ -30,6 +29,6 @@ do-build:
-o ${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>