aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix16-server/Makefile21
-rw-r--r--net-mgmt/zabbix16-server/files/zabbix_proxy.in2
-rw-r--r--net-mgmt/zabbix16-server/files/zabbix_server.in2
3 files changed, 16 insertions, 9 deletions
diff --git a/net-mgmt/zabbix16-server/Makefile b/net-mgmt/zabbix16-server/Makefile
index e8a0eaf8c5e5..2d9553ab15a6 100644
--- a/net-mgmt/zabbix16-server/Makefile
+++ b/net-mgmt/zabbix16-server/Makefile
@@ -15,6 +15,8 @@ PKGNAMESUFFIX?= -server
MAINTAINER= ports@christianserving.org
COMMENT= Enterprise-class open source distributed monitoring (${PKGNAMESUFFIX:S/^-//})
+LATEST_LINK= ${PORTNAME}16${PKGNAMESUFFIX}
+
CONFLICTS= ${PKGBASE}-1.8*
.if ${PKGNAMESUFFIX} != "-agent"
@@ -24,11 +26,6 @@ CONFLICTS+= ${PORTNAME}-1.[0-6]*
ZABBIX_BUILD= ${PKGNAMESUFFIX:S/^-//}
.if ${ZABBIX_BUILD} != "frontend" # frontend only needs the version/distribution settings
-LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
- curl:${PORTSDIR}/ftp/curl
-
-SUB_FILES= pkg-message
-
.if ${ZABBIX_BUILD} != "agent"
USE_RC_SUBR= ${PORTNAME}_${ZABBIX_BUILD}
.else
@@ -39,13 +36,20 @@ USERS= zabbix
GROUPS= zabbix
PLIST_SUB= ZABBIX_BUILD=${ZABBIX_BUILD}
-SUB_LIST= ZABBIX_BUILD=${ZABBIX_BUILD}
+SUB_LIST= ZABBIX_BUILD=${ZABBIX_BUILD} ZABBIX_REQUIRE=${ZABBIX_REQUIRE}
MAKE_ARGS+= ARCH=freebsd
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} --with-net-snmp
+CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD}
.if ${ZABBIX_BUILD} != "agent"
+LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
+ curl:${PORTSDIR}/ftp/curl
+
+SUB_FILES= pkg-message
+
+CONFIGURE_ARGS+= --with-net-snmp
+
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
OPTIONS= MYSQL "Use MySQL backend" on \
PGSQL "Use PostgreSQL backend" off \
@@ -58,12 +62,15 @@ OPTIONS= MYSQL "Use MySQL backend" on \
.include <bsd.port.options.mk>
.ifndef WITHOUT_MYSQL
+ZABBIX_REQUIRE= " mysql"
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
.elifdef WITH_PGSQL
+ZABBIX_REQUIRE= " postgresql"
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
.elifdef WITH_SQLITE
+ZABBIX_REQUIRE=
USE_SQLITE= yes
CONFIGURE_ARGS+= --with-sqlite3
.else
diff --git a/net-mgmt/zabbix16-server/files/zabbix_proxy.in b/net-mgmt/zabbix16-server/files/zabbix_proxy.in
index 14ab46b8a2a1..3d53faeb206c 100644
--- a/net-mgmt/zabbix16-server/files/zabbix_proxy.in
+++ b/net-mgmt/zabbix16-server/files/zabbix_proxy.in
@@ -1,7 +1,7 @@
#!/bin/sh
# PROVIDE: zabbix_proxy
-# REQUIRE: DAEMON
+# REQUIRE: DAEMON%%ZABBIX_REQUIRE%%
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to
diff --git a/net-mgmt/zabbix16-server/files/zabbix_server.in b/net-mgmt/zabbix16-server/files/zabbix_server.in
index b8c5bc324f44..5b2e85d1a354 100644
--- a/net-mgmt/zabbix16-server/files/zabbix_server.in
+++ b/net-mgmt/zabbix16-server/files/zabbix_server.in
@@ -1,7 +1,7 @@
#!/bin/sh
# PROVIDE: zabbix_server
-# REQUIRE: DAEMON
+# REQUIRE: DAEMON%%ZABBIX_REQUIRE%%
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to