aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/sendip/Makefile16
-rw-r--r--net-mgmt/sendip/files/patch-Makefile2
2 files changed, 12 insertions, 6 deletions
diff --git a/net-mgmt/sendip/Makefile b/net-mgmt/sendip/Makefile
index e1c451eda392..4204bb22549d 100644
--- a/net-mgmt/sendip/Makefile
+++ b/net-mgmt/sendip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sendip
PORTVERSION= 2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt ipv6
MASTER_SITES= http://www.earth.li/projectpurple/files/
@@ -14,15 +14,21 @@ LICENSE= GPLv2
BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
-USES= gmake perl5
+USES= gmake perl5 compiler
USE_LDCONFIG= yes
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang
+CFLAGS+= -Wno-empty-body -Wno-constant-conversion
+.endif
+
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sendip
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sendip
.for slib in ipv4.so ipv6.so icmp.so tcp.so udp.so rip.so ripng.so ntp.so \
bgp.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/sendip/${slib}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/sendip/${slib}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/sendip/files/patch-Makefile b/net-mgmt/sendip/files/patch-Makefile
index 42f6666caabb..2562ded5f947 100644
--- a/net-mgmt/sendip/files/patch-Makefile
+++ b/net-mgmt/sendip/files/patch-Makefile
@@ -19,7 +19,7 @@
-CFLAGS= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
- -Wstrict-prototypes -Wnested-externs -Winline -Werror -g -Wcast-align \
- -DSENDIP_LIBS=\"$(LIBDIR)\"
-+CFLAGS+= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings -Wno-empty-body -Wno-constant-conversion \
++CFLAGS+= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
+ -Wstrict-prototypes -Wnested-externs -Winline -Werror -Wcast-align \
+ -DSENDIP_LIBS=\"${LIBDIR}\"
#-Wcast-align causes problems on solaris, but not serious ones