aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/flowd/Makefile2
-rw-r--r--net-mgmt/flowd/files/flowd.in30
2 files changed, 32 insertions, 0 deletions
diff --git a/net-mgmt/flowd/Makefile b/net-mgmt/flowd/Makefile
index 7ba3d38d7c7e..08e83ea0d92a 100644
--- a/net-mgmt/flowd/Makefile
+++ b/net-mgmt/flowd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= flowd
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= net-mgmt ipv6
MASTER_SITES= http://www2.mindrot.org/files/flowd/
@@ -16,6 +17,7 @@ COMMENT= The flowd is a small, fast and secure NetFlow collector
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
USE_GMAKE= yes
+USE_RC_SUBR= flowd
MAN8= flowd.8 flowd-reader.8
MAN5= flowd.conf.5
PORTDOCS= README INSTALL
diff --git a/net-mgmt/flowd/files/flowd.in b/net-mgmt/flowd/files/flowd.in
new file mode 100644
index 000000000000..b28589667e97
--- /dev/null
+++ b/net-mgmt/flowd/files/flowd.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: flowd
+# REQUIRE: DAEMON
+#
+# Add the following lines to /etc/rc.conf to run ipcad:
+#
+# flowd_enable (bool): Set it to "YES" to enable flowd.
+# Default is "NO".
+# flowd_conf (file): Local config file.
+# Default is "%%PREFIX%%/etc/flowd.conf".
+#
+
+. %%RC_SUBR%%
+
+name="flowd"
+rcvar=${name}_enable
+load_rc_config ${name}
+
+: ${flowd_enable="NO"}
+: ${flowd_conf="%%PREFIX%%/etc/flowd.conf"}
+: ${flowd_flags=""}
+
+required_files="${flowd_conf}"
+command="%%PREFIX%%/sbin/flowd"
+command_args="-f ${flowd_conf}"
+
+run_rc_command "$1"