aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/flow-tools/Makefile8
-rw-r--r--net-mgmt/flow-tools/distinfo2
-rw-r--r--net-mgmt/flow-tools/files/patch-docs_flow-tag11
-rw-r--r--net-mgmt/flow-tools/files/patch-ftfile.c11
-rw-r--r--net-mgmt/flow-tools/files/patch-ftpaths.h26
-rw-r--r--net-mgmt/flow-tools/pkg-plist6
6 files changed, 37 insertions, 27 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index d799820f0542..35dbff4a7575 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= flow-tools
-PORTVERSION= 0.56
-PORTREVISION= 1
+PORTVERSION= 0.57
CATEGORIES= net
MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
@@ -23,11 +22,14 @@ MAN1= flow-capture.1 flow-gen.1 flow-split.1 flow-cat.1 \
flow-header.1 flow-stat.1 flow-dscan.1 flow-import.1 \
flow-tools-examples.1 flow-expire.1 flow-merge.1 \
flow-tools.1 flow-export.1 flow-print.1 flow-xlate.1 \
- flow-fanout.1 flow-receive.1 flow-filter.1 flow-send.1
+ flow-fanout.1 flow-receive.1 flow-filter.1 flow-send.1 \
+ flow-tag.1
post-patch:
${TOUCH} -r ${WRKSRC}/configure.in.orig ${WRKSRC}/configure.in
${TOUCH} -r ${WRKSRC}/configure.orig ${WRKSRC}/configure
+ ${PERL} -pi -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/docs/flow-print.1 \
+ ${WRKSRC}/docs/flow-tag.1
pre-build:
${RM} ${WRKSRC}/src/ftbuild.h
diff --git a/net-mgmt/flow-tools/distinfo b/net-mgmt/flow-tools/distinfo
index 36614e151034..656764091ff2 100644
--- a/net-mgmt/flow-tools/distinfo
+++ b/net-mgmt/flow-tools/distinfo
@@ -1 +1 @@
-MD5 (flow-tools-0.56.tar.gz) = 86565c23d4bf145630fff881ba1ce78c
+MD5 (flow-tools-0.57.tar.gz) = 6b26d229d7fd74bf515b1513b573859a
diff --git a/net-mgmt/flow-tools/files/patch-docs_flow-tag b/net-mgmt/flow-tools/files/patch-docs_flow-tag
new file mode 100644
index 000000000000..b184553adbd9
--- /dev/null
+++ b/net-mgmt/flow-tools/files/patch-docs_flow-tag
@@ -0,0 +1,11 @@
+--- docs/flow-tag.1 Mon Apr 22 11:42:06 2002
++++ docs/flow-tag.1 Mon Apr 22 11:42:43 2002
+@@ -189,7 +189,7 @@
+ .fi
+ .PP
+ .PP
+-First populate \fB/var/ft/sym/tags\fP for \fBflow-stat\fP to use as symbols\&.
++First populate \fB/usr/local/etc/flow-tools/tag_defs\fP for \fBflow-stat\fP to use as symbols\&.
+ .PP
+ .nf
+ \f(CW0x0001 OSU
diff --git a/net-mgmt/flow-tools/files/patch-ftfile.c b/net-mgmt/flow-tools/files/patch-ftfile.c
deleted file mode 100644
index d9863d07eda6..000000000000
--- a/net-mgmt/flow-tools/files/patch-ftfile.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/ftfile.c Tue Apr 24 14:07:18 2001
-+++ lib/ftfile.c Tue Apr 16 16:52:49 2002
-@@ -449,7 +449,7 @@
- } else if (nest == -2) {
- sprintf(dbuf, "%2.2d-%2.2d/%2.2d-%2.2d-%2.2d/",
- (int)tm->tm_year+1900, (int)tm->tm_mon+1,
-- (int)tm->tm_year+1900, (int)tm->tm_mon+1, (int)tm->tm_mon+1);
-+ (int)tm->tm_year+1900, (int)tm->tm_mon+1, (int)tm->tm_mday);
- } else if (nest == -1) {
- sprintf(dbuf, "%2.2d/%2.2d-%2.2d/%2.2d-%2.2d-%2.2d/",
- (int)tm->tm_year+1900,
diff --git a/net-mgmt/flow-tools/files/patch-ftpaths.h b/net-mgmt/flow-tools/files/patch-ftpaths.h
index e3619a6d6828..10b66b70d0ff 100644
--- a/net-mgmt/flow-tools/files/patch-ftpaths.h
+++ b/net-mgmt/flow-tools/files/patch-ftpaths.h
@@ -1,19 +1,21 @@
---- lib/ftpaths.h.in Tue Jul 17 09:51:05 2001
-+++ lib/ftpaths.h.in Sat Jan 12 06:28:15 2002
-@@ -29,11 +29,11 @@
+--- lib/ftpaths.h.in Sun Apr 21 04:08:41 2002
++++ lib/ftpaths.h.in Mon Apr 22 11:29:07 2002
+@@ -29,12 +29,12 @@
#ifndef FTPATHS_H
#define FTPATHS_H
--#define FT_FILE_MAP "@localstatedir@/cfg/map"
+-#define FT_PATH_MAP "@localstatedir@/cfg/map"
+#define FT_FILE_MAP "@localstatedir@/etc/flow-tools/map"
--#define FT_FILE_IP_PROT "@localstatedir@/sym/ip-prot"
--#define FT_FILE_IP_CLASS "@localstatedir@/sym/ip-class"
--#define FT_FILE_TCP_PORT "@localstatedir@/sym/tcp-port"
--#define FT_FILE_ASN "@localstatedir@/sym/asn"
-+#define FT_FILE_IP_PROT "@localstatedir@/share/flow-tools/ip-prot"
-+#define FT_FILE_IP_CLASS "@localstatedir@/share/flow-tools/ip-class"
-+#define FT_FILE_TCP_PORT "@localstatedir@/share/flow-tools/tcp-port"
-+#define FT_FILE_ASN "@localstatedir@/share/flow-tools/asn"
+-#define FT_PATH_IP_PROT "@localstatedir@/sym/ip-prot"
+-#define FT_PATH_IP_CLASS "@localstatedir@/sym/ip-class"
+-#define FT_PATH_TCP_PORT "@localstatedir@/sym/tcp-port"
+-#define FT_PATH_ASN "@localstatedir@/sym/asn"
+-#define FT_PATH_TAG "@localstatedir@/cfg/tag_defs"
++#define FT_PATH_IP_PROT "@localstatedir@/share/flow-tools/ip-prot"
++#define FT_PATH_IP_CLASS "@localstatedir@/share/flow-tools/ip-class"
++#define FT_PATH_TCP_PORT "@localstatedir@/share/flow-tools/tcp-port"
++#define FT_PATH_ASN "@localstatedir@/share/flow-tools/asn"
++#define FT_PATH_TAG "@localstatedir@/etc/flow-tools/tag_defs"
#endif /* FTPATHS_H */
diff --git a/net-mgmt/flow-tools/pkg-plist b/net-mgmt/flow-tools/pkg-plist
index 5cad13f112c8..cc86af83ba5a 100644
--- a/net-mgmt/flow-tools/pkg-plist
+++ b/net-mgmt/flow-tools/pkg-plist
@@ -21,6 +21,12 @@ bin/flow-tag
bin/flow-xlate
etc/flow-tools/map
etc/flow-tools/filter-acl
+include/ftconfig.h
+include/ftlib.h
+include/ftpaths.h
+include/ftqueue.h
+include/radix.h
+lib/libft.a
share/flow-tools/asn
share/flow-tools/ip-prot
share/flow-tools/tcp-port