aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/pmacct/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 7bef041f12a2..7c675b5dbaf7 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -22,8 +22,8 @@ USE_REINPLACE= yes
OPTIONS= MYSQL "Enable MySQL support." Off \
PGSQL "Enable PostgreSQL support." Off \
- MMAP "Disable mmap(2) support." Off \
- LAYER2 "Disable Layer-2 support: MAC Adresses and VLANs" Off
+ MMAP "Enable mmap(2) support." On \
+ LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" On
.include <bsd.port.pre.mk>
@@ -46,15 +46,15 @@ PLIST_SUB+= WITH_PGSQL="@comment "
.endif
.if defined(WITHOUT_MMAP)
-CONFIGURE_ARGS+=--enable-mmap
-.else
CONFIGURE_ARGS+=--disable-mmap
+.else
+CONFIGURE_ARGS+=--enable-mmap
.endif
.if defined(WITHOUT_LAYER2)
-CONFIGURE_ARGS+=--enable-l2
-.else
CONFIGURE_ARGS+=--disable-l2
+.else
+CONFIGURE_ARGS+=--enable-l2
.endif
post-patch: