aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios/Makefile2
-rw-r--r--net-mgmt/nagios/files/patch-html_includes_rss_parse.inc11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index c821b3431437..9bb06d45d3e4 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios
PORTVERSION= 3.5.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-3.x/${PORTNAME}-${PORTVERSION}
diff --git a/net-mgmt/nagios/files/patch-html_includes_rss_parse.inc b/net-mgmt/nagios/files/patch-html_includes_rss_parse.inc
new file mode 100644
index 000000000000..06215c2541b0
--- /dev/null
+++ b/net-mgmt/nagios/files/patch-html_includes_rss_parse.inc
@@ -0,0 +1,11 @@
+--- html/includes/rss/rss_parse.inc.orig 2017-12-21 16:55:41.032397000 +0100
++++ html/includes/rss/rss_parse.inc 2017-12-21 16:57:40.079068000 +0100
+@@ -150,7 +150,7 @@
+ // check for a namespace, and split if found
+ $ns = false;
+ if ( strpos( $element, ':' ) ) {
+- list($ns, $el) = split( ':', $element, 2);
++ list($ns, $el) = explode( ':', $element, 2);
+ }
+ if ( $ns and $ns != 'rdf' ) {
+ $this->current_namespace = $ns;