aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/argus3-clients/Makefile2
-rw-r--r--net-mgmt/gps/Makefile2
-rw-r--r--net-mgmt/icinga2/Makefile1
-rw-r--r--net-mgmt/nagiosgraph/Makefile1
-rw-r--r--net-mgmt/p5-SNMP_Session/Makefile2
-rw-r--r--net-mgmt/pancho/Makefile2
-rw-r--r--net-mgmt/sx/Makefile2
7 files changed, 9 insertions, 3 deletions
diff --git a/net-mgmt/argus3-clients/Makefile b/net-mgmt/argus3-clients/Makefile
index 28066bae8ad2..f917a368e84e 100644
--- a/net-mgmt/argus3-clients/Makefile
+++ b/net-mgmt/argus3-clients/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
CONFLICTS= argus-clients-2* argus-clients-sasl-2*
-OPTIONS_DEFINE= GEOIP MYSQL SASL
+OPTIONS_DEFINE= GEOIP MYSQL SASL DOCS
OPTIONS_DEFAULT=MYSQL SASL
USES= bison ncurses perl5
diff --git a/net-mgmt/gps/Makefile b/net-mgmt/gps/Makefile
index 2cf32cf55c5d..ed262390e664 100644
--- a/net-mgmt/gps/Makefile
+++ b/net-mgmt/gps/Makefile
@@ -20,6 +20,8 @@ USES= gmake
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e \
's|-Wall -O3|${CFLAGS}|; \
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index cee66e553a9a..14163313812b 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -20,6 +20,7 @@ USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
+OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND= MYSQL PGSQL
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
index ae67d4a43947..ebc7e0f587a2 100644
--- a/net-mgmt/nagiosgraph/Makefile
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -12,6 +12,7 @@ COMMENT= Generate rrdtool graphs using performance data from nagios plugins
RUN_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool
+OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= NAGIOS
OPTIONS_SINGLE_NAGIOS= NAGIOS35 NAGIOS4
OPTIONS_DEFAULT= NAGIOS35
diff --git a/net-mgmt/p5-SNMP_Session/Makefile b/net-mgmt/p5-SNMP_Session/Makefile
index 41ab741c72c7..6eac1eb9f2f1 100644
--- a/net-mgmt/p5-SNMP_Session/Makefile
+++ b/net-mgmt/p5-SNMP_Session/Makefile
@@ -17,7 +17,7 @@ USE_PERL5= configure
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
${RM} ${WRKSRC}/lib/SNMP_Session.pm.orig
diff --git a/net-mgmt/pancho/Makefile b/net-mgmt/pancho/Makefile
index 2c47d3d3629e..e875f911e051 100644
--- a/net-mgmt/pancho/Makefile
+++ b/net-mgmt/pancho/Makefile
@@ -20,6 +20,8 @@ USE_PERL5= configure
DOCS= README README.plugins Plugin.sample
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${MV} ${WRKSRC}/lib/Pancho/Plugins/README ${WRKSRC}/README.plugins
@${MV} ${WRKSRC}/lib/Pancho/Plugins/Plugin.sample ${WRKSRC}/
diff --git a/net-mgmt/sx/Makefile b/net-mgmt/sx/Makefile
index 6108b78488f9..dc91ff9dad05 100644
--- a/net-mgmt/sx/Makefile
+++ b/net-mgmt/sx/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" --prefix="${STAGE}${PREFIX}" \
--sysconfdir="${ETCDIR}"
-OPTIONS_DEFINE= SXSERVER
+OPTIONS_DEFINE= SXSERVER DOCS
SXSERVER_DESC= Enable sxhttpd server
OPTIONS_DEFAULT=SXSERVER