aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/cardano-node/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/cardano-node/Makefile')
-rw-r--r--net-p2p/cardano-node/Makefile316
1 files changed, 159 insertions, 157 deletions
diff --git a/net-p2p/cardano-node/Makefile b/net-p2p/cardano-node/Makefile
index db79d2e17589..0fc1df9adc26 100644
--- a/net-p2p/cardano-node/Makefile
+++ b/net-p2p/cardano-node/Makefile
@@ -1,7 +1,7 @@
PORTNAME= cardano-node
-PORTVERSION= 8.7.3
+PORTVERSION= 8.9.2
CATEGORIES= net-p2p
-MASTER_SITES= https://input-output-hk.github.io/cardano-haskell-packages/package/:chap
+MASTER_SITES= https://chap.intersectmbo.org/package/:chap
MAINTAINER= arrowd@FreeBSD.org
COMMENT= Core component of the Cardano decentralized blockchain
@@ -22,11 +22,11 @@ RUN_DEPENDS= ${LOCALBASE}/share/rc-subr-jail/rc.subr.jail:ports-mgmt/rc-subr-jai
USES= autoreconf:build cabal gmake libtool pkgconfig
USE_GITHUB= yes
-GH_ACCOUNT= input-output-hk
+GH_ACCOUNT= IntersectMBO
-GH_TUPLE= input-output-hk:libsodium:${LIBSODIUM_HASH}:sodium
+GH_TUPLE= IntersectMBO:libsodium:${LIBSODIUM_HASH}:sodium
-CARDANO_NODE_HASH= a4a8119b59b1fbb9a69c79e1e6900e91292161e7
+CARDANO_NODE_HASH= 424983fa186786397f5a99539f51710abf62c37b
LIBSODIUM_HASH= dbb48cce5429cb6585c9034f002568964f1ce567
USE_RC_SUBR= cardano_node
@@ -44,6 +44,7 @@ USE_CABAL= Cabal-3.10.2.1_1 \
HUnit-1.6.2.0 \
Histogram-0.1.0.2 \
HsOpenSSL-0.11.7.6_1 \
+ MemoTrie-0.6.11 \
MonadRandom-0.6_4 \
OneTuple-0.4.1.1_1 \
Only-0.1_2 \
@@ -59,7 +60,7 @@ USE_CABAL= Cabal-3.10.2.1_1 \
aeson-2.2.1.0_1 \
aeson-pretty-0.8.10 \
algebraic-graphs-0.7_2 \
- ansi-terminal-1.0 \
+ ansi-terminal-1.0.2 \
ansi-terminal-types-0.11.5_1 \
ansi-wl-pprint-0.6.9_4 \
ap-normalize-0.1.0.1 \
@@ -68,15 +69,15 @@ USE_CABAL= Cabal-3.10.2.1_1 \
asn1-parse-0.9.5 \
asn1-types-0.3.4 \
assoc-1.1_1 \
- async-2.2.4_4 \
+ async-2.2.5_1 \
async-extras-0.1.3.2 \
async-timer-0.1.4.1 \
- atomic-primops-0.8.4 \
+ atomic-primops-0.8.5 \
attoparsec-0.14.4_5 \
attoparsec-aeson-2.2.0.1 \
attoparsec-iso8601-1.1.0.1 \
auto-update-0.1.6 \
- barbies-2.0.5.0 \
+ barbies-2.1.1.0 \
base-compat-0.13.1 \
base-compat-batteries-0.13.1 \
base-deriving-via-0.1.0.2:chap \
@@ -86,58 +87,58 @@ USE_CABAL= Cabal-3.10.2.1_1 \
base64-bytestring-1.2.1.0_1 \
base64-bytestring-type-1.0.1_19 \
basement-0.0.16 \
- bech32-1.1.4.1:chap \
- bifunctors-5.6.1_2 \
+ bech32-1.1.5 \
+ bifunctors-5.6.2 \
bimap-0.5.0 \
bin-0.1.3_1 \
binary-orphans-1.0.4.1_3 \
- bitvec-1.1.5.0 \
+ bitvec-1.1.5.0_1 \
blaze-builder-0.4.2.3 \
- blaze-html-0.9.1.2_4 \
+ blaze-html-0.9.2.0 \
blaze-markup-0.8.3.0_1 \
boring-0.2.1_1 \
- brick-2.1.1 \
+ brick-2.3.1 \
bsb-http-chunked-0.0.0.4_4 \
- byron-spec-chain-1.0.0.1:chap \
- byron-spec-ledger-1.0.0.1:chap \
+ byron-spec-chain-1.0.0.2:chap \
+ byron-spec-ledger-1.0.0.2:chap \
byteorder-1.0.4 \
bytestring-builder-0.10.8.2.0 \
+ bytestring-strict-builder-0.4.5.7 \
cabal-doctest-1.0.9_3 \
call-stack-0.4.0 \
canonical-json-0.6.0.1_1 \
- cardano-api-8.36.1.1:chap \
+ cardano-api-8.39.3.0_1:chap \
cardano-binary-1.7.1.0:chap \
- cardano-cli-8.17.0.0:chap \
+ cardano-cli-8.20.3.0:chap \
cardano-crypto-1.1.2:chap \
cardano-crypto-class-2.1.4.0:chap \
cardano-crypto-praos-2.1.2.0:chap \
- cardano-crypto-test-1.5.0.0:chap \
+ cardano-crypto-test-1.5.0.1:chap \
cardano-crypto-tests-2.1.2.0:chap \
- cardano-crypto-wrapper-1.5.1.0:chap \
- cardano-data-1.1.2.0:chap \
- cardano-ledger-allegra-1.2.5.0:chap \
- cardano-ledger-alonzo-1.5.1.0:chap \
- cardano-ledger-alonzo-test-1.1.2.7:chap \
- cardano-ledger-api-1.7.0.1:chap \
- cardano-ledger-babbage-1.5.1.0:chap \
- cardano-ledger-babbage-test-1.1.1.8:chap \
- cardano-ledger-binary-1.2.1.0:chap \
- cardano-ledger-byron-1.0.0.3:chap \
- cardano-ledger-byron-test-1.5.0.0:chap \
- cardano-ledger-conway-1.11.0.0:chap \
- cardano-ledger-conway-test-1.2.1.2:chap \
- cardano-ledger-core-1.9.0.0:chap \
- cardano-ledger-mary-1.4.0.0:chap \
- cardano-ledger-pretty-1.3.3.1:chap \
- cardano-ledger-shelley-1.8.0.0:chap \
- cardano-ledger-shelley-ma-test-1.2.1.5:chap \
- cardano-ledger-shelley-test-1.3.0.0:chap \
- cardano-ping-0.2.0.10:chap \
+ cardano-crypto-wrapper-1.5.1.1:chap \
+ cardano-data-1.2.1.0:chap \
+ cardano-ledger-allegra-1.3.0.0:chap \
+ cardano-ledger-alonzo-1.6.0.0:chap \
+ cardano-ledger-alonzo-test-1.2.0.0:chap \
+ cardano-ledger-api-1.8.0.0:chap \
+ cardano-ledger-babbage-1.6.0.0:chap \
+ cardano-ledger-babbage-test-1.2.0.0:chap \
+ cardano-ledger-binary-1.3.0.0:chap \
+ cardano-ledger-byron-1.0.0.4:chap \
+ cardano-ledger-byron-test-1.5.0.1:chap \
+ cardano-ledger-conway-1.12.0.0:chap \
+ cardano-ledger-conway-test-1.2.1.3:chap \
+ cardano-ledger-core-1.10.0.0:chap \
+ cardano-ledger-mary-1.5.0.0:chap \
+ cardano-ledger-shelley-1.9.0.0:chap \
+ cardano-ledger-shelley-ma-test-1.2.1.6:chap \
+ cardano-ledger-shelley-test-1.3.0.1:chap \
+ cardano-ping-0.2.0.13:chap \
cardano-prelude-0.1.0.4:chap \
cardano-prelude-test-0.1.0.2:chap \
- cardano-protocol-tpraos-1.0.3.7:chap \
+ cardano-protocol-tpraos-1.1.0.0:chap \
cardano-slotting-0.1.2.0:chap \
- cardano-strict-containers-0.1.2.1:chap \
+ cardano-strict-containers-0.1.3.0:chap \
case-insensitive-1.2.1.0 \
cassava-0.5.3.0_5 \
cborg-0.2.10.0 \
@@ -152,9 +153,9 @@ USE_CABAL= Cabal-3.10.2.1_1 \
concurrent-output-1.10.20 \
conduit-1.3.5 \
conduit-extra-1.3.6 \
- config-ini-0.2.7.0 \
+ config-ini-0.2.7.0_1 \
connection-0.3.1_2 \
- constraints-0.13.4_1 \
+ constraints-0.14 \
constraints-extras-0.4.0.0_2 \
contra-tracer-0.1.0.2:chap \
contravariant-1.5.5 \
@@ -164,9 +165,9 @@ USE_CABAL= Cabal-3.10.2.1_1 \
crypton-0.34 \
crypton-x509-1.7.6_1 \
cryptonite-0.30 \
- data-accessor-0.2.3.1 \
+ data-accessor-0.2.3.1_1 \
data-accessor-transformers-0.2.1.8 \
- data-array-byte-0.1.0.1_2 \
+ data-array-byte-0.1.0.1_3 \
data-clist-0.2_1 \
data-default-0.7.1.1 \
data-default-class-0.1.2.0 \
@@ -175,28 +176,27 @@ USE_CABAL= Cabal-3.10.2.1_1 \
data-default-instances-old-locale-0.0.1 \
data-fix-0.3.2_5 \
dec-0.0.5_2 \
- deferred-folds-0.9.18.5 \
+ deferred-folds-0.9.18.6 \
dense-linear-algebra-0.1.0.0 \
dependent-map-0.4.0.0_1 \
dependent-sum-0.7.2.0_2 \
- dependent-sum-template-0.1.1.1.0.0.0.1:chap \
deque-0.4.4.1 \
deriving-aeson-0.2.9_1 \
- deriving-compat-0.6.5_1 \
+ deriving-compat-0.6.6 \
dictionary-sharing-0.1.0.0_3 \
- digest-0.0.1.7_1 \
+ digest-0.0.2.1 \
distributive-0.6.2.1_1 \
dlist-1.0_1 \
- dns-3.0.4_1 \
+ dns-4.2.0 \
doctest-0.22.2 \
dom-lt-0.2.3 \
- double-conversion-2.0.4.2_2 \
+ double-conversion-2.0.5.0 \
easy-file-0.2.5 \
ede-0.3.3.0 \
either-5.0.2_1 \
ekg-0.4.0.15.0.0.0.0.2:chap \
ekg-core-0.1.1.7.0.0.0.0.1:chap \
- ekg-forward-0.4_2:chap \
+ ekg-forward-0.5:chap \
ekg-json-0.1.0.7.0.0.0.0.2:chap \
entropy-0.4.1.10_1 \
erf-2.0.0.0 \
@@ -204,73 +204,75 @@ USE_CABAL= Cabal-3.10.2.1_1 \
extra-1.7.14 \
fast-logger-3.2.2 \
fgl-5.8.2.0 \
- file-embed-0.0.15.0 \
+ file-embed-0.0.16.0 \
filelock-0.1.1.7 \
fin-0.3_2 \
fingertree-0.1.5.0 \
flat-0.6 \
foldable1-classes-compat-0.1_4 \
- foldl-1.4.15_1 \
+ foldl-1.4.16 \
formatting-7.2.0 \
foundation-0.0.30 \
- free-5.2_3 \
- fs-api-0.2.0.1:chap \
- fs-sim-0.2.1.1:chap \
- generic-data-1.1.0.0_1 \
+ free-5.2_4 \
+ fs-api-0.2.0.1_1:chap \
+ fs-sim-0.2.1.1_1:chap \
+ generic-data-1.1.0.0_2 \
generic-monoid-0.1.0.1_3 \
generic-random-1.5.0.1 \
generically-0.1.1_2 \
- generics-sop-0.5.1.3 \
+ generics-sop-0.5.1.4 \
genvalidity-1.1.0.0 \
ghc-paths-0.1.0.12_5 \
githash-0.1.7.0 \
- gnuplot-0.5.7_1 \
- graphviz-2999.20.1.0_3 \
+ gnuplot-0.5.7_2 \
+ graphviz-2999.20.2.0 \
groups-0.5.3 \
half-0.3.1_1 \
happy-1.20.1.1 \
hashable-1.4.3.0_1 \
haskell-lexer-1.1.1 \
heapwords-0.1.0.2:chap \
- hedgehog-1.4_1 \
- hedgehog-extras-0.4.7.1_1 \
+ hedgehog-1.4_5 \
+ hedgehog-extras-0.6.1.0 \
hedgehog-quickcheck-0.1.1_6 \
hostname-1.0 \
hourglass-0.2.12 \
- hsc2hs-0.68.10_1 \
+ hsc2hs-0.68.10_2 \
hspec-2.11.7 \
hspec-core-2.11.7 \
hspec-discover-2.11.7 \
hspec-expectations-0.8.4_2 \
- http-api-data-0.5.1 \
- http-client-0.7.15 \
+ http-api-data-0.6_1 \
+ http-client-0.7.17 \
http-client-tls-0.3.6.1 \
http-conduit-2.3.8.3 \
http-date-0.0.11 \
http-media-0.8.1.1_1 \
- http-types-0.12.3 \
- http2-4.2.2 \
+ http-types-0.12.4 \
+ http2-5.0.1 \
indexed-traversable-0.1.3 \
indexed-traversable-instances-0.1.1.2_2 \
- infinite-list-0.1 \
+ infinite-list-0.1.1 \
integer-conversion-0.1.0.1_1 \
- integer-logarithms-1.0.3.1_5 \
- invariant-0.6.2_1 \
- io-classes-1.3.1.0 \
- io-classes-mtl-0.1.0.2 \
- io-sim-1.3.1.0_1 \
- io-streams-1.5.2.2_3 \
+ integer-logarithms-1.0.3.1_6 \
+ invariant-0.6.3 \
+ io-classes-1.4.1.0 \
+ io-classes-mtl-0.1.1.0 \
+ io-sim-1.4.1.0 \
+ io-streams-1.5.2.2_4 \
io-streams-haproxy-1.0.1.0_8 \
- iohk-monitoring-0.1.11.3:chap \
+ iohk-monitoring-0.1.11.4:chap \
iproute-1.7.12 \
- isomorphism-class-0.1.0.11 \
+ isomorphism-class-0.1.0.12 \
js-chart-2.9.4.1 \
kan-extensions-5.2.5_2 \
- katip-0.8.7.4 \
+ katip-0.8.8.0 \
lazy-search-0.1.3.0 \
lazysmallcheck-0.6 \
- lens-5.2.3_2 \
- libyaml-0.1.2_1 \
+ lens-5.2.3_4 \
+ lens-aeson-1.2.3_2 \
+ libyaml-0.1.4 \
+ libyaml-clib-0.2.5 \
lifted-async-0.10.2.5 \
lifted-base-0.2.3.12 \
list-t-1.0.5.7 \
@@ -278,11 +280,8 @@ USE_CABAL= Cabal-3.10.2.1_1 \
lobemo-backend-ekg-0.1.0.1:chap \
lobemo-backend-monitoring-0.1.0.0:chap \
lobemo-backend-trace-forwarder-0.1.0.0:chap \
- logict-0.8.1.0 \
- loop-0.3.0 \
- markov-chain-usage-model-0.0.0 \
+ logict-0.8.1.0_1 \
math-functions-0.3.4.3 \
- matrix-0.3.6.3 \
measures-0.1.0.2:chap \
megaparsec-9.2.1_1 \
memory-0.18.0 \
@@ -294,103 +293,105 @@ USE_CABAL= Cabal-3.10.2.1_1 \
mime-types-0.1.2.0 \
mmorph-1.2.0_3 \
monad-control-1.0.3.1 \
- mono-traversable-1.0.15.3 \
+ mono-traversable-1.0.17.0 \
monoidal-containers-0.6.4.0_2 \
- monoidal-synchronisation-0.1.0.4:chap \
+ monoidal-synchronisation-0.1.0.5:chap \
mtl-compat-0.2.2 \
multiset-0.3.4.3_1 \
mwc-random-0.15.0.2_1 \
network-3.1.4.0_1 \
network-bsd-2.8.1.0_5 \
network-byte-order-0.1.7 \
- network-mux-0.4.4.0:chap \
+ network-control-0.0.2 \
+ network-mux-0.4.5.1:chap \
network-uri-2.6.4.2_1 \
newtype-0.2.2.0_3 \
+ newtype-generics-0.6.2_2 \
non-integral-1.0.0.0:chap \
nonempty-vector-0.2.3_1 \
- nothunks-0.1.4_1 \
+ nothunks-0.1.5 \
old-locale-1.0.0.7_2 \
- old-time-1.1.0.3_2 \
+ old-time-1.1.0.4 \
openssl-streams-1.2.3.0_2 \
optparse-applicative-0.18.1.0 \
optparse-applicative-fork-0.18.1.0:chap \
- optparse-generic-1.5.2 \
- ouroboros-consensus-0.14.0.0:chap \
- ouroboros-consensus-cardano-0.12.1.0:chap \
- ouroboros-consensus-diffusion-0.9.0.0_2:chap \
- ouroboros-consensus-protocol-0.6.0.0_1:chap \
- ouroboros-network-0.10.2.1:chap \
- ouroboros-network-api-0.6.2.0:chap \
- ouroboros-network-framework-0.10.2.0:chap \
- ouroboros-network-mock-0.1.1.0:chap \
- ouroboros-network-protocols-0.6.1.0:chap \
- ouroboros-network-testing-0.4.1.0:chap \
- parallel-3.2.2.0_7 \
- parsec-3.1.17.0 \
+ optparse-generic-1.5.2_1 \
+ ouroboros-consensus-0.16.0.0_1:chap \
+ ouroboros-consensus-cardano-0.14.1.0_1:chap \
+ ouroboros-consensus-diffusion-0.14.0.0:chap \
+ ouroboros-consensus-protocol-0.7.0.0_1:chap \
+ ouroboros-network-0.14.0.0:chap \
+ ouroboros-network-api-0.7.1.0:chap \
+ ouroboros-network-framework-0.12.0.0:chap \
+ ouroboros-network-mock-0.1.1.1:chap \
+ ouroboros-network-protocols-0.8.1.0:chap \
+ ouroboros-network-testing-0.6.0.0:chap \
+ parallel-3.2.2.0_8 \
+ parsec-3.1.17.0_1 \
parser-combinators-1.3.0_1 \
parsers-0.12.11_2 \
partial-order-0.2.0.0 \
pem-0.2.4 \
pipes-4.3.16_6 \
- plutus-core-1.15.0.1:chap \
- plutus-ledger-api-1.15.0.1:chap \
- plutus-tx-1.15.0.1:chap \
+ plutus-core-1.21.0.0:chap \
+ plutus-ledger-api-1.21.0.0:chap \
+ plutus-tx-1.21.0.0:chap \
polyparse-1.13_9 \
pretty-show-1.10 \
pretty-simple-4.1.2.0 \
prettyprinter-1.7.1 \
prettyprinter-ansi-terminal-1.1.3 \
- prettyprinter-configurable-1.15.0.0:chap \
- primitive-0.8.0.0_1 \
+ prettyprinter-configurable-1.21.0.0:chap \
+ primitive-0.9.0.0_1 \
profunctors-5.6.2_3 \
- prometheus-2.2.4 \
- protolude-0.3.3.0.0.0.0.1:chap \
+ prometheus-2.2.4_1 \
+ protolude-0.3.4 \
psqueues-0.2.8.0 \
quickcheck-instances-0.3.30_1 \
quickcheck-io-0.2.0 \
- quickcheck-state-machine-0.7.3 \
+ quickcheck-state-machine-0.9.0 \
quickcheck-transformer-0.3.1.2 \
quiet-0.2 \
ral-0.2.1_3 \
- random-1.2.1.1_1 \
+ random-1.2.1.2 \
random-shuffle-0.0.4 \
readable-0.3.1_2 \
- recursion-schemes-5.2.2.5 \
+ recursion-schemes-5.2.2.5_1 \
recv-0.1.0 \
reducers-3.12.4_6 \
reflection-2.1.7_1 \
regex-base-0.94.0.2_4 \
regex-posix-0.96.0.1_3 \
resourcet-1.3.0 \
- safe-0.3.19 \
+ safe-0.3.21_1 \
safe-exceptions-0.1.7.4_1 \
scientific-0.3.7.0_7 \
selective-0.6_1 \
semialign-1.3_1 \
semigroupoids-6.0.0.1_1 \
semigroups-0.20 \
- serialise-0.2.6.1_1 \
+ serialise-0.2.6.1_2 \
servant-0.20.1_2 \
servant-server-0.20_4 \
- set-algebra-1.1.0.1:chap \
+ set-algebra-1.1.0.2:chap \
show-combinators-0.2.0.0_2 \
- si-timers-1.3.0.0 \
+ si-timers-1.4.0.0 \
signal-0.1.0.4 \
simple-sendfile-0.2.32 \
singleton-bool-0.1.7_1 \
size-based-0.1.3.2 \
- small-steps-1.0.0.0:chap \
- small-steps-test-1.0.0.1:chap \
+ small-steps-1.0.1.0:chap \
+ small-steps-test-1.0.1.0:chap \
smtp-mail-0.3.0.0 \
snap-blaze-0.2.1.5 \
- snap-core-1.0.5.1_3 \
+ snap-core-1.0.5.1_4 \
snap-server-1.1.2.1_3 \
socks-0.6.1 \
some-1.0.6 \
sop-core-0.5.0.2_3 \
sop-extras-0.1.0.0:chap \
- split-0.2.4 \
- splitmix-0.1.0.5 \
+ split-0.2.5 \
+ splitmix-0.1.0.5_1 \
statistics-0.16.2.1 \
statistics-linreg-0.3 \
streaming-0.2.4.0 \
@@ -398,19 +399,19 @@ USE_CABAL= Cabal-3.10.2.1_1 \
streaming-bytestring-0.3.2 \
streaming-commons-0.2.2.6_1 \
strict-0.5_1 \
- strict-checked-vars-0.1.0.4_2:chap \
+ strict-checked-vars-0.2.0.0_1:chap \
strict-list-0.1.7.4 \
- strict-mvar-1.3.0.0 \
+ strict-mvar-1.4.0.0 \
strict-sop-core-0.1.0.0:chap \
- strict-stm-1.3.0.0 \
+ strict-stm-1.4.0.0 \
string-conv-0.2.0 \
string-conversions-0.4.0.1_1 \
- string-qq-0.0.5_1 \
+ string-qq-0.0.6 \
syb-0.7.2.4 \
system-filepath-0.4.14_2 \
- tagged-0.8.8 \
+ tagged-0.8.8_1 \
tar-0.5.1.1_10 \
- tasty-1.5_1 \
+ tasty-1.5_2 \
tasty-expected-failure-0.12.3 \
tasty-golden-2.3.5 \
tasty-hedgehog-1.4.0.2_3 \
@@ -428,17 +429,17 @@ USE_CABAL= Cabal-3.10.2.1_1 \
text-short-0.1.5_3 \
text-zipper-0.13 \
tf-random-0.5 \
- th-abstraction-0.5.0.0 \
- th-compat-0.1.4_4 \
- th-expand-syns-0.4.11.0_2 \
- th-extras-0.0.0.6.0.0.0.0.1:chap \
- th-lift-0.8.4 \
+ th-abstraction-0.6.0.0_2 \
+ th-compat-0.1.5 \
+ th-env-0.1.1 \
+ th-expand-syns-0.4.11.0_3 \
+ th-lift-0.8.4_2 \
th-lift-instances-0.1.20 \
th-orphans-0.13.14_2 \
th-reify-many-0.1.10 \
th-utilities-0.2.5.0 \
these-1.2_1 \
- threepenny-gui-0.9.4.0_4 \
+ threepenny-gui-0.9.4.1 \
time-compat-1.9.6.1_6 \
time-manager-0.0.1 \
time-units-1.0.0 \
@@ -447,45 +448,46 @@ USE_CABAL= Cabal-3.10.2.1_1 \
transformers-base-0.4.6 \
transformers-compat-0.7.2 \
transformers-except-0.1.4_1 \
- tree-diff-0.3.0.1_4 \
- trifecta-2.1.3_1 \
+ tree-diff-0.3.0.1_5 \
+ trifecta-2.1.4 \
type-equality-1_6 \
typed-process-0.2.11.1 \
- typed-protocols-0.1.1.0_1:chap \
+ typed-protocols-0.1.1.0_2:chap \
typed-protocols-cborg-0.1.0.4:chap \
typed-protocols-examples-0.2.0.2:chap \
unagi-chan-0.4.1.4 \
unbounded-delays-0.1.1.1 \
universe-base-1.1.3.1_1 \
- unix-bytestring-0.4.0_1 \
- unix-compat-0.7 \
- unix-time-0.4.11 \
+ unix-bytestring-0.4.0.1 \
+ unix-compat-0.7.1 \
+ unix-time-0.4.12 \
unliftio-0.2.25.0 \
unliftio-core-0.2.1.0_3 \
- unordered-containers-0.2.19.1_3 \
+ unordered-containers-0.2.20_1 \
utf8-string-1.0.2 \
- utility-ht-0.0.17_1 \
+ utility-ht-0.0.17.1 \
uuid-types-1.0.5.1 \
validation-selective-0.2.0.0.0.0.0.0.1:chap \
validity-0.12.0.2 \
- vault-0.3.1.5_5 \
- vector-0.13.1.0 \
- vector-algorithms-0.9.0.1.0.0.0.0.1_1:chap \
+ vault-0.3.1.5_6 \
+ vector-0.13.1.0_1 \
+ vector-algorithms-0.9.0.1_3 \
vector-binary-instances-0.2.5.2_5 \
- vector-map-1.0.1.0:chap \
- vector-stream-0.1.0.0_3 \
- vector-th-unbox-0.2.2_5 \
+ vector-map-1.1.0.0:chap \
+ vector-stream-0.1.0.1_1 \
+ vector-th-unbox-0.2.2_6 \
void-0.7.3 \
- vty-6.1_1 \
- vty-crossplatform-0.4.0.0 \
- vty-unix-0.2.0.0 \
- wai-3.2.3 \
- wai-app-static-3.1.8 \
- wai-extra-3.1.13.0_1 \
+ vty-6.0_1 \
+ vty-crossplatform-0.2.0.0_1 \
+ vty-unix-0.1.0.0_1 \
+ wai-3.2.4 \
+ wai-app-static-3.1.9 \
+ wai-extra-3.1.14 \
wai-logger-2.4.0 \
- warp-3.3.30 \
- websockets-0.12.7.3_2 \
- websockets-snap-0.10.3.1_1 \
+ warp-3.3.31 \
+ websockets-0.13.0.0 \
+ websockets-snap-0.10.3.1_2 \
+ with-utf8-1.1.0.0 \
witherable-0.4.2_4 \
wl-pprint-annotated-0.1.0.1_3 \
wl-pprint-text-1.2.0.2_2 \
@@ -496,7 +498,7 @@ USE_CABAL= Cabal-3.10.2.1_1 \
x509-system-1.6.7 \
x509-validation-1.6.12 \
yaml-0.11.11.2_2 \
- zlib-0.6.3.0_4 \
+ zlib-0.7.0.0_1 \
zlib-bindings-0.1.1.5_2
CABAL_PROJECT= append