aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/files/patch-setup.py')
-rw-r--r--net-p2p/deluge/files/patch-setup.py49
1 files changed, 17 insertions, 32 deletions
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
index e865b7a6f230..294f27b847e4 100644
--- a/net-p2p/deluge/files/patch-setup.py
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2010-01-10 06:16:08.000000000 +0900
-+++ setup.py 2010-01-13 16:48:06.000000000 +0900
-@@ -67,7 +67,6 @@
+--- setup.py.orig 2010-08-20 18:20:27.000000000 -0300
++++ setup.py 2010-08-21 16:49:05.000000000 -0300
+@@ -68,7 +68,6 @@
"-D_FILE_OFFSET_BITS=64",
"-DNDEBUG",
"-DTORRENT_USE_OPENSSL=1",
@@ -8,8 +8,8 @@
]
if windows_check():
-@@ -113,12 +112,14 @@
- sysconfig.get_config_vars()["OPT"] = " ".join(cv_opt.split())
+@@ -115,12 +114,14 @@
+ remove_from_cflags(removals)
_library_dirs = [
+ '%%LOCALBASE%%/lib'
@@ -24,7 +24,7 @@
]
if windows_check():
-@@ -140,14 +141,6 @@
+@@ -142,14 +143,6 @@
'zlib'
]
else:
@@ -39,7 +39,7 @@
if osx_check():
_include_dirs += [
'/opt/local/include/boost-1_35',
-@@ -161,7 +154,6 @@
+@@ -163,7 +156,6 @@
'boost_iostreams',
'boost_python',
'boost_thread',
@@ -47,39 +47,24 @@
'ssl',
'z'
]
-@@ -204,12 +196,6 @@
-
- # Check for a system libtorrent and if found, then do not build the libtorrent extension
- build_libtorrent = True
--try:
-- from deluge._libtorrent import lt
--except ImportError:
-- build_libtorrent = True
--else:
-- build_libtorrent = False
-
- if build_libtorrent and os.path.exists("libtorrent"):
- # There isn't a system libtorrent library, so let's build the one included with deluge
-@@ -219,6 +205,7 @@
- include_dirs = _include_dirs,
- libraries = _libraries,
- library_dirs = _library_dirs,
-+ extra_link_args = ['%%PTHREAD_LIBS%%'],
- sources = _sources
- )
+@@ -212,6 +204,7 @@
+ build_libtorrent = True
+ else:
+ build_libtorrent = False
++build_libtorrent = False
-@@ -356,8 +343,8 @@
+ if build_libtorrent:
+ got_libtorrent = False
+@@ -392,8 +385,6 @@
for cmd_name in self.get_sub_commands():
self.run_command(cmd_name)
_install.run(self)
- if not self.root:
- self.do_egg_install()
-+# if not self.root:
-+# self.do_egg_install()
cmdclass = {
'build': build,
-@@ -371,7 +358,7 @@
+@@ -409,7 +400,7 @@
# Data files to be installed to the system
_data_files = [
@@ -88,7 +73,7 @@
('share/icons/hicolor/128x128/apps', ['deluge/data/icons/hicolor/128x128/apps/deluge.png']),
('share/icons/hicolor/16x16/apps', ['deluge/data/icons/hicolor/16x16/apps/deluge.png']),
('share/icons/hicolor/192x192/apps', ['deluge/data/icons/hicolor/192x192/apps/deluge.png']),
-@@ -386,7 +373,7 @@
+@@ -424,7 +415,7 @@
('share/icons/hicolor/96x96/apps', ['deluge/data/icons/hicolor/96x96/apps/deluge.png']),
('share/applications', ['deluge/data/share/applications/deluge.desktop']),
('share/pixmaps', ['deluge/data/pixmaps/deluge.png', 'deluge/data/pixmaps/deluge.xpm']),