aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/deluge/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/deluge/files')
-rw-r--r--net-p2p/deluge/files/patch-setup.py28
-rw-r--r--net-p2p/deluge/files/patch-src_deluge_core.cpp12
-rw-r--r--net-p2p/deluge/files/patch-src_delugegtk.py35
3 files changed, 75 insertions, 0 deletions
diff --git a/net-p2p/deluge/files/patch-setup.py b/net-p2p/deluge/files/patch-setup.py
new file mode 100644
index 000000000000..fe3f68d5c867
--- /dev/null
+++ b/net-p2p/deluge/files/patch-setup.py
@@ -0,0 +1,28 @@
+--- setup.py.orig Thu Mar 1 18:27:45 2007
++++ setup.py Fri Mar 2 18:38:43 2007
+@@ -44,7 +44,7 @@
+ #
+
+ removals = ['-g', '-DNDEBUG', '-O2', '-Wstrict-prototypes']
+-additions = ['-DNDEBUG', '-O2']
++additions = ['-DNDEBUG']
+
+ if pythonVersion == '2.5':
+ cv_opt = sysconfig.get_config_vars()["CFLAGS"]
+@@ -78,12 +78,14 @@
+ deluge_core = Extension('deluge_core',
+ include_dirs = ['./libtorrent', './libtorrent/include',
+ './libtorrent/include/libtorrent',
+- '/usr/include/python' + pythonVersion],
++ '%%LOCALBASE%%/include'],
++ library_dirs = ['%%LOCALBASE%%/lib'],
+ libraries = ['boost_filesystem', 'boost_date_time',
+ 'boost_program_options', 'boost_regex',
+ 'boost_serialization', 'boost_thread',
+- 'z', 'pthread'],
++ 'z'],
+ extra_compile_args = ["-Wno-missing-braces"],
++ extra_link_args = ['%%PTHREAD_LIBS%%'],
+ sources = ['src/deluge_core.cpp',
+ 'libtorrent/src/alert.cpp',
+ 'libtorrent/src/allocate_resources.cpp',
diff --git a/net-p2p/deluge/files/patch-src_deluge_core.cpp b/net-p2p/deluge/files/patch-src_deluge_core.cpp
new file mode 100644
index 000000000000..656a51348ced
--- /dev/null
+++ b/net-p2p/deluge/files/patch-src_deluge_core.cpp
@@ -0,0 +1,12 @@
+Index: /trunk/src/deluge_core.cpp
+===================================================================
+--- src/deluge_core.cpp (revision 205)
++++ src/deluge_core.cpp (revision 292)
+@@ -861,4 +861,7 @@
+ "pieces", py_pieces
+ );
++
++ Py_DECREF(py_pieces); // Assuming the previous line does NOT steal the ref, then this is
++ // needed!
+
+ PyTuple_SetItem(ret, i, peer_info);
diff --git a/net-p2p/deluge/files/patch-src_delugegtk.py b/net-p2p/deluge/files/patch-src_delugegtk.py
new file mode 100644
index 000000000000..f2d1cba3e84f
--- /dev/null
+++ b/net-p2p/deluge/files/patch-src_delugegtk.py
@@ -0,0 +1,35 @@
+Index: /trunk/src/delugegtk.py
+===================================================================
+--- src/delugegtk.py (revision 288)
++++ src/delugegtk.py (revision 289)
+@@ -695,6 +695,5 @@
+ self.wtree.get_widget("toolbutton_pause").set_stock_id(gtk.STOCK_MEDIA_PAUSE)
+ except KeyError:
+- pass
+- self.saved_peer_info = None
++ pass
+
+
+@@ -744,8 +743,5 @@
+ unique_id = self.get_selected_torrent()
+
+- self.saved_peer_info = self.manager.get_torrent_peer_info(unique_id)
+-
+-
+- new_peer_info = self.saved_peer_info
++ new_peer_info = self.manager.get_torrent_peer_info(unique_id)
+
+ new_ips = {}
+@@ -782,4 +778,12 @@
+ dcommon.frate(peer["download_speed"]),
+ dcommon.frate(peer["upload_speed"])])
++ #print new_ips
++ #print curr_ips
++ #print new_peer_info
++ del new_peer_info
++ del new_ips
++ del curr_ips
++
++
+
+ elif tab == 2: #File List