aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gkrellm-gift/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gkrellm-gift/Makefile')
-rw-r--r--net-p2p/gkrellm-gift/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/gkrellm-gift/Makefile b/net-p2p/gkrellm-gift/Makefile
new file mode 100644
index 000000000000..6c6e523db539
--- /dev/null
+++ b/net-p2p/gkrellm-gift/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gkrellm-gift
+# Date created: Mon May 3 08:48:47 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gift
+PORTVERSION= 0.2.2
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/gkrellm-gift/ \
+ http://depot.fsck.ch/mirror/distfiles/
+PKGNAMEPREFIX= gkrellm-
+DISTNAME= ${PKGNAMEPREFIX}giFT-${PORTVERSION}
+
+MAINTAINER= ports@fsck.ch
+COMMENT= GKrellM2 plugin that monitors active giFT transfers
+
+LIB_DEPENDS= gift.0:${PORTSDIR}/net/gift
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/libexec/gkrellm2/plugins/${PORTNAME}.so
+
+.include <bsd.port.mk>