aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/gnunet
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/Makefile137
-rw-r--r--net-p2p/gnunet/distinfo2
-rw-r--r--net-p2p/gnunet/files/patch-configure16
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_conf_Makefile.in23
-rw-r--r--net-p2p/gnunet/files/patch-src_include_gnunet__util.h25
-rw-r--r--net-p2p/gnunet/files/patch-src_server_Makefile.in14
-rw-r--r--net-p2p/gnunet/files/patch-src_transports_udp6.c21
-rw-r--r--net-p2p/gnunet/pkg-descr14
-rw-r--r--net-p2p/gnunet/pkg-plist72
17 files changed, 0 insertions, 436 deletions
diff --git a/net-p2p/gnunet/Makefile b/net-p2p/gnunet/Makefile
deleted file mode 100644
index ff16b3fb506a..000000000000
--- a/net-p2p/gnunet/Makefile
+++ /dev/null
@@ -1,137 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: GNUnet
-# Date created: Mar 23, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnunet
-PORTVERSION= 0.6.6b
-CATEGORIES= net
-MASTER_SITES= http://www.ovmj.org/GNUnet/download/ \
- ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= GNUnet-${PORTVERSION}
-
-MAINTAINER= krion@FreeBSD.org
-COMMENT= An anonymous, distributed, reputation-based network
-
-LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
-
-USE_LIBLTDL= yes
-USE_BZIP2= yes
-USE_GETOPT_LONG= yes
-USE_GETTEXT= yes
-USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 lthack
-USE_INC_LIBTOOL_VER=13
-USE_OPENSSL= yes
-USE_REINPLACE= yes
-
-INSTALLS_SHLIB= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ARGS= --disable-ltdl-install --with-crypto
-LDFLAGS+= -L${LOCALBASE}/lib
-
-.if defined(WITH_GDBM)
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
-PLIST_SUB+= WITH_GDBM=""
-.else
-CONFIGURE_ARGS+= --without-gdbm
-PLIST_SUB+= WITH_GDBM="@comment "
-.endif
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql
-.else
-CONFIGURE_ARGS+= --without-mysql
-.endif
-
-.if defined(WITH_TDB)
-LIB_DEPENDS+= tdb.1:${PORTSDIR}/databases/tdb
-PLIST_SUB+= WITH_TDB=""
-.else
-CONFIGURE_ARGS+= --without-tdb
-PLIST_SUB+= WITH_TDB="@comment "
-.endif
-
-.if defined(WITH_BDB3)
-LIB_DEPENDS+= db3:${PORTSDIR}/databases/db3
-CONFIGURE_ARGS+= --with-bdb=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-bdb
-.endif
-
-.if defined(WITH_SQLITE)
-LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
-CONFIGURE_ARGS+= --with-sqlite
-PLIST_SUB+= WITH_SQLITE=""
-.else
-CONFIGURE_ARGS+= --without-sqlite
-PLIST_SUB+= WITH_SQLITE="@comment "
-.endif
-
-.if defined(WITH_IPV6)
-PKGNAMESUFFIX= -ipv6
-CONFIGURE_ARGS+= --enable-ipv6
-PLIST_SUB+= WITH_IPV6=""
-.else
-PLIST_SUB+= WITH_IPV6="@comment "
-.endif
-
-.if defined(WITH_GUILE)
-LIB_DEPENDS+= guile.15:${PORTSDIR}/lang/guile
-CONFIGURE_ARGS+= --enable-guile
-MAN1+= gnunet-download-manager.1
-PLIST_SUB+= WITH_GUILE=""
-.else
-CONFIGURE_ARGS+= --disable-guile
-PLIST_SUB+= WITH_GUILE="@comment "
-.endif
-
-MAN1= gnunet-chat.1 gnunet-check.1 gnunet-convert.1 \
- gnunet-delete.1 gnunet-directory.1 \
- gnunet-download.1 gnunet-gtk.1 gnunet-insert.1 \
- gnunet-peer-info.1 gnunet-pseudonym.1 \
- gnunet-search.1 gnunet-stats.1 gnunet-tbench.1 \
- gnunet-testbed.1 gnunet-tracekit.1 gnunet-transport-check.1 \
- gnunet-update.1 gnunetd.1
-MAN5= gnunet.conf.5
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You can build GNUnet with the following options:"
- @${ECHO_MSG} " WITH_MYSQL=yes Turn on MySQL support"
- @${ECHO_MSG} " WITH_TDB=yes Turn on TDB support"
- @${ECHO_MSG} " WITH_BDB3=yes Turn on Berkely DB library support"
- @${ECHO_MSG} " WITH_GDBM=yes Turn on GNU dbm support"
- @${ECHO_MSG} " WITH_SQLITE=yes Turn on sqlite support"
- @${ECHO_MSG} " WITH_IPV6=yes Turn on to enable IPv6 support"
- @${ECHO_MSG} ""
-
-post-patch:
- @${FIND} ${WRKSRC} -name configure | ${XARGS} \
- ${REINPLACE_CMD} -e \
- 's|-pthread [\$$]CFLAGS|${PTHREAD_CFLAGS} \$$CFLAGS|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g'
- ${REINPLACE_CMD} -e \
- 's|^#include <values.h>|#include <limits.h>|g' \
- ${WRKSRC}/src/applications/afs/module/manager.c
- ${REINPLACE_CMD} -e \
- 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/src/include/gnunet_util.h
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/contrib/gnunet.root ${PREFIX}/etc/gnunet.conf-dist
-.ifndef(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/contrib/gnunet.user ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>
diff --git a/net-p2p/gnunet/distinfo b/net-p2p/gnunet/distinfo
deleted file mode 100644
index 180c3f89f5fe..000000000000
--- a/net-p2p/gnunet/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (GNUnet-0.6.6b.tar.bz2) = dc04ecf7d1e7d4ccfde62fad101a301f
-SIZE (GNUnet-0.6.6b.tar.bz2) = 1291441
diff --git a/net-p2p/gnunet/files/patch-configure b/net-p2p/gnunet/files/patch-configure
deleted file mode 100644
index 5934b64bc7d0..000000000000
--- a/net-p2p/gnunet/files/patch-configure
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Mon Aug 2 20:01:59 2004
-+++ configure Mon Aug 2 20:02:55 2004
-@@ -15035,8 +15035,8 @@
- echo "${ECHO_T}\"$with_mysql\"" >&6
- if test "$with_mysql" != "no"
- then
-- LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql $LDFLAGS $ZLIBS"
-- CPPFLAGS="-I$with_mysql/include $CPPFLAGS"
-+ LDFLAGS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql $LDFLAGS $ZLIBS"
-+ CPPFLAGS="-I${LOCALBASE}/include $CPPFLAGS"
-
- for ac_header in mysql/mysql.h
- do
diff --git a/net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in
deleted file mode 100644
index 8952e613bd82..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_afs_module_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/afs/module/Makefile.in.orig
-+++ src/applications/afs/module/Makefile.in
-@@ -203,7 +203,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(libgnunetafs_database_bdb_la_SOURCES) \
- $(libgnunetafs_database_directory_la_SOURCES) \
- $(libgnunetafs_database_gdbm_la_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in
deleted file mode 100644
index d9a2b848d970..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_afs_tools_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/afs/tools/Makefile.in.orig
-+++ src/applications/afs/tools/Makefile.in
-@@ -104,7 +104,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(gnunet_delete_SOURCES) $(gnunet_directory_SOURCES) \
- $(gnunet_download_SOURCES) $(gnunet_insert_SOURCES) \
- $(gnunet_pseudonym_SOURCES) $(gnunet_search_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in
deleted file mode 100644
index 9139ec802848..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_chat_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/chat/Makefile.in.orig
-+++ src/applications/chat/Makefile.in
-@@ -80,7 +80,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(libgnunetchat_protocol_la_SOURCES) $(gnunet_chat_SOURCES)
- DIST_SOURCES = $(libgnunetchat_protocol_la_SOURCES) \
- $(gnunet_chat_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in
deleted file mode 100644
index 6342016773f5..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_dht_tools_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/dht/tools/Makefile.in.orig
-+++ src/applications/dht/tools/Makefile.in
-@@ -84,7 +84,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(libgnunetdht_api_la_SOURCES) $(gnunet_dht_join_SOURCES) \
- $(gnunet_dht_query_SOURCES)
- DIST_SOURCES = $(libgnunetdht_api_la_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in
deleted file mode 100644
index 1134073ae1bf..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_stats_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/stats/Makefile.in.orig
-+++ src/applications/stats/Makefile.in
-@@ -71,7 +71,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(gnunet_stats_SOURCES)
- DIST_SOURCES = $(gnunet_stats_SOURCES)
- ETAGS = etags
diff --git a/net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in
deleted file mode 100644
index b3c0253bf1d6..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_tbench_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/tbench/Makefile.in.orig
-+++ src/applications/tbench/Makefile.in
-@@ -81,7 +81,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(libgnunettbench_protocol_la_SOURCES) \
- $(gnunet_tbench_SOURCES)
- DIST_SOURCES = $(libgnunettbench_protocol_la_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in
deleted file mode 100644
index 23b0ed59044f..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_testbed_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/testbed/Makefile.in.orig
-+++ src/applications/testbed/Makefile.in
-@@ -84,7 +84,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(libgnunettestbed_protocol_la_SOURCES) \
- $(gnunet_testbed_SOURCES)
- DIST_SOURCES = $(libgnunettestbed_protocol_la_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in b/net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in
deleted file mode 100644
index 5a089ab930ab..000000000000
--- a/net-p2p/gnunet/files/patch-src_applications_tracekit_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/applications/tracekit/Makefile.in.orig
-+++ src/applications/tracekit/Makefile.in
-@@ -81,7 +81,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(libgnunettracekit_protocol_la_SOURCES) \
- $(gnunet_tracekit_SOURCES)
- DIST_SOURCES = $(libgnunettracekit_protocol_la_SOURCES) \
diff --git a/net-p2p/gnunet/files/patch-src_conf_Makefile.in b/net-p2p/gnunet/files/patch-src_conf_Makefile.in
deleted file mode 100644
index 270399434142..000000000000
--- a/net-p2p/gnunet/files/patch-src_conf_Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- src/conf/Makefile.in.orig
-+++ src/conf/Makefile.in
-@@ -100,7 +100,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(gnunet_setup_SOURCES) gnunet-win-tool.c
- DIST_SOURCES = $(am__gnunet_setup_SOURCES_DIST) gnunet-win-tool.c
- ETAGS = etags
-@@ -312,7 +312,7 @@
- gnunet-setup.c
-
- gnunet_setup_LDFLAGS = \
-- $(curses_lib)
-+ $(curses_lib) $(LTLIBINTL)
-
- gnunet_setup_LDADD = \
- $(top_builddir)/src/util/libgnunetutil.la
diff --git a/net-p2p/gnunet/files/patch-src_include_gnunet__util.h b/net-p2p/gnunet/files/patch-src_include_gnunet__util.h
deleted file mode 100644
index 89867ccbfa46..000000000000
--- a/net-p2p/gnunet/files/patch-src_include_gnunet__util.h
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- src/include/gnunet_util.h.orig
-+++ src/include/gnunet_util.h
-@@ -637,7 +637,7 @@
- * Default names of the configuration files.
- */
- #define DEFAULT_CLIENT_CONFIG_FILE "~/.gnunet/gnunet.conf"
--#define DEFAULT_DAEMON_CONFIG_FILE "/etc/gnunet.conf"
-+#define DEFAULT_DAEMON_CONFIG_FILE "%%PREFIX%%/etc/gnunet.conf"
-
- /* *******************API *********************** */
-
-@@ -1053,8 +1053,8 @@
- * @param ip the IP to check (in network byte order)
- * @return NO if the IP is not in the list, YES if it it is
- */
--int checkIP6Listed(const CIDR6Network * list,
-- const IP6addr * ip);
-+int checkIP6Listed(CIDR6Network * list,
-+ IP6addr * ip);
-
- /**
- * Parse a network specification. The argument specifies
diff --git a/net-p2p/gnunet/files/patch-src_server_Makefile.in b/net-p2p/gnunet/files/patch-src_server_Makefile.in
deleted file mode 100644
index 15587ef6d6bd..000000000000
--- a/net-p2p/gnunet/files/patch-src_server_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/server/Makefile.in.orig
-+++ src/server/Makefile.in
-@@ -108,7 +108,7 @@
- $(AM_CFLAGS) $(CFLAGS)
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-+ $(AM_LDFLAGS) $(LDFLAGS) $(LTLIBINTL) -o $@
- SOURCES = $(fragmentationtest_SOURCES) $(gnunet_peer_info_SOURCES) \
- $(gnunet_transport_check_SOURCES) $(gnunet_update_SOURCES) \
- $(gnunetd_SOURCES)
diff --git a/net-p2p/gnunet/files/patch-src_transports_udp6.c b/net-p2p/gnunet/files/patch-src_transports_udp6.c
deleted file mode 100644
index bcab32ed46c0..000000000000
--- a/net-p2p/gnunet/files/patch-src_transports_udp6.c
+++ /dev/null
@@ -1,21 +0,0 @@
-
-$FreeBSD$
-
---- src/transports/udp6.c.orig
-+++ src/transports/udp6.c
-@@ -275,6 +275,7 @@
- #endif
- /* quick test of the packet, if failed, repeat! */
- if (size != ntohs(udp6m.size)) {
-+ char * tmp = MALLOC(INET6_ADDRSTRLEN);
- LOG(LOG_WARNING,
- _("Packed received from %s:%d (UDP6) failed format check."),
- inet_ntop(AF_INET6,
-@@ -282,6 +283,7 @@
- tmp,
- INET6_ADDRSTRLEN),
- ntohs(incoming.sin6_port));
-+ FREE(tmp);
- goto RETRY;
- }
- GNUNET_ASSERT(sizeof(struct in6_addr) == sizeof(IP6addr));
diff --git a/net-p2p/gnunet/pkg-descr b/net-p2p/gnunet/pkg-descr
deleted file mode 100644
index e79703470809..000000000000
--- a/net-p2p/gnunet/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-GNUnet is an anonymous, distributed, reputation-based network. A first
-service implemented on top of the networking layer allows censorship-
-resistant file-sharing.
-
-Our goal is to provide an infrastructure for secure networking. All
-communication in GNUnet is authenticated and encrypted. The reputation
-model makes attacks on the network harder. GNUnet does not rely on any
-centralized services.
-
-While our goals are similar to projects like Freenet, Gnutella, MojoNation
-and others, we hope to provide a superior combination of features for users
-that value security more than efficiency.
-
-WWW: http://gnunet.org/
diff --git a/net-p2p/gnunet/pkg-plist b/net-p2p/gnunet/pkg-plist
deleted file mode 100644
index 7ff5c2b77282..000000000000
--- a/net-p2p/gnunet/pkg-plist
+++ /dev/null
@@ -1,72 +0,0 @@
-bin/gnunet-chat
-bin/gnunet-check
-bin/gnunet-convert
-bin/gnunet-delete
-bin/gnunet-dht-join
-bin/gnunet-dht-query
-bin/gnunet-directory
-bin/gnunet-download
-%%WITH_GUILE%%bin/gnunet-download-manager.scm
-bin/gnunet-gtk
-bin/gnunet-insert
-bin/gnunet-peer-info
-bin/gnunet-pseudonym
-bin/gnunet-search
-bin/gnunet-setup
-bin/gnunet-stats
-bin/gnunet-tbench
-bin/gnunet-testbed
-bin/gnunet-tracekit
-bin/gnunet-transport-check
-bin/gnunet-update
-bin/gnunetd
-etc/gnunet.conf-dist
-include/gnunet_afs_esed2.h
-include/gnunet_core.h
-include/gnunet_dht.h
-include/gnunet_dht_datastore_memory.h
-include/gnunet_dht_lib.h
-include/gnunet_dht_service.h
-include/gnunet_rpc_service.h
-include/gnunet_transport.h
-include/gnunet_util.h
-lib/libgnunet_afs_esed2.a
-lib/libgnunet_afs_esed2.so
-lib/libgnunet_afs_esed2.so.0
-lib/libgnunetafs_database_directory.so
-lib/libgnunetafs_protocol.so
-lib/libgnunetchat_protocol.so
-lib/libgnunetdht_api.a
-lib/libgnunetdht_api.so
-lib/libgnunetdht_api.so.0
-lib/libgnunetdht_datastore_memory.a
-lib/libgnunetdht_datastore_memory.so
-lib/libgnunetdht_datastore_memory.so.0
-lib/libgnunetdht_protocol.so
-lib/libgnunetrpc_protocol.so
-lib/libgnunetrpc_util.a
-lib/libgnunetrpc_util.so
-lib/libgnunetrpc_util.so.0
-lib/libgnunettbench_protocol.so
-lib/libgnunettestbed_protocol.so
-lib/libgnunettracekit_protocol.so
-lib/libgnunettransport_http.so
-lib/libgnunettransport_nat.so
-lib/libgnunettransport_smtp.so
-lib/libgnunettransport_tcp.so
-lib/libgnunettransport_udp.so
-lib/libgnunetutil.a
-lib/libgnunetutil.so
-lib/libgnunetutil.so.0
-share/GNUnet/gnunet_logo.png
-share/locale/de/LC_MESSAGES/GNUnet.mo
-%%WITH_GDBM%%lib/libgnunetafs_database_gdbm.so
-%%WITH_TDB%%lib/libgnunetafs_database_tdb.so
-%%WITH_SQLITE%%lib/libgnunetafs_database_sqlite.so
-%%WITH_IPV6%%lib/libgnunettransport_tcp6.so
-%%WITH_IPV6%%lib/libgnunettransport_udp6.so
-@dirrm share/GNUnet
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/gnunet.user
-%%PORTDOCS%%@dirrm %%DOCSDIR%%