aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar-14
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/libtorrent-rasterbar-14')
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile37
-rw-r--r--net-p2p/libtorrent-rasterbar-14/distinfo3
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-Makefile.in11
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_asio_detail_socket_ops.hpp92
-rw-r--r--net-p2p/libtorrent-rasterbar-14/pkg-descr13
-rw-r--r--net-p2p/libtorrent-rasterbar-14/pkg-plist213
6 files changed, 0 insertions, 369 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
deleted file mode 100644
index 64ec889d5c99..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# New ports collection makefile for: rblibtorrent
-# Date created: 5 February 2006
-# Whom: Johan Ström <johan@stromnet.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libtorrent
-PORTVERSION= 0.11
-PORTREVISION= 1
-CATEGORIES= net-p2p
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=libtorrent
-PKGNAMEPREFIX= rb
-
-MAINTAINER= johan@stromnet.se
-COMMENT= A C++ library implementing a BitTorrent client
-
-LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost \
- boost_filesystem.3:${PORTSDIR}/devel/boost \
- boost_thread.3:${PORTSDIR}/devel/boost
-
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-debug
-CONFIGURE_ENV= CXXFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-
-CONFLICTS= libtorrent-[0-9]*
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= is unsupported on FreeBSD < 5
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/net-p2p/libtorrent-rasterbar-14/distinfo b/net-p2p/libtorrent-rasterbar-14/distinfo
deleted file mode 100644
index 74318f11702b..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (libtorrent-0.11.tar.gz) = 56e9071b95a6e3f9377121f2fead3499
-SHA256 (libtorrent-0.11.tar.gz) = f350e0af6b42c2cdb1f19008b00fe5f0b70236817f532a94bcb1e3ef6ebba0d7
-SIZE (libtorrent-0.11.tar.gz) = 1130537
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-Makefile.in b/net-p2p/libtorrent-rasterbar-14/files/patch-Makefile.in
deleted file mode 100644
index 1b322cd1715d..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Wed Nov 29 13:16:17 2006
-+++ Makefile.in Wed Nov 29 13:16:22 2006
-@@ -235,7 +235,7 @@
- debian/libtorrent0.install \
- debian/rules
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libtorrent.pc
- all: config.h
- $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_asio_detail_socket_ops.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_asio_detail_socket_ops.hpp
deleted file mode 100644
index 0943e805c176..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/files/patch-include_libtorrent_asio_detail_socket_ops.hpp
+++ /dev/null
@@ -1,92 +0,0 @@
---- include/libtorrent/asio/detail/socket_ops.hpp.original Tue Oct 24 00:50:21 2006
-+++ include/libtorrent/asio/detail/socket_ops.hpp Wed Nov 29 14:40:02 2006
-@@ -66,7 +66,7 @@
- socket_addr_len_type* addrlen)
- {
- set_error(0);
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type new_s = error_wrapper(::accept(s, addr, addrlen));
- if (new_s == invalid_socket)
- return new_s;
-@@ -279,7 +279,7 @@
- #if defined(BOOST_WINDOWS) || defined(__CYGWIN__)
- return error_wrapper(::WSASocket(af, type, protocol, 0, 0,
- WSA_FLAG_OVERLAPPED));
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type s = error_wrapper(::socket(af, type, protocol));
- if (s == invalid_socket)
- return s;
-@@ -561,7 +561,7 @@
- }
-
- #if defined(BOOST_WINDOWS) || defined(__CYGWIN__) \
-- || defined(__MACH__) && defined(__APPLE__)
-+ || defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
-
- // The following functions are only needed for emulation of getaddrinfo and
- // getnameinfo.
-@@ -604,7 +604,7 @@
- buffer, buflength, error));
- *error = translate_netdb_error(*error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- hostent* retval = error_wrapper(::getipnodebyaddr(addr, length, af, error));
-@@ -652,7 +652,7 @@
- buflength, error));
- *error = translate_netdb_error(*error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- hostent* retval = error_wrapper(::getipnodebyname(
-@@ -679,7 +679,7 @@
-
- inline void freehostent(hostent* h)
- {
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- if (h)
- ::freehostent(h);
- #else
-@@ -1372,7 +1372,7 @@
- }
-
- #endif // defined(BOOST_WINDOWS) || defined(__CYGWIN__)
-- // || defined(__MACH__) && defined(__APPLE__)
-+ // || defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
-
- inline int translate_addrinfo_error(int error)
- {
-@@ -1425,7 +1425,7 @@
- int error = getaddrinfo_emulation(host, service, hints, result);
- return translate_addrinfo_error(error);
- # endif
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- int error = getaddrinfo_emulation(host, service, hints, result);
- return translate_addrinfo_error(error);
- #else
-@@ -1453,7 +1453,7 @@
- }
- freeaddrinfo_emulation(ai);
- # endif
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- freeaddrinfo_emulation(ai);
- #else
- ::freeaddrinfo(ai);
-@@ -1488,7 +1488,7 @@
- host, hostlen, serv, servlen, flags);
- return translate_addrinfo_error(error);
- # endif
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- using namespace std; // For memcpy.
- sockaddr_storage_type tmp_addr;
- memcpy(&tmp_addr, addr, addrlen);
diff --git a/net-p2p/libtorrent-rasterbar-14/pkg-descr b/net-p2p/libtorrent-rasterbar-14/pkg-descr
deleted file mode 100644
index 814d0c42687a..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-libtorrent is a C++ library that aims to be a good alternative to
-all the other bittorrent implementations around.
-It is a library and not a full featured client, although it comes
-with a working example client.
-
-The main goals of libtorrent are:
- * to be cpu efficient
- * to be memory efficient
- * to be very easy to use
-
-Note that this is NOT the same library as the libtorrent port!
-
-WWW: http://www.rasterbar.com/products/libtorrent.html
diff --git a/net-p2p/libtorrent-rasterbar-14/pkg-plist b/net-p2p/libtorrent-rasterbar-14/pkg-plist
deleted file mode 100644
index fca1337deebc..000000000000
--- a/net-p2p/libtorrent-rasterbar-14/pkg-plist
+++ /dev/null
@@ -1,213 +0,0 @@
-include/libtorrent/alert.hpp
-include/libtorrent/alert_types.hpp
-include/libtorrent/allocate_resources.hpp
-include/libtorrent/asio.hpp
-include/libtorrent/asio/basic_datagram_socket.hpp
-include/libtorrent/asio/basic_deadline_timer.hpp
-include/libtorrent/asio/basic_io_object.hpp
-include/libtorrent/asio/basic_resolver.hpp
-include/libtorrent/asio/basic_socket.hpp
-include/libtorrent/asio/basic_socket_acceptor.hpp
-include/libtorrent/asio/basic_socket_iostream.hpp
-include/libtorrent/asio/basic_socket_streambuf.hpp
-include/libtorrent/asio/basic_stream_socket.hpp
-include/libtorrent/asio/basic_streambuf.hpp
-include/libtorrent/asio/buffer.hpp
-include/libtorrent/asio/buffered_read_stream.hpp
-include/libtorrent/asio/buffered_read_stream_fwd.hpp
-include/libtorrent/asio/buffered_stream.hpp
-include/libtorrent/asio/buffered_stream_fwd.hpp
-include/libtorrent/asio/buffered_write_stream.hpp
-include/libtorrent/asio/buffered_write_stream_fwd.hpp
-include/libtorrent/asio/completion_condition.hpp
-include/libtorrent/asio/datagram_socket_service.hpp
-include/libtorrent/asio/deadline_timer.hpp
-include/libtorrent/asio/deadline_timer_service.hpp
-include/libtorrent/asio/detail/bind_handler.hpp
-include/libtorrent/asio/detail/buffer_resize_guard.hpp
-include/libtorrent/asio/detail/buffered_stream_storage.hpp
-include/libtorrent/asio/detail/call_stack.hpp
-include/libtorrent/asio/detail/const_buffers_iterator.hpp
-include/libtorrent/asio/detail/consuming_buffers.hpp
-include/libtorrent/asio/detail/deadline_timer_service.hpp
-include/libtorrent/asio/detail/epoll_reactor.hpp
-include/libtorrent/asio/detail/epoll_reactor_fwd.hpp
-include/libtorrent/asio/detail/event.hpp
-include/libtorrent/asio/detail/fd_set_adapter.hpp
-include/libtorrent/asio/detail/handler_alloc_helpers.hpp
-include/libtorrent/asio/detail/handler_invoke_helpers.hpp
-include/libtorrent/asio/detail/hash_map.hpp
-include/libtorrent/asio/detail/io_control.hpp
-include/libtorrent/asio/detail/kqueue_reactor.hpp
-include/libtorrent/asio/detail/kqueue_reactor_fwd.hpp
-include/libtorrent/asio/detail/mutex.hpp
-include/libtorrent/asio/detail/noncopyable.hpp
-include/libtorrent/asio/detail/null_event.hpp
-include/libtorrent/asio/detail/null_mutex.hpp
-include/libtorrent/asio/detail/null_signal_blocker.hpp
-include/libtorrent/asio/detail/null_thread.hpp
-include/libtorrent/asio/detail/null_tss_ptr.hpp
-include/libtorrent/asio/detail/old_win_sdk_compat.hpp
-include/libtorrent/asio/detail/pipe_select_interrupter.hpp
-include/libtorrent/asio/detail/pop_options.hpp
-include/libtorrent/asio/detail/posix_event.hpp
-include/libtorrent/asio/detail/posix_fd_set_adapter.hpp
-include/libtorrent/asio/detail/posix_mutex.hpp
-include/libtorrent/asio/detail/posix_signal_blocker.hpp
-include/libtorrent/asio/detail/posix_thread.hpp
-include/libtorrent/asio/detail/posix_tss_ptr.hpp
-include/libtorrent/asio/detail/push_options.hpp
-include/libtorrent/asio/detail/reactive_socket_service.hpp
-include/libtorrent/asio/detail/reactor_op_queue.hpp
-include/libtorrent/asio/detail/resolver_service.hpp
-include/libtorrent/asio/detail/scoped_lock.hpp
-include/libtorrent/asio/detail/select_interrupter.hpp
-include/libtorrent/asio/detail/select_reactor.hpp
-include/libtorrent/asio/detail/select_reactor_fwd.hpp
-include/libtorrent/asio/detail/service_registry.hpp
-include/libtorrent/asio/detail/signal_blocker.hpp
-include/libtorrent/asio/detail/signal_init.hpp
-include/libtorrent/asio/detail/socket_holder.hpp
-include/libtorrent/asio/detail/socket_ops.hpp
-include/libtorrent/asio/detail/socket_option.hpp
-include/libtorrent/asio/detail/socket_select_interrupter.hpp
-include/libtorrent/asio/detail/socket_types.hpp
-include/libtorrent/asio/detail/strand_service.hpp
-include/libtorrent/asio/detail/task_io_service.hpp
-include/libtorrent/asio/detail/task_io_service_fwd.hpp
-include/libtorrent/asio/detail/thread.hpp
-include/libtorrent/asio/detail/timer_queue.hpp
-include/libtorrent/asio/detail/timer_queue_base.hpp
-include/libtorrent/asio/detail/tss_ptr.hpp
-include/libtorrent/asio/detail/win_event.hpp
-include/libtorrent/asio/detail/win_fd_set_adapter.hpp
-include/libtorrent/asio/detail/win_iocp_io_service.hpp
-include/libtorrent/asio/detail/win_iocp_io_service_fwd.hpp
-include/libtorrent/asio/detail/win_iocp_operation.hpp
-include/libtorrent/asio/detail/win_iocp_socket_service.hpp
-include/libtorrent/asio/detail/win_local_free_on_block_exit.hpp
-include/libtorrent/asio/detail/win_mutex.hpp
-include/libtorrent/asio/detail/win_signal_blocker.hpp
-include/libtorrent/asio/detail/win_thread.hpp
-include/libtorrent/asio/detail/win_tss_ptr.hpp
-include/libtorrent/asio/detail/winsock_init.hpp
-include/libtorrent/asio/detail/wrapped_handler.hpp
-include/libtorrent/asio/error.hpp
-include/libtorrent/asio/error_handler.hpp
-include/libtorrent/asio/handler_alloc_hook.hpp
-include/libtorrent/asio/handler_invoke_hook.hpp
-include/libtorrent/asio/impl/io_service.ipp
-include/libtorrent/asio/impl/read.ipp
-include/libtorrent/asio/impl/read_until.ipp
-include/libtorrent/asio/impl/write.ipp
-include/libtorrent/asio/io_service.hpp
-include/libtorrent/asio/ip/address.hpp
-include/libtorrent/asio/ip/address_v4.hpp
-include/libtorrent/asio/ip/address_v6.hpp
-include/libtorrent/asio/ip/basic_endpoint.hpp
-include/libtorrent/asio/ip/basic_resolver_entry.hpp
-include/libtorrent/asio/ip/basic_resolver_iterator.hpp
-include/libtorrent/asio/ip/basic_resolver_query.hpp
-include/libtorrent/asio/ip/detail/socket_option.hpp
-include/libtorrent/asio/ip/host_name.hpp
-include/libtorrent/asio/ip/multicast.hpp
-include/libtorrent/asio/ip/resolver_query_base.hpp
-include/libtorrent/asio/ip/tcp.hpp
-include/libtorrent/asio/ip/udp.hpp
-include/libtorrent/asio/is_read_buffered.hpp
-include/libtorrent/asio/is_write_buffered.hpp
-include/libtorrent/asio/placeholders.hpp
-include/libtorrent/asio/read.hpp
-include/libtorrent/asio/read_until.hpp
-include/libtorrent/asio/resolver_service.hpp
-include/libtorrent/asio/socket_acceptor_service.hpp
-include/libtorrent/asio/socket_base.hpp
-include/libtorrent/asio/ssl.hpp
-include/libtorrent/asio/ssl/basic_context.hpp
-include/libtorrent/asio/ssl/context.hpp
-include/libtorrent/asio/ssl/context_base.hpp
-include/libtorrent/asio/ssl/context_service.hpp
-include/libtorrent/asio/ssl/detail/openssl_context_service.hpp
-include/libtorrent/asio/ssl/detail/openssl_init.hpp
-include/libtorrent/asio/ssl/detail/openssl_operation.hpp
-include/libtorrent/asio/ssl/detail/openssl_stream_service.hpp
-include/libtorrent/asio/ssl/detail/openssl_types.hpp
-include/libtorrent/asio/ssl/stream.hpp
-include/libtorrent/asio/ssl/stream_base.hpp
-include/libtorrent/asio/ssl/stream_service.hpp
-include/libtorrent/asio/strand.hpp
-include/libtorrent/asio/stream_socket_service.hpp
-include/libtorrent/asio/streambuf.hpp
-include/libtorrent/asio/system_exception.hpp
-include/libtorrent/asio/thread.hpp
-include/libtorrent/asio/time_traits.hpp
-include/libtorrent/asio/write.hpp
-include/libtorrent/aux_/allocate_resources_impl.hpp
-include/libtorrent/aux_/session_impl.hpp
-include/libtorrent/bencode.hpp
-include/libtorrent/bt_peer_connection.hpp
-include/libtorrent/buffer.hpp
-include/libtorrent/config.hpp
-include/libtorrent/debug.hpp
-include/libtorrent/entry.hpp
-include/libtorrent/escape_string.hpp
-include/libtorrent/file.hpp
-include/libtorrent/fingerprint.hpp
-include/libtorrent/hasher.hpp
-include/libtorrent/http_tracker_connection.hpp
-include/libtorrent/identify_client.hpp
-include/libtorrent/invariant_check.hpp
-include/libtorrent/io.hpp
-include/libtorrent/ip_filter.hpp
-include/libtorrent/kademlia/closest_nodes.hpp
-include/libtorrent/kademlia/dht_tracker.hpp
-include/libtorrent/kademlia/find_data.hpp
-include/libtorrent/kademlia/logging.hpp
-include/libtorrent/kademlia/node.hpp
-include/libtorrent/kademlia/node_entry.hpp
-include/libtorrent/kademlia/node_id.hpp
-include/libtorrent/kademlia/packet_iterator.hpp
-include/libtorrent/kademlia/refresh.hpp
-include/libtorrent/kademlia/routing_table.hpp
-include/libtorrent/kademlia/rpc_manager.hpp
-include/libtorrent/kademlia/traversal_algorithm.hpp
-include/libtorrent/peer.hpp
-include/libtorrent/peer_connection.hpp
-include/libtorrent/peer_id.hpp
-include/libtorrent/peer_info.hpp
-include/libtorrent/peer_request.hpp
-include/libtorrent/piece_block_progress.hpp
-include/libtorrent/piece_picker.hpp
-include/libtorrent/policy.hpp
-include/libtorrent/random_sample.hpp
-include/libtorrent/resource_request.hpp
-include/libtorrent/session.hpp
-include/libtorrent/session_settings.hpp
-include/libtorrent/session_status.hpp
-include/libtorrent/size_type.hpp
-include/libtorrent/socket.hpp
-include/libtorrent/stat.hpp
-include/libtorrent/storage.hpp
-include/libtorrent/torrent.hpp
-include/libtorrent/torrent_handle.hpp
-include/libtorrent/torrent_info.hpp
-include/libtorrent/tracker_manager.hpp
-include/libtorrent/udp_tracker_connection.hpp
-include/libtorrent/utf8.hpp
-include/libtorrent/version.hpp
-include/libtorrent/web_peer_connection.hpp
-lib/libtorrent.a
-lib/libtorrent.la
-lib/libtorrent.so
-lib/libtorrent.so.1
-libdata/pkgconfig/libtorrent.pc
-@dirrm include/libtorrent/kademlia
-@dirrm include/libtorrent/aux_
-@dirrm include/libtorrent/asio/ssl/detail
-@dirrm include/libtorrent/asio/ssl
-@dirrm include/libtorrent/asio/ip/detail
-@dirrm include/libtorrent/asio/ip
-@dirrm include/libtorrent/asio/impl
-@dirrm include/libtorrent/asio/detail
-@dirrm include/libtorrent/asio
-@dirrm include/libtorrent