aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/libtorrent/Makefile')
-rw-r--r--net-p2p/libtorrent/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 6fca3e9c4bc1..b3e73069cbd2 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= libtorrent
-PORTVERSION?= 0.12.6
-PORTREVISION?= 1
+PORTVERSION?= 0.12.7
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -28,7 +27,8 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-OPTIONS= KQUEUE "Use kqueue(2) support" on
+OPTIONS= KQUEUE "Use kqueue(2) support" on \
+ IPV6 "Enable IPv6 support" off
.include <bsd.port.pre.mk>
@@ -48,4 +48,8 @@ post-patch:
CONFIGURE_ARGS+= --with-kqueue
.endif
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
.include <bsd.port.post.mk>