aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/libtorrent/Makefile')
-rw-r--r--net-p2p/libtorrent/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index b7efdaf93c15..c3d75b8d4dea 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= libtorrent
-PORTVERSION?= 0.9.3
+PORTVERSION?= 0.10.3
PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/
@@ -21,12 +21,14 @@ CONFLICTS?= libtorrent-devel-[0-9]*
USE_GCC= 3.4
USE_GNOME= pkgconfig gnomehack
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
EXTRA_PATCHES?= ${.CURDIR}/files/stable-*
+OPTIONS= KQUEUE "Use kqueue(2) support" on
+
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --disable-debug --with-openssl=${OPENSSLBASE}
@@ -34,4 +36,8 @@ CONFIGURE_ARGS+= --disable-debug --with-openssl=${OPENSSLBASE}
post-patch:
@${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
+.if !defined(WITHOUT_KQUEUE)
+CONFIGURE_ARGS=--with-kqueue
+.endif
+
.include <bsd.port.post.mk>