aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rblibtorrent-devel/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rblibtorrent-devel/files')
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-configure.in66
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__chained_buffer.hpp20
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__error_code.hpp20
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__proxy_base.hpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__socket.hpp20
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__ssl_stream.hpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__time.hpp29
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__variant_stream.hpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__broadcast_socket.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__enum_net.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__error_code.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__file_pool.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__lsd.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__natpmp.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp114
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__udp_socket.cpp11
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__upnp.cpp11
17 files changed, 0 insertions, 390 deletions
diff --git a/net-p2p/rblibtorrent-devel/files/patch-configure.in b/net-p2p/rblibtorrent-devel/files/patch-configure.in
deleted file mode 100644
index 8c9d4d668051..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-configure.in
+++ /dev/null
@@ -1,66 +0,0 @@
---- configure.in.orig 2009-08-05 11:29:42.000000000 +0900
-+++ configure.in 2009-08-29 03:28:28.000000000 +0900
-@@ -65,19 +65,6 @@
- AM_CONDITIONAL([ENABLE_SHIPPED_ASIO], false)
-
- dnl Check for boost libraries.
--AX_BOOST_BASE([1.35],[
-- AX_BOOST_SYSTEM
-- dnl check that Boost.System was found:
-- if test -z "$BOOST_SYSTEM_LIB"; then
-- AC_MSG_ERROR([unable to find Boost.System library, currently this is required.])
-- fi
--
-- AX_BOOST_ASIO
-- dnl check that Boost.Asio was found:
-- if test -z "$BOOST_ASIO_LIB"; then
-- AC_MSG_ERROR([Unable to find Boost.Asio library, currently this is required.])
-- fi
--],[
- AX_BOOST_BASE([1.34],[
-
- dnl the user can choose which Asio library to use
-@@ -121,7 +108,6 @@
- esac
- AM_CONDITIONAL([ENABLE_SHIPPED_ASIO], [test x$enable_shipped_asio = "xyes"])
- ])
--])
-
- AC_MSG_NOTICE([BOOST_CPPFLAGS=$BOOST_CPPFLAGS])
- AC_MSG_NOTICE([BOOST_LDFLAGS=$BOOST_LDFLAGS])
-@@ -351,7 +337,7 @@
- esac
-
- dnl Use possibly specific python install params
--if [[ "x$PYTHON_INSTALL_PARAMS" == "x" ]]; then
-+if [[ "x$PYTHON_INSTALL_PARAMS" = "x" ]]; then
- PYTHON_INSTALL_PARAMS='--prefix=$(DESTDIR)$(prefix)'
- fi
- AC_SUBST(PYTHON_INSTALL_PARAMS)
-@@ -413,7 +399,7 @@
- esac
-
- dnl Set some defines if we are building a shared library
--if [[ "x$enable_shared" == "xyes" ]]; then
-+if [[ "x$enable_shared" = "xyes" ]]; then
- AC_DEFINE(TORRENT_BUILDING_SHARED,,[Make sure the functions and classes are exported.])
- COMPILETIME_OPTIONS+="-DTORRENT_LINKING_SHARED "
- fi
-@@ -425,7 +411,7 @@
- [case "$enableval" in
- no)
- AC_DEFINE(NDEBUG,,[Define to disable debugging])
-- DEBUGFLAGS="-Os"
-+ DEBUGFLAGS=""
- # COMPILETIME_OPTIONS+="-DNDEBUG "
- ;;
- yes)
-@@ -438,7 +424,7 @@
- AC_MSG_ERROR([Unknown --enable-debug option "$enableval". Use either "yes" or "no".])
- ;;
- esac],
-- [DEBUGFLAGS="-Os"
-+ [DEBUGFLAGS=""
- AC_DEFINE(NDEBUG,,[Define to disable debugging])
- # COMPILETIME_OPTIONS+="-DNDEBUG "
- ]
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__chained_buffer.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__chained_buffer.hpp
deleted file mode 100644
index 19028a1e5e7c..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__chained_buffer.hpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/libtorrent/chained_buffer.hpp.orig 2008-10-05 10:41:54.000000000 +0900
-+++ include/libtorrent/chained_buffer.hpp 2009-04-19 05:13:19.000000000 +0900
-@@ -35,7 +35,7 @@
-
- #include <boost/function.hpp>
- #include <boost/version.hpp>
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/buffer.hpp>
- #else
- #include <boost/asio/buffer.hpp>
-@@ -45,7 +45,7 @@
-
- namespace libtorrent
- {
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- namespace asio = boost::asio;
- #endif
- struct chained_buffer
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__error_code.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__error_code.hpp
deleted file mode 100644
index d3bd0e6192a1..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__error_code.hpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/libtorrent/error_code.hpp.orig 2008-10-05 10:41:54.000000000 +0900
-+++ include/libtorrent/error_code.hpp 2009-04-19 05:15:39.000000000 +0900
-@@ -35,7 +35,7 @@
-
- #include <boost/version.hpp>
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/error_code.hpp>
- #else
- #include <boost/system/error_code.hpp>
-@@ -53,7 +53,7 @@
- };
- }
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- typedef asio::error_code error_code;
- inline asio::error::error_category get_posix_category() { return asio::error::system_category; }
- inline asio::error::error_category get_system_category() { return asio::error::system_category; }
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__proxy_base.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__proxy_base.hpp
deleted file mode 100644
index 94af000ecdd2..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__proxy_base.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/libtorrent/proxy_base.hpp.orig 2008-10-05 10:41:54.000000000 +0900
-+++ include/libtorrent/proxy_base.hpp 2009-04-19 05:17:07.000000000 +0900
-@@ -38,7 +38,7 @@
- #include <boost/bind.hpp>
- #include <boost/lexical_cast.hpp>
- #include <boost/function.hpp>
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/read.hpp>
- #include <asio/write.hpp>
- #else
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__socket.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__socket.hpp
deleted file mode 100644
index f1ae1b7a67c8..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__socket.hpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/libtorrent/socket.hpp.orig 2009-02-08 17:13:07.000000000 +0900
-+++ include/libtorrent/socket.hpp 2009-04-19 05:18:58.000000000 +0900
-@@ -47,7 +47,7 @@
-
- #include <boost/version.hpp>
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ip/tcp.hpp>
- #include <asio/ip/udp.hpp>
- #include <asio/io_service.hpp>
-@@ -82,7 +82,7 @@
- namespace libtorrent
- {
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- using asio::ip::tcp;
- using asio::ip::udp;
- using asio::async_write;
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__ssl_stream.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__ssl_stream.hpp
deleted file mode 100644
index 14ffbc74bf39..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__ssl_stream.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/libtorrent/ssl_stream.hpp.orig 2008-10-21 17:07:26.000000000 +0900
-+++ include/libtorrent/ssl_stream.hpp 2009-04-19 05:19:42.000000000 +0900
-@@ -34,7 +34,7 @@
- #define TORRENT_SSL_STREAM_HPP_INCLUDED
-
- #include "libtorrent/socket.hpp"
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ssl.hpp>
- #else
- #include <boost/asio/ssl.hpp>
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__time.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__time.hpp
deleted file mode 100644
index b74e4bec71d6..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__time.hpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- include/libtorrent/time.hpp.orig 2008-11-30 04:31:36.000000000 +0900
-+++ include/libtorrent/time.hpp 2009-04-19 23:13:40.000000000 +0900
-@@ -87,7 +87,7 @@
-
- #else
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/time_traits.hpp>
- #else
- #include <boost/asio/time_traits.hpp>
-@@ -159,7 +159,7 @@
- }
-
- // asio time_traits
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- namespace boost {
- #endif
- namespace asio
-@@ -182,7 +182,7 @@
- { return boost::posix_time::microseconds(libtorrent::total_microseconds(d)); }
- };
- }
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- }
- #endif
-
diff --git a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__variant_stream.hpp b/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__variant_stream.hpp
deleted file mode 100644
index b5444156d38e..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-include__libtorrent__variant_stream.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/libtorrent/variant_stream.hpp.orig 2008-10-05 10:41:54.000000000 +0900
-+++ include/libtorrent/variant_stream.hpp 2009-04-19 05:21:46.000000000 +0900
-@@ -21,7 +21,7 @@
- # include <boost/type_traits/add_pointer.hpp>
- # include <boost/noncopyable.hpp>
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/io_service.hpp>
- #else
- #include <boost/asio/io_service.hpp>
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__broadcast_socket.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__broadcast_socket.cpp
deleted file mode 100644
index 7002819a4efe..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__broadcast_socket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/broadcast_socket.cpp.orig 2008-10-22 10:15:07.000000000 +0900
-+++ src/broadcast_socket.cpp 2009-04-19 05:27:08.000000000 +0900
-@@ -32,7 +32,7 @@
-
- #include <boost/version.hpp>
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ip/host_name.hpp>
- #include <asio/ip/multicast.hpp>
- #else
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__enum_net.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__enum_net.cpp
deleted file mode 100644
index cedc99dab46f..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__enum_net.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/enum_net.cpp.orig 2009-02-08 17:13:04.000000000 +0900
-+++ src/enum_net.cpp 2009-04-19 05:28:22.000000000 +0900
-@@ -35,7 +35,7 @@
- #include <vector>
- #include "libtorrent/enum_net.hpp"
- #include "libtorrent/broadcast_socket.hpp"
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ip/host_name.hpp>
- #else
- #include <boost/asio/ip/host_name.hpp>
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__error_code.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__error_code.cpp
deleted file mode 100644
index d584a40c469d..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__error_code.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/error_code.cpp.orig 2008-10-05 10:41:56.000000000 +0900
-+++ src/error_code.cpp 2009-04-19 05:35:55.000000000 +0900
-@@ -32,7 +32,7 @@
-
- #include <boost/version.hpp>
-
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
-
- #include "libtorrent/error_code.hpp"
-
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__file_pool.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__file_pool.cpp
deleted file mode 100644
index 78a7af6ff9de..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__file_pool.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/file_pool.cpp.orig 2009-02-08 17:13:04.000000000 +0900
-+++ src/file_pool.cpp 2009-04-19 05:29:34.000000000 +0900
-@@ -62,7 +62,7 @@
- {
- // this means that another instance of the storage
- // is using the exact same file.
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- ec = error_code(errors::file_collision, libtorrent_category);
- #endif
- return boost::shared_ptr<file>();
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__lsd.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__lsd.cpp
deleted file mode 100644
index 850bf0af0bac..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__lsd.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lsd.cpp.orig 2009-02-12 03:16:27.000000000 +0900
-+++ src/lsd.cpp 2009-04-19 05:30:17.000000000 +0900
-@@ -41,7 +41,7 @@
-
- #include <boost/bind.hpp>
- #include <boost/ref.hpp>
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ip/host_name.hpp>
- #include <asio/ip/multicast.hpp>
- #else
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__natpmp.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__natpmp.cpp
deleted file mode 100644
index b7cc1537de30..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__natpmp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/natpmp.cpp.orig 2009-02-08 17:13:04.000000000 +0900
-+++ src/natpmp.cpp 2009-04-19 05:30:54.000000000 +0900
-@@ -35,7 +35,7 @@
- #include <boost/version.hpp>
- #include <boost/bind.hpp>
-
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ip/host_name.hpp>
- #else
- #include <boost/asio/ip/host_name.hpp>
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
deleted file mode 100644
index 3bc14260d622..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
+++ /dev/null
@@ -1,114 +0,0 @@
---- src/storage.cpp.orig 2009-11-06 09:45:13.000000000 -0800
-+++ src/storage.cpp 2009-11-21 23:12:53.000000000 -0800
-@@ -53,7 +53,7 @@
- #include <boost/multi_index_container.hpp>
- #include <boost/multi_index/member.hpp>
- #include <boost/multi_index/ordered_index.hpp>
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- #include <boost/system/system_error.hpp>
- #endif
-
-@@ -185,15 +185,15 @@
- }
- #ifndef BOOST_NO_EXCEPTIONS
- }
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- catch (boost::system::system_error& e)
- {
- ec = e.code();
- }
- #else
-- catch (boost::filesystem::filesystem_error& e)
-+ catch (std::exception& e)
- {
-- ec = error_code(e.system_error(), get_system_category());
-+ ec = error_code(errno, get_posix_category());
- }
- #endif // BOOST_VERSION
- #endif // BOOST_NO_EXCEPTIONS
-@@ -460,17 +460,17 @@
- }
- #ifndef BOOST_NO_EXCEPTIONS
- }
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- catch (boost::system::system_error& e)
- {
- set_error(m_save_path / file_iter->path, e.code());
- return true;
- }
- #else
-- catch (boost::filesystem::filesystem_error& e)
-+ catch (std::exception& e)
- {
- set_error(m_save_path / file_iter->path
-- , error_code(e.system_error(), get_system_category()));
-+ , error_code(errno, get_posix_category()));
- return true;
- }
- #endif // BOOST_VERSION
-@@ -503,16 +503,16 @@
- #endif
- #ifndef BOOST_NO_EXCEPTIONS
- }
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- catch (boost::system::system_error& e)
- {
- set_error(f, e.code());
- return false;
- }
- #else
-- catch (boost::filesystem::filesystem_error& e)
-+ catch (std::exception& e)
- {
-- set_error(f, error_code(e.system_error(), get_system_category()));
-+ set_error(f, error_code(errno, get_posix_category()));
- return false;
- }
- #endif // BOOST_VERSION
-@@ -560,17 +560,17 @@
- m_mapped_files->rename_file(index, new_filename);
- #ifndef BOOST_NO_EXCEPTIONS
- }
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- catch (boost::system::system_error& e)
- {
- set_error(old_name, e.code());
- return true;
- }
- #else
-- catch (boost::filesystem::filesystem_error& e)
-+ catch (std::exception& e)
- {
-- set_error(old_name, error_code(e.system_error()
-- , get_system_category()));
-+ set_error(old_name, error_code(errno
-+ , get_posix_category()));
- return true;
- }
- #endif // BOOST_VERSION
-@@ -593,7 +593,7 @@
- #endif
- { fs::remove(safe_convert(p)); }
- #ifndef BOOST_NO_EXCEPTIONS
--#if BOOST_VERSION >= 103500
-+#if 0 // BOOST_VERSION >= 103500
- catch (boost::system::system_error& e)
- {
- // no such file or directory is not an error
-@@ -601,9 +601,9 @@
- set_error(p, e.code());
- }
- #else
-- catch (boost::filesystem::filesystem_error& e)
-+ catch (std::exception& e)
- {
-- set_error(p, error_code(e.system_error(), get_system_category()));
-+ set_error(p, errno, get_posix_category()));
- }
- #endif // BOOST_VERSION
- #endif // BOOST_NO_EXCEPTIONS
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__udp_socket.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__udp_socket.cpp
deleted file mode 100644
index c44d01c0d869..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__udp_socket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/udp_socket.cpp.orig 2009-02-08 17:13:04.000000000 +0900
-+++ src/udp_socket.cpp 2009-04-19 05:33:12.000000000 +0900
-@@ -36,7 +36,7 @@
- #include <stdlib.h>
- #include <boost/bind.hpp>
- #include <boost/array.hpp>
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/read.hpp>
- #else
- #include <boost/asio/read.hpp>
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__upnp.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__upnp.cpp
deleted file mode 100644
index d3ed06379061..000000000000
--- a/net-p2p/rblibtorrent-devel/files/patch-src__upnp.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/upnp.cpp.orig 2009-02-18 17:42:16.000000000 +0900
-+++ src/upnp.cpp 2009-04-19 05:33:50.000000000 +0900
-@@ -43,7 +43,7 @@
-
- #include <boost/bind.hpp>
- #include <boost/ref.hpp>
--#if BOOST_VERSION < 103500
-+#if 1 // BOOST_VERSION < 103500
- #include <asio/ip/host_name.hpp>
- #include <asio/ip/multicast.hpp>
- #else