aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile2
-rw-r--r--net-p2p/transmission-cli/files/patch-fix_without_ipv611
2 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index bf74f1bb42b5..941acce37221 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -7,7 +7,7 @@
PORTNAME= transmission
PORTVERSION= 2.04
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= net-p2p
MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
PKGNAMESUFFIX?= -cli
diff --git a/net-p2p/transmission-cli/files/patch-fix_without_ipv6 b/net-p2p/transmission-cli/files/patch-fix_without_ipv6
new file mode 100644
index 000000000000..cd9deba2732e
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-fix_without_ipv6
@@ -0,0 +1,11 @@
+--- libtransmission/fdlimit.c.orig 2010-09-13 14:17:18.000000000 +0600
++++ libtransmission/fdlimit.c 2010-09-13 14:04:19.000000000 +0600
+@@ -646,7 +646,7 @@
+ if( gFd->socketCount < gFd->socketLimit )
+ if( ( s = socket( domain, type, 0 ) ) < 0 )
+ {
+- if( sockerrno != EAFNOSUPPORT )
++ if( sockerrno != EPROTONOSUPPORT )
+ tr_err( _( "Couldn't create socket: %s" ),
+ tr_strerror( sockerrno ) );
+ }