aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/transmission')
-rw-r--r--net-p2p/transmission/Makefile33
-rw-r--r--net-p2p/transmission/distinfo6
-rw-r--r--net-p2p/transmission/files/patch-libtransmission_torrent.c13
-rw-r--r--net-p2p/transmission/files/patch-version.sh8
4 files changed, 40 insertions, 20 deletions
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index d065b4de177e..6dffdee52946 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -6,34 +6,42 @@
#
PORTNAME= transmission
-PORTVERSION= 0.72
+PORTVERSION= 0.80
PORTREVISION?= 0
CATEGORIES= net-p2p
-#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://people.freebsd.org/~mezz/distfiles/
-MASTER_SITE_SUBDIR=mezz
+MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
DISTNAME= Transmission-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT?= A free BitTorrent client written from scratch in C
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
+SLAVE_TRANS?= no
HAS_CONFIGURE= yes
CONFIGURE_ARGS?=--prefix=${PREFIX} \
+ --disable-daemon \
--disable-gtk
+DOCS= AUTHORS LICENSE NEWS README
+
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude beos \
--exclude macosx \
--exclude Transmission.xcodeproj
-DOCS= AUTHORS LICENSE NEWS README
+.if !defined(MASTERDIR)
+EXTRACT_AFTER_ARGS+= --exclude daemon \
+ --exclude gtk \
+ --exclude libevent \
+ --exclude wx
+MAN1= transmissioncli.1
+.endif
-.if defined(SLAVE_TRANS)
-EXTRACT_AFTER_ARGS+=--exclude cli
-.else
-EXTRACT_AFTER_ARGS+=--exclude gtk
-MAN1= transmissioncli.1
+.if ${SLAVE_TRANS}=="gtk2"
+EXTRACT_AFTER_ARGS+= --exclude cli \
+ --exclude daemon \
+ --exclude libevent \
+ --exclude wx
.endif
.if defined(WITHOUT_OPENSSL)
@@ -50,8 +58,7 @@ pre-everything::
.endif
general-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g ; \
- s|/usr/X11R6/|${X11BASE}/|g' \
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
s|-g -Wall -W -O3 -funroll-loops|-Wall -W|g' \
diff --git a/net-p2p/transmission/distinfo b/net-p2p/transmission/distinfo
index 684677101a87..1c2461268d4d 100644
--- a/net-p2p/transmission/distinfo
+++ b/net-p2p/transmission/distinfo
@@ -1,3 +1,3 @@
-MD5 (Transmission-0.72.tar.gz) = 634a18bf7cea1e2497465a3522de3e60
-SHA256 (Transmission-0.72.tar.gz) = 987172b8e4779cff77b98917ab85e518fb3366e1052d5598ff81df860f6d31bb
-SIZE (Transmission-0.72.tar.gz) = 1335882
+MD5 (Transmission-0.80.tar.gz) = 5fde1bc0f8c3c31daaa202680e00d44a
+SHA256 (Transmission-0.80.tar.gz) = d05d158d23e819d7a4f06eee92c158a86be52b18af838927f19be8897050f06e
+SIZE (Transmission-0.80.tar.gz) = 2283341
diff --git a/net-p2p/transmission/files/patch-libtransmission_torrent.c b/net-p2p/transmission/files/patch-libtransmission_torrent.c
new file mode 100644
index 000000000000..90c4162c14ab
--- /dev/null
+++ b/net-p2p/transmission/files/patch-libtransmission_torrent.c
@@ -0,0 +1,13 @@
+Index: /branches/0.8x/libtransmission/torrent.c
+===================================================================
+--- /branches/0.8x/libtransmission/torrent.c (revision 2573)
++++ libtransmission/torrent.c (revision 2650)
+@@ -736,6 +736,6 @@
+ assert( 0<=fileIndex && fileIndex<tor->info.fileCount );
+ assert( file->offset + file->length <= tor->info.totalSize );
+- assert( (int)firstBlock < tor->blockCount );
+- assert( (int)lastBlock < tor->blockCount );
++ assert( ( (int)firstBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
++ assert( ( (int)lastBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
+ assert( firstBlock <= lastBlock );
+ assert( (int)tr_torBlockPiece( tor, firstBlock ) == file->firstPiece );
diff --git a/net-p2p/transmission/files/patch-version.sh b/net-p2p/transmission/files/patch-version.sh
index cc23ee3516c7..52aea6e5df4d 100644
--- a/net-p2p/transmission/files/patch-version.sh
+++ b/net-p2p/transmission/files/patch-version.sh
@@ -1,11 +1,11 @@
---- version.sh.orig Wed Apr 18 11:24:12 2007
-+++ version.sh Wed Apr 18 11:24:21 2007
-@@ -48,9 +48,4 @@
+--- version.sh.orig 2007-08-07 10:44:05.000000000 -0500
++++ version.sh 2007-08-07 10:44:41.000000000 -0500
+@@ -52,9 +52,4 @@
EOF
replace_if_differs libtransmission/version.h.new libtransmission/version.h
-# Generate Info.plist from Info.plist.in
--sed -e "s/%%BUNDLE_VERSION%%/$REV/" -e "s/%%SHORT_VERSION_STRING%%/$STRING/" \
+-sed -e "s/%%BUNDLE_VERSION%%/$SVN_REVISION/" -e "s/%%SHORT_VERSION_STRING%%/$USERAGENT_PREFIX/" \
- < macosx/Info.plist.in > macosx/Info.plist.new
-replace_if_differs macosx/Info.plist.new macosx/Info.plist
-