aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/unworkable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/unworkable/Makefile')
-rw-r--r--net-p2p/unworkable/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/net-p2p/unworkable/Makefile b/net-p2p/unworkable/Makefile
index a4002bdeed9a..03db479c52a4 100644
--- a/net-p2p/unworkable/Makefile
+++ b/net-p2p/unworkable/Makefile
@@ -4,29 +4,27 @@
PORTNAME= unworkable
PORTVERSION= 0.53
CATEGORIES= net-p2p
-MASTER_SITES= http://p2presearch.com/unworkable/dist/\
- http://unworkable.googlecode.com/files/
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= wenheping@gmail.com
COMMENT= A Free BitTorrent Implementation
-LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
USE_SCONS= yes
USE_OPENSSL= yes
+
SCONS_BUILDENV= ${SCONS_ENV}
WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_FILES= bin/unworkable
-MAN1= unworkable.1
+PLIST_FILES= bin/unworkable man/man1/unworkable.1.gz
-NO_STAGE= yes
post-extract:
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
${WRKSRC}/SConstruct
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unworkable ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/unworkable.1 ${MANPREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/unworkable ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/unworkable.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>