aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/valknut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/valknut/Makefile')
-rw-r--r--net-p2p/valknut/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index b31afdd0d122..4005976b7f5f 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -1,3 +1,4 @@
+# ex: ts=8
# New ports collection makefile for: dcgui
# Date created: Wed 10 Jul 2002
# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
@@ -7,25 +8,31 @@
#
PORTNAME= valknut
-PORTVERSION= 0.3.13
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= net-p2p
MASTER_SITES= SF
MASTER_SITE_SUBDIR= wxdcgui
+DISTNAME= ${PORTNAME}-${PORTVERSION}a
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A Direct Connect client QT GUI
LIB_DEPENDS= dc.0:${PORTSDIR}/net-p2p/dclib \
xml2.5:${PORTSDIR}/textproc/libxml2
-USE_QT_VER= 3
-USE_XORG= x11 ice xext
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+MAN1= valknut.1
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui network qt3support
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libdc=${LOCALBASE}
+CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
+ --x-libraries=${LOCALBASE}/lib \
+ --x-includes=${LOCALBASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}