aboutsummaryrefslogtreecommitdiff
path: root/net/angst/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/angst/Makefile')
-rw-r--r--net/angst/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/angst/Makefile b/net/angst/Makefile
new file mode 100644
index 000000000000..85994007f508
--- /dev/null
+++ b/net/angst/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: angst
+# Date created: Dec 4, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= angst
+PORTVERSION= 0.4b
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+
+MAN8= angst.8
+
+post-patch:
+ @${PERL} -pi -e "s,^CC,#CC,g ; \
+ s,^CFLAGS,#CFLAGS,g ; \
+ s,libnet-config,${LIBNET_CONFIG},g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>