aboutsummaryrefslogtreecommitdiff
path: root/net/arp-sk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/arp-sk/Makefile')
-rw-r--r--net/arp-sk/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/arp-sk/Makefile b/net/arp-sk/Makefile
new file mode 100644
index 000000000000..150790c250d7
--- /dev/null
+++ b/net/arp-sk/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: arp-sk
+# Date Created: Apr 14, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= arp-sk
+PORTVERSION= 0.0.15
+CATEGORIES= net
+MASTER_SITES= http://www.arp-sk.org/files/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A tool designed to manipulate ARP tables of all kinds of equipment
+
+BUILD_DEPENDS= ${LOCALBASE}/include/libnet/libnet-types.h:${PORTSDIR}/net/libnet-devel
+
+USE_REINPLACE= yes
+#USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+
+MAN1= arp-sk.1
+PLIST_FILES= sbin/arp-sk
+
+post-patch:
+ @${REINPLACE_CMD} -e "s, -pedantic -g,," ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/arp-sk ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/man/arp-sk.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>