aboutsummaryrefslogtreecommitdiff
path: root/net/arping/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/arping/Makefile')
-rw-r--r--net/arping/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index c8df0dac24a5..94fdd5a4cf11 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -14,10 +14,9 @@ LICENSE= GPLv2
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="`${LIBNET_CONFIG} --libs` -lpcap"
-CFLAGS+= `${LIBNET_CONFIG} --defines`
-CPPFLAGS+= -I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include \
+ `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
+LIBS+= -L${LOCALBASE}/lib `${LIBNET_CONFIG} --libs` -lpcap
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config