aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk-oh323/files/patch-asterisk-driver::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk-oh323/files/patch-asterisk-driver::Makefile')
-rw-r--r--net/asterisk-oh323/files/patch-asterisk-driver::Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/asterisk-oh323/files/patch-asterisk-driver::Makefile b/net/asterisk-oh323/files/patch-asterisk-driver::Makefile
new file mode 100644
index 000000000000..34cf24053f38
--- /dev/null
+++ b/net/asterisk-oh323/files/patch-asterisk-driver::Makefile
@@ -0,0 +1,43 @@
+--- asterisk-driver/Makefile.orig Mon Oct 4 14:52:09 2004
++++ asterisk-driver/Makefile Fri Jun 17 13:51:08 2005
+@@ -33,9 +33,9 @@ TARGET_OBJ=chan_oh323.o
+
+ ifndef SKIP_SUFFIX
+ ifeq ($(OH323STAT),1)
+- LIBPTPATH=$(word 1,$(shell ls $(PWLIBDIR)/lib/libpt*s.a))
++ LIBPTPATH=$(word 1,$(shell ls $(PWLIBDIR)/lib/libpt*.a))
+ else
+- LIBPTPATH=$(word 1,$(shell ls $(PWLIBDIR)/lib/libpt*r.so))
++ LIBPTPATH=$(word 1,$(shell ls $(PWLIBDIR)/lib/libpt*.so))
+ endif
+ LIBPTNAME=$(subst lib,,$(basename $(notdir $(LIBPTPATH))))
+ LIBPTSSUF=$(findstring _r_s,$(LIBPTNAME)) # Static lib suffix
+@@ -54,9 +54,9 @@ ifndef SKIP_SUFFIX
+ LIBH323PATH=$(word 1,$(shell ls $(OPENH323DIR)/lib/libh323*s.a))
+ else
+ ifdef NOTRACE
+- LIBH323PATH=$(word 1,$(shell ls $(OPENH323DIR)/lib/libh323*n.so))
++ LIBH323PATH=$(word 1,$(shell ls $(OPENH323DIR)/lib/libh323*.so))
+ else
+- LIBH323PATH=$(word 1,$(shell ls $(OPENH323DIR)/lib/libh323*r.so))
++ LIBH323PATH=$(word 1,$(shell ls $(OPENH323DIR)/lib/libh323*.so))
+ endif
+ endif
+ LIBH323NAME=$(subst lib,,$(basename $(notdir $(LIBH323PATH))))
+@@ -76,7 +76,7 @@ else
+ endif
+
+ ifndef SKIP_EXTLIBS
+- EXTLIBS=$(shell $(PWLIBDIR)/make/ptlib-config --libs)
++ EXTLIBS=$(shell $(PWLIBDIR)/make/ptlib-config --ldflags --libs)
+ endif
+
+ CFLAGS += -pipe -Wall -Wstrict-prototypes -Wmissing-prototypes \
+@@ -101,6 +101,7 @@ install:
+ if [ ! -d $(DESTDIR)$(ASTERISKETCDIR) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(ASTERISKETCDIR); \
+ fi
++ $(INSTALL) -m 0644 oh323.conf.sample $(DESTDIR)$(ASTERISKETCDIR)/oh323.conf.sample
+ if [ ! -f $(DESTDIR)$(ASTERISKETCDIR)/oh323.conf ]; then \
+ $(INSTALL) -m 0644 oh323.conf.sample $(DESTDIR)$(ASTERISKETCDIR)/oh323.conf; \
+ fi