aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk/Makefile')
-rw-r--r--net/asterisk/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index 3b27308d03e7..34a53f506d76 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asterisk
PORTVERSION= 1.8.22.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -26,7 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gsm=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
-USE_GCC= any
+USE_CSTD= gnu89
USE_GMAKE= yes
USE_GNOME= libxml2
USES= bison
@@ -286,7 +286,7 @@ post-patch:
${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/musiconhold.conf.sample
post-configure:
- @cd ${WRKSRC} && gmake menuselect.makeopts
+ @cd ${WRKSRC} && ${GMAKE} menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --disable res_timing_kqueue menuselect.makeopts
.if ${PORT_OPTIONS:MMYSQL}
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_config_mysql menuselect.makeopts