aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14-addons/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk14-addons/Makefile')
-rw-r--r--net/asterisk14-addons/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net/asterisk14-addons/Makefile b/net/asterisk14-addons/Makefile
new file mode 100644
index 000000000000..5e6173ef5a4a
--- /dev/null
+++ b/net/asterisk14-addons/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: asterisk-addons
+# Date created: 23 March 2006
+# Whom: Fabian Gast <fgast@only640k.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asterisk-addons
+PORTVERSION= 1.2.2
+CATEGORIES= net
+MASTER_SITES= http://ftp.digium.com/pub/asterisk/ \
+ http://ftp.digium.com/pub/asterisk/old-releases/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/ \
+ ftp://ftp.asterisk.org/pub/telephony/asterisk/old-releases/
+
+MAINTAINER= fgast@only640k.org
+COMMENT= Additional modules for the Asterisk Open Source PBX
+
+BUILD_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql41-client
+RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
+
+ONLY_FOR_ARCHS= i386 sparc64 amd64
+USE_GMAKE= yes
+
+CONF_SAMPLES= cdr_mysql.conf.sample res_mysql.conf.sample
+ASTETCDIR= ${PREFIX}/etc/asterisk
+
+post-patch:
+ @${REINPLACE_CMD} 's,^CFLAGS+=-I../asterisk,CFLAGS+=-I${LOCALBASE}/include,' ${WRKSRC}/Makefile
+
+post-install:
+ ${MKDIR} ${ASTETCDIR}
+.for f in ${CONF_SAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/configs/$f ${ASTETCDIR}
+.endfor
+
+.include <bsd.port.mk>