aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14/files/patch-cdr::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk14/files/patch-cdr::Makefile')
-rw-r--r--net/asterisk14/files/patch-cdr::Makefile45
1 files changed, 39 insertions, 6 deletions
diff --git a/net/asterisk14/files/patch-cdr::Makefile b/net/asterisk14/files/patch-cdr::Makefile
index f646d2c9a3dc..1d0fb2049ba2 100644
--- a/net/asterisk14/files/patch-cdr::Makefile
+++ b/net/asterisk14/files/patch-cdr::Makefile
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- cdr/Makefile.orig Tue Aug 31 19:33:00 2004
-+++ cdr/Makefile Thu Oct 14 19:13:38 2004
+--- cdr/Makefile.orig Tue Aug 31 23:33:00 2004
++++ cdr/Makefile Tue Aug 9 17:28:11 2005
@@ -21,7 +21,7 @@
OSARCH=$(shell uname -s)
@@ -12,7 +9,43 @@ $FreeBSD$
endif
#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
-@@ -71,7 +71,7 @@
+@@ -37,18 +37,23 @@
+ #
+ # unixODBC stuff...
+ #
++ifdef WITH_ODBC
+ MODS+=$(shell if [ -f "/usr/include/odbcinst.h" ]; then echo "cdr_odbc.so"; fi)
+ MODS+=$(shell if [ -f "/usr/local/include/odbcinst.h" ]; then echo "cdr_odbc.so"; fi)
++endif
+
+ #
+ # FreeTDS stuff...
+ #
++ifdef WITH_FREETDS
+ MODS+=$(shell if [ -f "/usr/include/tds.h" ]; then echo "cdr_tds.so"; fi)
+ MODS+=$(shell if [ -f "/usr/local/include/tds.h" ]; then echo "cdr_tds.so"; fi)
++endif
+
+ #
+ # PGSQL stuff... Autoconf anyone??
+ #
++ifdef WITH_PGSQL
+ MODS+=$(shell if [ -d /usr/local/pgsql/include ] || [ -d /usr/include/pgsql ] || [ -d /usr/local/include/pgsql ] || [ -d /opt/pgsql/include ] || [ -f /usr/include/libpq-fe.h ] ; then echo "cdr_pgsql.so"; fi)
+ CFLAGS+=$(shell if [ -d /usr/local/pgsql/include ]; then echo "-I/usr/local/pgsql/include"; fi)
+ CFLAGS+=$(shell if [ -d /usr/include/pgsql ]; then echo "-I/usr/include/pgsql"; fi)
+@@ -62,16 +67,19 @@
+ MLFLAGS+=$(shell if [ -d /usr/local/lib/pgsql ]; then echo "-L/usr/local/lib/pgsql"; fi)
+ MLFLAGS+=$(shell if [ -d /opt/pgsql/lib ]; then echo "-L/opt/pgsql/lib"; fi)
+ MLFLAGS+=$(shell if [ -f /usr/lib/libpq.so ]; then echo "-L/usr/lib"; fi)
++endif
+
+ #
+ # SQLIte stuff...
+ #
++ifdef WITH_SQLITE
+ MODS+=$(shell if [ -f "/usr/include/sqlite.h" ]; then echo "cdr_sqlite.so"; fi)
++endif
+
all: depend $(MODS)
install: all