aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk14/files/patch-channels::h323::Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk14/files/patch-channels::h323::Makefile')
-rw-r--r--net/asterisk14/files/patch-channels::h323::Makefile64
1 files changed, 0 insertions, 64 deletions
diff --git a/net/asterisk14/files/patch-channels::h323::Makefile b/net/asterisk14/files/patch-channels::h323::Makefile
deleted file mode 100644
index a9159b4441c1..000000000000
--- a/net/asterisk14/files/patch-channels::h323::Makefile
+++ /dev/null
@@ -1,64 +0,0 @@
-
-$FreeBSD$
-
---- channels/h323/Makefile.orig Sun Jan 11 04:22:32 2004
-+++ channels/h323/Makefile Fri Jan 30 01:47:34 2004
-@@ -19,7 +19,7 @@
- #
- # This needs to be updated to deal with more than just little endian machines
- #
--CFLAGS += -march=$(shell uname -m) -DPBYTE_ORDER=PLITTLE_ENDIAN
-+CFLAGS += -DPBYTE_ORDER=PLITTLE_ENDIAN
-
-
- #############################################
-@@ -27,38 +27,39 @@
- # Only change below if you know WTF your doing
- #
- CFLAGS += -DNDEBUG -DDO_CRASH -DDEBUG_THREADS
--CFLAGS += -pipe -Wall -fPIC -Wmissing-prototypes -Wmissing-declarations
--CFLAGS += -DP_LINUX -D_REENTRANT -D_GNU_SOURCE
-+CFLAGS += -Wall -fPIC
-+CFLAGS += -DP_FREEBSD=$(OSVERSION) -D_REENTRANT -D_GNU_SOURCE
- CFLAGS += -DP_HAS_SEMAPHORES -DP_SSL -DP_PTHREADS
- CFLAGS += -DPHAS_TEMPLATES -DPTRACING -DP_USE_PRAGMA
- CFLAGS += -I../../include
- CFLAGS += -I$(PWLIBDIR)/include/ptlib/unix -I$(PWLIBDIR)/include
--CFLAGS += -I$(OPENH323DIR)/include -Wno-missing-prototypes -Wno-missing-declarations
-+CFLAGS += -I$(OPENH323DIR)/include
-
-
- all: libchanh323.a
-
- samples:
-- if [ -f $(ASTETCDIR)/h323.conf ]; then \
-- mv -f $(ASTETCDIR)/h323.conf $(ASTETCDIR)/h323.conf.old ; \
-+ $(BSD_INSTALL_DATA) h323.conf.sample $(ASTETCDIR)/h323.conf-dist
-+ if ! [ -f $(ASTETCDIR)/h323.conf ]; then \
-+ $(BSD_INSTALL_DATA) h323.conf.sample $(ASTETCDIR)/h323.conf; \
- fi ;
-- install h323.conf.sample $(ASTETCDIR)/h323.conf
-
-
- ast_h323.o: ast_h323.cpp
-- g++ -g -c -o $@ $(CFLAGS) $<
-+ $(CXX) -c -o $@ $(CFLAGS) $<
-
- libchanh323.a: ast_h323.o
- ar cr libchanh323.a ast_h323.o
-
- chan_h323.so:
-- g++ -g -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_linux_x86_r -L$(OPENH323DIR)/lib -lh323_linux_x86_r -L/usr/lib -lpthread -ldl -lcrypto -lssl -lexpat
-+ $(CXX) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_linux_x86_r $(PTHREAD_LIBS) -lcrypto -lssl -lexpat
-
- chan_h323_d.so: chan_h323.o ast_h323.o
-- g++ -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_linux_x86_d -L$(OPENH323DIR)/lib -lh323_linux_x86_d -L/usr/lib -lpthread -ldl -lcrypto -lssl -lexpat
-+ $(CXX) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_linux_x86_d $(PTHREAD_LIBS) -lcrypto -lssl -lexpat
-
- chan_h323_s.so: chan_h323.o ast_h323.o
-- g++ -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_linux_x86_r_s -L$(OPENH323DIR)/lib -lh323_linux_x86_r_s -L/usr/lib -lpthread -ldl -lcrypto -lssl -lexpat
-+ $(CXX) -shared -Xlinker -x -o chan_h323.so chan_h323.o ast_h323.o -L$(PWLIBDIR)/lib -lpt_FreeBSD_x86_r_s -L$(OPENH323DIR)/lib -lh323_linux_x86_r_s $(PTHREAD_LIBS) -lcrypto -lssl -lexpat
-+
- clean:
- rm -f *.o *.so core.* libchanh323.a
-