aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk16/files/patch-main__Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk16/files/patch-main__Makefile')
-rw-r--r--net/asterisk16/files/patch-main__Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/net/asterisk16/files/patch-main__Makefile b/net/asterisk16/files/patch-main__Makefile
new file mode 100644
index 000000000000..21f82c0fa065
--- /dev/null
+++ b/net/asterisk16/files/patch-main__Makefile
@@ -0,0 +1,16 @@
+--- main/Makefile.orig 2018-08-08 16:02:31 UTC
++++ main/Makefile
+@@ -80,9 +80,12 @@ endif
+
+ ifeq ($(OSARCH),FreeBSD)
+ # -V is understood by BSD Make, not by GNU make.
+- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
++ BSDVERSION=$(OSVERSION)
++ BSDVERSION?=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
+ AST_LIBS+=$(shell if test $(BSDVERSION) -lt 502102 ; then echo "-lc_r"; else echo "-pthread"; fi)
++ CRYPT_LIB=$(shell if test $(BSDVERSION) -ge 1200001 ; then echo "-lcrypt"; fi)
+ AST_LIBS+=-lcrypto
++ AST_LIBS+=%%LIBSYSINFO%%
+ endif
+
+ ifneq ($(findstring $(OSARCH), mingw32 cygwin ),)