aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk18
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk18')
-rw-r--r--net/asterisk18/Makefile3
-rw-r--r--net/asterisk18/files/patch-menuselect_configure11
2 files changed, 12 insertions, 2 deletions
diff --git a/net/asterisk18/Makefile b/net/asterisk18/Makefile
index c0096ead9d8a..400744ea8729 100644
--- a/net/asterisk18/Makefile
+++ b/net/asterisk18/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libuuid.so:misc/e2fsprogs-libuuid \
libjansson.so:devel/jansson
USES= bison compiler:c11 cpe gmake gnome iconv libedit localbase \
- shebangfix sqlite ssl ncurses
+ pkgconfig shebangfix sqlite ssl ncurses
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_RC_SUBR= asterisk
@@ -166,7 +166,6 @@ PGSQL_CONFIGURE_WITH= postgres
PGSQL_USES= pgsql
PJSIP_CONFIGURE_WITH= pjproject pjproject-bundled
-PJSIP_USES= pkgconfig
PJSIP_LIB_DEPENDS= libsrtp2.so:net/libsrtp2 \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp
diff --git a/net/asterisk18/files/patch-menuselect_configure b/net/asterisk18/files/patch-menuselect_configure
new file mode 100644
index 000000000000..0447a4c09766
--- /dev/null
+++ b/net/asterisk18/files/patch-menuselect_configure
@@ -0,0 +1,11 @@
+--- menuselect/configure.orig 2022-05-12 11:50:59 UTC
++++ menuselect/configure
+@@ -5024,7 +5024,7 @@ printf "%s\n" "yes" >&6; }
+ printf "%s\n" "yes" >&6; }
+
+ PBX_LIBXML2=1
+- LIBXML2_INCLUDE=$(echo ${LIBXML2_CFLAGS} | $SED -e "s|-std=c99||g")
++ LIBXML2_INCLUDE=$(echo ${LIBXML2_CFLAGS} | sed -e "s|-std=c99||g")
+ LIBXML2_LIB="$LIBXML2_LIBS"
+
+ printf "%s\n" "#define HAVE_LIBXML2 1" >>confdefs.h