aboutsummaryrefslogtreecommitdiff
path: root/net/bird-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/bird-devel/Makefile')
-rw-r--r--net/bird-devel/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/bird-devel/Makefile b/net/bird-devel/Makefile
index 8421380086e5..3957cb8d5090 100644
--- a/net/bird-devel/Makefile
+++ b/net/bird-devel/Makefile
@@ -18,7 +18,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --enable-mpls
USE_CSTD= gnu89
-OPTIONS= KMPLS "Enable kernel MPLS support" Off
+OPTIONS_DEFINE= KMPLS
+KMPLS_DESC= kernel MPLS support
MAKE_JOBS_UNSAFE= yes
@@ -26,7 +27,7 @@ USE_RC_SUBR= bird
.include <bsd.port.pre.mk>
-.if defined(WITH_KMPLS)
+.if ${PORT_OPTIONS:MKMPLS}
CONFIGURE_ARGS+= --enable-kmpls
.endif