aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/boinc-client/Makefile')
-rw-r--r--net/boinc-client/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index cc6f05986c06..7e2e18c4ecd4 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= boinc-client
-PORTVERSION= 5.8.17
+PORTVERSION= 5.10.32
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
@@ -66,6 +66,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gui_rpc_auth.cfg|${BOINC_HOME}/gui_rpc_auth.cfg|g' \
${WRKSRC}/client/file_names.h ${WRKSRC}/lib/boinc_cmd.C \
${WRKSRC}/clientgui/MainDocument.cpp
+ @${REINPLACE_CMD} -e 's|../curl/ca-bundle.crt||' ${WRKSRC}/client/Makefile.in
@${REINPLACE_CMD} -e 's|ca-bundle.crt|${LOCALBASE}/share/curl/curl-ca-bundle.crt|' ${WRKSRC}/client/http_curl.C
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/clientgui/stdwx.h