aboutsummaryrefslogtreecommitdiff
path: root/net/bredbandskollen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/bredbandskollen/Makefile')
-rw-r--r--net/bredbandskollen/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/bredbandskollen/Makefile b/net/bredbandskollen/Makefile
index 896e7c58d731..4c43dba8af7d 100644
--- a/net/bredbandskollen/Makefile
+++ b/net/bredbandskollen/Makefile
@@ -9,7 +9,7 @@ COMMENT= Command line tool to check internet connection speed
LICENSE= GPLv2
-USES= gmake
+USES= compiler:c++11-lang gmake
USE_GITHUB= yes
GH_ACCOUNT= dotse
@@ -26,6 +26,10 @@ OPTIONS_DEFINE= GNUTLS
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_MAKE_ARGS= GNUTLS=1
+post-patch:
+ ${REINPLACE_CMD} -e 's/CXX = c++/CXX ?= c++/g' \
+ ${WRKSRC}/src/framework/mk.inc
+
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/cli ${STAGEDIR}/${PREFIX}/bin/bbk_cli
${LN} -sf bbk_cli ${STAGEDIR}/${PREFIX}/bin/bredbandskollen