aboutsummaryrefslogtreecommitdiff
path: root/net/callweaver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/callweaver/Makefile')
-rw-r--r--net/callweaver/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/net/callweaver/Makefile b/net/callweaver/Makefile
index 9369b130bf89..79950829acc8 100644
--- a/net/callweaver/Makefile
+++ b/net/callweaver/Makefile
@@ -6,7 +6,7 @@
PORTNAME= callweaver
PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= http://devs.callweaver.org/release/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -25,8 +25,12 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-pic
USE_RC_SUBR= callweaver
-USERS= callweaver
-GROUPS= callweaver
+CWUSER= callweaver
+CWGROUP= callweaver
+
+USERS= ${CWUSER}
+GROUPS= ${CWGROUP}
+PLIST_SUB+= CWUSER=${CWUSER} CWGROUP=${CWGROUP}
MAN8= callweaver.8 safe_callweaver.8
@@ -46,9 +50,9 @@ OPTIONS= SIPTCP "Enable SIP TCP/TLS support" on \
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS+= --with-man-pages
+CONFIGURE_ARGS+= --with-readme --with-license --with-credits
.else
-CONFIGURE_ARGS+= --without-man-pages
+CONFIGURE_ARGS+= --without-readme --without-license --without-credits
.endif
.if defined(WITH_SIPTCP)