aboutsummaryrefslogtreecommitdiff
path: root/net/cap/files/patch-ac
diff options
context:
space:
mode:
Diffstat (limited to 'net/cap/files/patch-ac')
-rw-r--r--net/cap/files/patch-ac36
1 files changed, 32 insertions, 4 deletions
diff --git a/net/cap/files/patch-ac b/net/cap/files/patch-ac
index f6a136923b41..299819508c3c 100644
--- a/net/cap/files/patch-ac
+++ b/net/cap/files/patch-ac
@@ -7,8 +7,8 @@
compat.h sysvcompat.h macfile.h abnbp.h fcntldomv.h afppass.h
--- etc/Makefile.m4.orig Sun Mar 8 22:46:19 1992
-+++ etc/Makefile.m4 Sat Nov 30 09:36:23 1996
-@@ -1,11 +1,12 @@
++++ etc/Makefile.m4 Sun Jan 26 00:19:02 1997
+@@ -1,17 +1,20 @@
CFLAGS=cflags() nbpflags() specialcflags()
SDESTDIR=capsrvrdestdir()
UDESTDIR=capdestdir()
@@ -17,8 +17,36 @@
I=includedir()
# for other libraries (like BSD on hpux)
SLIB=libspecial()
-+
-+ETCDIR=/var/run
++ETCDIR=/var/run
++
ifdef([useatis],[],[# ])ATISPROGS=atis
PROGS=${ATISPROGS}
+
+ # aufs.c definitions: USEVPRINTF - use vprintf in logging
+ ifdef([usevprintf],[],[#])ATISDEFS=-DUSEVPRINTF
++
++ATISDEFS+=-DNISDUMPFILE=\"/var/tmp/nis.db\" -DATISRUNFILE=\"/var/tmp/atis.run\"
+
+ # Make sure to define needgetopt if your system doesnt have it or
+ # just set GETOPT=att_getopt.o (or to a getopt of your own liking)
+--- support/uab/Makefile.m4.orig Sun Mar 8 22:46:21 1992
++++ support/uab/Makefile.m4 Sun Jan 26 00:46:55 1997
+@@ -5,6 +5,8 @@
+ CAPLIB=libcap()
+ LFLAGS=
+
++UABDEFS=-DUAB_RUNFILE=\"/var/tmp/uab.run\" -DUAB_STATSFILE=\"/var/tmp/uab.stats\" -DUAB_DUMPFILE=\"/var/tmp/uab.dump\"
++
+ SRCS=aarp.c kip_mpx.c rtmp.c ethertalk.c ddprouter.c ddpsvcs.c ddpport.c \
+ hash.c asyncatalk.c
+ OBJS=aarp.o kip_mpx.o rtmp.o ethertalk.o ddprouter.o ddpsvcs.o ddpport.o \
+@@ -28,7 +30,7 @@
+ ${CC} -c ${CFLAGS} -DTAB=etalklocal() -DMTAB=etalklocal() kip_mpx.c
+
+ uab.o: uab.c mpxddp.h gw.h node.h ddpport.h if_desc.h
+- ${CC} -c ${CFLAGS} -DUAB_PIDFILE=uabpidfile() \
++ ${CC} -c ${CFLAGS} ${UABDEFS} -DUAB_PIDFILE=uabpidfile() \
+ -DBRIDGE_DESC=uabbrdescr() uab.c
+
+ lint: