aboutsummaryrefslogtreecommitdiff
path: root/net/ciscoconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ciscoconf/Makefile')
-rw-r--r--net/ciscoconf/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/ciscoconf/Makefile b/net/ciscoconf/Makefile
new file mode 100644
index 000000000000..9f4f086e9b76
--- /dev/null
+++ b/net/ciscoconf/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ciscoconf
+# Version required: 1.0beta1
+# Date created: 11 September 1998
+# Whom: jabley@clear.co.nz
+#
+# $Id:$
+#
+
+DISTNAME= ciscoconf-1.0beta1
+PKGNAME= ciscoconf-1.0
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.patho.gen.nz/pub/users/jabley/ \
+ http://www.FreeBSD.org/~billf/
+
+MAINTAINER= jabley@clear.co.nz
+
+ALL_TARGET= depend all
+MAN8= ciscoconfd.8 ciscoconfr.8
+
+post-patch:
+
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.old
+ ${CAT} ${WRKSRC}/Makefile.old | \
+ ${SED} -e 's#/usr/local#${PREFIX}#g' | \
+ ${SED} -e 's#lib/cisco#share/cisco#' \
+ >> ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ciscoconfd ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ciscoconfr ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ciscoconfd.man ${PREFIX}/man/man8/ciscoconfd.8
+ ${INSTALL_MAN} ${WRKSRC}/ciscoconfr.man ${PREFIX}/man/man8/ciscoconfr.8
+
+post-install:
+ ${MKDIR} ${PREFIX}/share/cisco/RCS
+
+.include <bsd.port.mk>