aboutsummaryrefslogtreecommitdiff
path: root/net/citrix_ica/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/citrix_ica/Makefile')
-rw-r--r--net/citrix_ica/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 07edcab5ef65..9686f083cdf0 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= citrix_ica
-PORTVERSION= 3.0.15
+PORTVERSION= 6.0.908
CATEGORIES= net comms linux
-MASTER_SITES=
-DISTNAME= linux
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES=
+DISTNAME= linuxx86
-MAINTAINER= msmith@FreeBSD.org
+MAINTAINER= mb@imp.ch
RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
@@ -24,13 +23,13 @@ DIST_SUBDIR= citrix_ica
NO_WRKSUBDIR= Yes
NO_BUILD= Yes
-CDIR= ${PREFIX}/lib/ICAClient
+CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE='The distribution file for this port may not be automatically fetched due to licensing restrictions. You MUST fetch the file manually after reading and agreeing to the license at: http://download.citrix.com/download.asp?client=LINUX Once ${DISTFILES} has been downloaded, move it to ${DISTDIR}/${DIST_SUBDIR} and then restart this build.'
+IGNORE='The distribution file for this port may not be automatically fetched due to licensing restrictions. You MUST fetch the file manually after reading and agreeing to the license at: http://www.citrix.com/download/bin/license.asp?client=linux Once ${DISTFILES} has been downloaded, move it to ${DISTDIR}/${DIST_SUBDIR} and then restart this build.'
.endif
do-install:
@@ -40,7 +39,7 @@ do-install:
> ${WRKSRC}/wfcmgr.x
${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
> ${WRKSRC}/wfica.x
- cd ${WRKSRC} && ./setupwfc < response
+ cd ${WRKSRC} && ${LINUXBASE}/bin/sh -c './setupwfc < response'
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica