aboutsummaryrefslogtreecommitdiff
path: root/net/cyphesis
diff options
context:
space:
mode:
Diffstat (limited to 'net/cyphesis')
-rw-r--r--net/cyphesis/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index c66c4bd6de18..a7acd0f77457 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= Server for WorldForge games
+LICENSE= GPLv2
+
LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
libvarconf-1.0.so:${PORTSDIR}/devel/varconf \
libwfmath-1.0.so:${PORTSDIR}/math/wfmath \
@@ -20,6 +22,8 @@ LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
CONFIGURE_ARGS= --with-python=${LOCALBASE}
+BROKEN= Does not compile with clang
+
GNU_CONFIGURE= yes
USE_BZIP2= yes
USES= gmake pathfix pkgconfig compiler:c++11-lib
@@ -61,8 +65,8 @@ post-install:
.for file in README COPYING AUTHORS THANKS NEWS ChangeLog TODO FIXME
@${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.for file in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
- @${INSTALL_DATA} ${WRKSRC}/data/${file} ${STAGEDIR}${DOCSDIR}/conf
+.for xmlfile in acorn.xml basic.xml cyphesis.vconf mason.xml werewolf.xml
+ @${INSTALL_DATA} ${WRKSRC}/data/${xmlfile} ${STAGEDIR}${DOCSDIR}/conf
.endfor
.endif