aboutsummaryrefslogtreecommitdiff
path: root/net/despoof/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/despoof/Makefile')
-rw-r--r--net/despoof/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/net/despoof/Makefile b/net/despoof/Makefile
index 347b4c01c8a3..9ad19be9b7a9 100644
--- a/net/despoof/Makefile
+++ b/net/despoof/Makefile
@@ -7,7 +7,7 @@
PORTNAME= despoof
PORTVERSION= 0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net security
MASTER_SITES= http://www.bindview.com/Resources/RAZOR/Files/ \
${MASTER_SITE_PACKETSTORM}
@@ -17,11 +17,24 @@ EXTRACT_SUFX= .tgz
MAINTAINER= roam@FreeBSD.org
COMMENT= Command-line anti-spoofing detection utility
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-I$${LOCALBASE}/include ||; \
+ s|-L$${LOCALBASE}/lib ||; \
+ s|--defines|& --cflags|; \
+ s|libnet-config|${LIBNET_CONFIG}|; \
+ s|-lnet |`${LIBNET_CONFIG} --libs` |' \
+ ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/despoof ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/doc/despoof
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/despoof
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>