aboutsummaryrefslogtreecommitdiff
path: root/net/dhcp6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/dhcp6/Makefile')
-rw-r--r--net/dhcp6/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
index 3e6d029da261..ba9f58d4cf4c 100644
--- a/net/dhcp6/Makefile
+++ b/net/dhcp6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dhcp6
PORTVERSION= 20040816a
-CATEGORIES= net
+CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.kame.net/pub/kame/misc/
DISTNAME= kame-${PORTNAME}-${PORTVERSION}
@@ -15,6 +15,7 @@ MAINTAINER= sumikawa@FreeBSD.org
COMMENT= KAME DHCP6 client and server
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_RC_SUBR= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${LOCALBASE}/etc --with-localdbdir=/var/db
USE_REINPLACE= yes
@@ -22,11 +23,19 @@ USE_REINPLACE= yes
MAN5= dhcp6c.conf.5 dhcp6s.conf.5
MAN8= dhcp6c.8 dhcp6s.8 dhcp6relay.8 dhcp6sctl.8
+RC_SCRIPTS= dhcp6c.sh dhcp6relay.sh dhcp6s.sh
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
+ RC_SUBR=${RC_SUBR}
+
post-patch:
.for file in ${MAN5} ${MAN8}
${REINPLACE_CMD} -e 's|/usr/local/v6/etc|${LOCALBASE}/etc|' \
${WRKSRC}/${file}
.endfor
+.for f in ${RC_SCRIPTS}
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/${f} > ${WRKDIR}/${f}
+.endfor
post-install:
.if !defined(NOPORTDOCS)
@@ -35,5 +44,8 @@ post-install:
.endif
${INSTALL_DATA} ${WRKSRC}/dhcp6c.conf.sample ${PREFIX}/etc
${INSTALL_DATA} ${WRKSRC}/dhcp6s.conf.sample ${PREFIX}/etc
+.for f in ${RC_SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKDIR}/${f} ${PREFIX}/etc/rc.d/${f}
+.endfor
.include <bsd.port.mk>