aboutsummaryrefslogtreecommitdiff
path: root/net/ekiga
diff options
context:
space:
mode:
Diffstat (limited to 'net/ekiga')
-rw-r--r--net/ekiga/Makefile52
-rw-r--r--net/ekiga/distinfo2
-rw-r--r--net/ekiga/files/patch-endpoint37
-rw-r--r--net/ekiga/files/patch-lib_xdap_xdap.c11
-rw-r--r--net/ekiga/pkg-descr9
-rw-r--r--net/ekiga/pkg-plist59
6 files changed, 0 insertions, 170 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
deleted file mode 100644
index 0a3b656f8f82..000000000000
--- a/net/ekiga/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# Ports collection Makefile for: gnomemeeting
-# Date created: 24/07/2001
-# Whom: roger@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomemeeting
-PORTVERSION= 0.98.5
-PORTREVISION= 4
-CATEGORIES= net gnome
-MASTER_SITES= ftp://ftp.gnome.org/pub/GNOME/sources/gnomemeeting/0.98/ \
- # http://www.gnomemeeting.org/downloads/0.98.0/sources/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GNOME H323 Video Conferencing program, similar to NetMeeting
-
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
-
-BROKEN= "Does not build"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
-
-# note, we do not want to clean openh323, otherwise it has to build
-# it all over again which can take several hours.
-NOCLEANDEPENDS= yes
-
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_GNOME= libgnomeui libbonobo gnomeprefix gnomehack
-USE_OPENLDAP= yes
-USE_BISON= yes
-# Clear configure target so we stop getting binaries prefixed with i386-portbld-freebsd46
-CONFIGURE_TARGET=
-GNU_CONFIGURE= YES
-CONFIGURE_ENV= OSTYPE=${OPSYS} \
- LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
- PTLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
- OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323 \
- SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
- CPPFLAGS="-I${LOCALBASE}/include"
-
-CONFIGURE_ARGS= --with-ptlib-includes=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/include/ptlib \
- --with-ptlib-libs=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/lib \
- --with-openh323-includes=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/include \
- --with-openh323-libs=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/lib \
- --with-ldap-includes=${LOCALBASE}/include \
- --with-openldap-libs=${LOCALBASE}/lib
-
-MAN1= gnomemeeting.1
-.include <bsd.port.mk>
diff --git a/net/ekiga/distinfo b/net/ekiga/distinfo
deleted file mode 100644
index 23959edbe677..000000000000
--- a/net/ekiga/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (gnomemeeting-0.98.5.tar.bz2) = fa11d5f3e6adb924f91aaa92099b6269
-SIZE (gnomemeeting-0.98.5.tar.bz2) = 1739613
diff --git a/net/ekiga/files/patch-endpoint b/net/ekiga/files/patch-endpoint
deleted file mode 100644
index c906400224db..000000000000
--- a/net/ekiga/files/patch-endpoint
+++ /dev/null
@@ -1,37 +0,0 @@
-*** src/endpoint.cpp.orig Thu Jul 31 17:26:36 2003
---- src/endpoint.cpp Fri Sep 5 11:40:58 2003
-*************** GMH323EndPoint::GMH323EndPoint ()
-*** 176,183 ****
-
- /* Use IPv6 address family by default if available. */
- #ifdef P_HAS_IPV6
-! if (PIPSocket::IsIpAddressFamilyV6Supported())
-! PIPSocket::SetDefaultIpAddressFamilyV6();
- #endif
-
- rtp_port_range =
---- 176,185 ----
-
- /* Use IPv6 address family by default if available. */
- #ifdef P_HAS_IPV6
-! // ENABLING THIS CAUSES PWLIB TO GIVE AN ASSERTION WHEN THERE IS AN
-! // INCOMING CALL
-! // if (PIPSocket::IsIpAddressFamilyV6Supported())
-! // PIPSocket::SetDefaultIpAddressFamilyV6();
- #endif
-
- rtp_port_range =
-*************** GMH323EndPoint::TranslateTCPAddress(PIPS
-*** 682,687 ****
---- 684,694 ----
-
- && !((remoteAddr.Byte1() == 172)
- && ((remoteAddr.Byte2() >= 16)&&(remoteAddr.Byte2()<=31)))
-+
-+ && !((remoteAddr.Byte1() == 127)
-+ &&(remoteAddr.Byte2()== 0)
-+ &&(remoteAddr.Byte3()==0)
-+ &&(remoteAddr.Byte4()==1))
-
- && !(remoteAddr.Byte1() == 10)) {
-
diff --git a/net/ekiga/files/patch-lib_xdap_xdap.c b/net/ekiga/files/patch-lib_xdap_xdap.c
deleted file mode 100644
index 6ee81f64df0d..000000000000
--- a/net/ekiga/files/patch-lib_xdap_xdap.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/xdap/xdap.c.orig Tue Oct 28 21:28:24 2003
-+++ lib/xdap/xdap.c Tue Oct 28 21:49:59 2003
-@@ -159,7 +159,7 @@
- xmlSAXHandler sax;
-
- memset (&sax, 0, sizeof sax);
-- sax = xmlDefaultSAXHandler; /* Copy original handler */
-+ xmlSAX2InitDefaultSAXHandler (&sax, 0);
- *oldgetent = sax.getEntity; /* Substitute entity handling */
- if (noerr) {
- sax.error = NULL; /* Disable errors and warnings */
diff --git a/net/ekiga/pkg-descr b/net/ekiga/pkg-descr
deleted file mode 100644
index 9a8d6e495a8d..000000000000
--- a/net/ekiga/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Gnomemeeting is a Video Conferencing application which uses the H323
-protocol and the OpenH323 libraries.
-
-It can connect to a variety of other H323 applications including
-Microsoft NetMeeting, OpenMCU, OpenAM, OhPhone and CPhone.
-
-WWW: http://www.gnomemeeting.org/
-
-Roger Hardiman <roger@freebsd.org>
diff --git a/net/ekiga/pkg-plist b/net/ekiga/pkg-plist
deleted file mode 100644
index 914786a58cba..000000000000
--- a/net/ekiga/pkg-plist
+++ /dev/null
@@ -1,59 +0,0 @@
-share/gnome/pixmaps/gnomemeeting-logo-icon.png
-share/gnome/pixmaps/gnomemeeting-logo.png
-share/gnome/pixmaps/gnomemeeting-splash.png
-bin/gnomemeeting
-bin/gnomemeeting-config-tool
-libdata/bonobo/servers/gnomemeeting.server
-share/locale/am/LC_MESSAGES/gnomemeeting.mo
-share/locale/az/LC_MESSAGES/gnomemeeting.mo
-share/locale/be/LC_MESSAGES/gnomemeeting.mo
-share/locale/ca/LC_MESSAGES/gnomemeeting.mo
-share/locale/cs/LC_MESSAGES/gnomemeeting.mo
-share/locale/cy/LC_MESSAGES/gnomemeeting.mo
-share/locale/da/LC_MESSAGES/gnomemeeting.mo
-share/locale/de/LC_MESSAGES/gnomemeeting.mo
-share/locale/el/LC_MESSAGES/gnomemeeting.mo
-share/locale/es/LC_MESSAGES/gnomemeeting.mo
-share/locale/fi/LC_MESSAGES/gnomemeeting.mo
-share/locale/fr/LC_MESSAGES/gnomemeeting.mo
-share/locale/ga/LC_MESSAGES/gnomemeeting.mo
-share/locale/gl/LC_MESSAGES/gnomemeeting.mo
-share/locale/hi/LC_MESSAGES/gnomemeeting.mo
-share/locale/hu/LC_MESSAGES/gnomemeeting.mo
-share/locale/it/LC_MESSAGES/gnomemeeting.mo
-share/locale/ja/LC_MESSAGES/gnomemeeting.mo
-share/locale/ko/LC_MESSAGES/gnomemeeting.mo
-share/locale/lv/LC_MESSAGES/gnomemeeting.mo
-share/locale/ml/LC_MESSAGES/gnomemeeting.mo
-share/locale/ms/LC_MESSAGES/gnomemeeting.mo
-share/locale/nl/LC_MESSAGES/gnomemeeting.mo
-share/locale/no/LC_MESSAGES/gnomemeeting.mo
-share/locale/pl/LC_MESSAGES/gnomemeeting.mo
-share/locale/pt/LC_MESSAGES/gnomemeeting.mo
-share/locale/pt_BR/LC_MESSAGES/gnomemeeting.mo
-share/locale/ro/LC_MESSAGES/gnomemeeting.mo
-share/locale/ru/LC_MESSAGES/gnomemeeting.mo
-share/locale/sk/LC_MESSAGES/gnomemeeting.mo
-share/locale/sq/LC_MESSAGES/gnomemeeting.mo
-share/locale/sr/LC_MESSAGES/gnomemeeting.mo
-share/locale/sr@Latn/LC_MESSAGES/gnomemeeting.mo
-share/locale/sv/LC_MESSAGES/gnomemeeting.mo
-share/locale/ta/LC_MESSAGES/gnomemeeting.mo
-share/locale/tr/LC_MESSAGES/gnomemeeting.mo
-share/locale/uk/LC_MESSAGES/gnomemeeting.mo
-share/locale/vi/LC_MESSAGES/gnomemeeting.mo
-share/locale/wa/LC_MESSAGES/gnomemeeting.mo
-share/locale/zh_CN/LC_MESSAGES/gnomemeeting.mo
-share/locale/zh_TW/LC_MESSAGES/gnomemeeting.mo
-share/gnome/sounds/gnomemeeting/gnomemeeting.wav
-etc/sound/events/gnomemeeting.soundlist
-share/gnome/gnomemeeting/xdap/ils_nm_reg.xml
-share/gnome/gnomemeeting/xdap/ils_nm_unreg.xml
-share/gnome/gnomemeeting/xdap/ils_nm_mod.xml
-share/gnome/applications/gnomemeeting.desktop
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnomemeeting.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/gnomemeeting.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnomemeeting.schemas > /dev/null || /usr/bin/true
-@dirrm share/gnome/sounds/gnomemeeting
-@dirrm share/gnome/gnomemeeting/xdap
-@dirrm share/gnome/gnomemeeting