aboutsummaryrefslogtreecommitdiff
path: root/net/etherboot
diff options
context:
space:
mode:
Diffstat (limited to 'net/etherboot')
-rw-r--r--net/etherboot/Makefile7
-rw-r--r--net/etherboot/distinfo2
-rw-r--r--net/etherboot/files/patch-aa38
3 files changed, 41 insertions, 6 deletions
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index 39f6c25baf65..e9e09356faff 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -1,16 +1,17 @@
# New ports collection makefile for: etherboot
-# Version required: 4.2.9
+# Version required: 4.2.11
# Date created: 16 April 1999
# Whom: Doug Ambrisko <ambrisko@whistle.com>
#
# $FreeBSD$
#
-DISTNAME= etherboot-4.2.9
+DISTNAME= etherboot-4.2.11
PKGNAME= etherboot-4.2
CATEGORIES= net
MASTER_SITES= http://www.slug.org.au/etherboot/ \
- http://www.us.kernel.org/pub/linux/devel/gcc/
+ http://www.us.kernel.org/pub/linux/devel/gcc/ \
+ http://www.ambrisko.com/doug/
DISTFILES= ${DISTNAME}.tar.gz ${BINUTILS_VER}.tar.gz
MAINTAINER= ambrisko@whistle.com
diff --git a/net/etherboot/distinfo b/net/etherboot/distinfo
index 78ef74d1d180..e105ad1170bd 100644
--- a/net/etherboot/distinfo
+++ b/net/etherboot/distinfo
@@ -1,2 +1,2 @@
-MD5 (etherboot-4.2.9.tar.gz) = 3af0e7dbd0e094ebfd287f9639b60722
+MD5 (etherboot-4.2.11.tar.gz) = 9fe7c9a689dfbb7f90b7afa453922598
MD5 (binutils-2.9.1.0.25.tar.gz) = 2350a282f8fd53b409f523e77fccb904
diff --git a/net/etherboot/files/patch-aa b/net/etherboot/files/patch-aa
index 23cb19ffbb59..0e51fdf3df87 100644
--- a/net/etherboot/files/patch-aa
+++ b/net/etherboot/files/patch-aa
@@ -1,5 +1,5 @@
-*** Makefile.orig Fri Oct 22 09:17:37 1999
---- Makefile Fri Oct 22 09:18:27 1999
+*** Makefile.orig Thu Nov 25 00:34:35 1999
+--- Makefile Mon Nov 29 14:25:36 1999
***************
*** 74,79 ****
--- 74,80 ----
@@ -10,3 +10,37 @@
IDENT= 'Etherboot/$(BITS) $(VERSION) (GPL) $@'
# Stack must be below 640kb so we have real memory there
+***************
+*** 102,108 ****
+
+ # Exactly one of the following definitions for AS86 should be uncommented
+ # If you have not made any changes to the *.asm files (most people)
+! AS86= none
+ # If you have made changes to the *.asm files
+ # and you want to rebuild *loader.bin and floppyload.bin and you have as86
+ # from the ELKS Dev86 package (not the one that normally comes with Linux)
+--- 103,109 ----
+
+ # Exactly one of the following definitions for AS86 should be uncommented
+ # If you have not made any changes to the *.asm files (most people)
+! #AS86= none
+ # If you have made changes to the *.asm files
+ # and you want to rebuild *loader.bin and floppyload.bin and you have as86
+ # from the ELKS Dev86 package (not the one that normally comes with Linux)
+***************
+*** 111,117 ****
+ # If you have made changes to the *.asm files
+ # and you want to rebuild *loader.bin and floppyload.bin and you have nasm
+ # (not most people)
+! #AS86= nasm
+
+ # if your as has trouble with the data32 directive, uncomment this
+ # but note that the premade start*.o will be larger than necessary because it
+--- 112,118 ----
+ # If you have made changes to the *.asm files
+ # and you want to rebuild *loader.bin and floppyload.bin and you have nasm
+ # (not most people)
+! AS86= nasm
+
+ # if your as has trouble with the data32 directive, uncomment this
+ # but note that the premade start*.o will be larger than necessary because it