aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius2
diff options
context:
space:
mode:
Diffstat (limited to 'net/freeradius2')
-rw-r--r--net/freeradius2/Makefile99
-rw-r--r--net/freeradius2/distinfo4
-rw-r--r--net/freeradius2/files/patch-CVE-2012-354711
-rw-r--r--net/freeradius2/files/patch-configure.in39
-rw-r--r--net/freeradius2/files/patch-perl61
-rw-r--r--net/freeradius2/files/patch-pthread147
-rw-r--r--net/freeradius2/files/patch-src__include__sysutmp.h20
-rw-r--r--net/freeradius2/files/patch-src__modules__rlm_perl__configure.in22
-rw-r--r--net/freeradius2/pkg-plist30
9 files changed, 136 insertions, 297 deletions
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index e216ef87f216..afcc23326262 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= freeradius
-DISTVERSION= 2.1.12
-PORTREVISION= 2
+DISTVERSION= 2.2.0
CATEGORIES= net
MASTER_SITES= ftp://ftp.freeradius.org/pub/freeradius/%SUBDIR%/ \
ftp://ftp.ntua.gr/pub/net/radius/freeradius/%SUBDIR%/ \
@@ -44,30 +43,29 @@ MAKE_JOBS_UNSAFE= yes
PLIST_SUB= PORTVERSION=${DISTVERSION}
-OPTIONS= USER "Run as user freeradius, group freeradius" on \
- KERBEROS "With Kerberos support" off \
- HEIMDAL "With Heimdal Kerberos support" off \
- HEIMDAL_PORT "Use Heimdal Kerberos from ports" off \
- HEIMDAL_PATCH "Enhanced Heimdal support (specify SPN/keytab)" off \
- LDAP "With LDAP database support" off \
- MYSQL "With MySQL database support" off \
- PGSQL "With PostgreSQL database support" off \
- UNIXODBC "With unixODBC database support" off \
- FIREBIRD "With Firebird database support (EXPERIMENTAL)" off \
- PERL "With Perl support" on \
- PYTHON "With Python support" on \
- OCI8 "With Oracle support (currently experimental)" off \
- RUBY "With Ruby support (EXPERIMENTAL)" off \
- DHCP "With DHCP support (EXPERIMENTAL)" off \
- EXPERIMENTAL "Build experimental modules" off \
- UDPFROMTO "Compile in UDPFROMTO support" off
+OPTIONS_DEFINE= USER KERBEROS HEIMDAL HEIMDAL_PORT HEIMDAL_PATCH LDAP MYSQL \
+ PGSQL UNIXODBC FIREBIRD PERL PYTHON OCI8 RUBY DHCP \
+ EXPERIMENTAL UDPFROMTO DEVELOPER
+OPTIONS_DEFAULT=USER PERL PYTHON
+
+DHCP_DESC= With DHCP support (EXPERIMENTAL)
+USER_DESC= Run as user freeradius, group freeradius
+HEIMDAL_DESC= With Heimdal Kerberos support
+HEIMDAL_PORT_DESC= With Heimdal Kerberos from ports
+HEIMDAL_PATCH_DESC= Enhanced Heimdal support (specify SPN/keytab)
+UNIXODBC_DESC= With unixODBC database support
+FIREBIRD_DESC= With Firebird database support (EXPERIMENTAL)
+OCI8_DESC= With Oracle support (currently experimental)
+EXPERIMENTAL_DESC= Build experimental modules
+UDPFROMTO_DESC= Compile in UDPFROMTO support
+DEVELOPER_DESC= Enable developer options
.include <bsd.port.options.mk>
# Default requirements for rc script
_REQUIRE= NETWORKING SERVERS
-.ifdef(WITH_USER)
+.if ${PORT_OPTIONS:MUSER}
SUB_LIST+= RUN_AS_USER="yes"
.else
SUB_LIST+= RUN_AS_USER="no"
@@ -80,15 +78,16 @@ RADIUS_GROUP= freeradius
USERS= ${RADIUS_USER}
GROUPS= ${RADIUS_GROUP}
-CONFIGURE_ARGS+= --with-system-libtool --with-system-libltdl --disable-ltdl-install
+CONFIGURE_ARGS+=--with-system-libtool --with-system-libltdl \
+ --disable-ltdl-install
-.if defined(WITH_HEIMDAL) && !defined(WITH_KERBEROS)
-WITH_KERBEROS= yes
+.if ${PORT_OPTIONS:MHEIMDAL} && empty(${PORT_OPTIONS:MKERBEROS})
+${UNIQUENAME}_SET+= KERBEROS
.endif
-.ifdef(WITH_KERBEROS)
-.ifdef(WITH_HEIMDAL)
-.ifdef(WITH_HEIMDAL_PORT)
+.if ${PORT_OPTIONS:MKERBEROS}
+.if ${PORT_OPTIONS:MHEIMDAL}
+.if ${PORT_OPTIONS:MHEIMDAL_PORT}
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
.endif
CONFIGURE_ARGS+=--enable-heimdal-krb5
@@ -96,7 +95,7 @@ CONFIGURE_ARGS+=--enable-heimdal-krb5
LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
.endif
CONFIGURE_ARGS+=--with-rlm_krb5
-.if defined (WITH_HEIMDAL) && !defined(WITH_HEIMDAL_PORT)
+.if ${PORT_OPTIONS:MHEIMDAL} && empty(${PORT_OPTIONS:MHEIMDAL_PORT})
CONFIGURE_ARGS+=--with-rlm-krb5-lib-dir=/usr/lib
CONFIGURE_ARGS+=--with-rlm-krb5-include-dir=/usr/include
CONFIGURE_ENV+= KRB5LIBS="$$(${KRB5_CONFIG})"
@@ -111,11 +110,11 @@ PLIST_SUB+= KRB5="@comment "
.endif
# Patch rlm_krb5.c to add Heimdal support for specifying keytab+SPN
-.ifdef(WITH_HEIMDAL_PATCH)
+.if ${PORT_OPTIONS:MHEIMDAL_PATCH}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__modules__rlm_krb5__rlm_krb5.c
.endif
-.ifdef(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= YES
CONFIGURE_ARGS+=--with-rlm_ldap
PLIST_SUB+= LDAP=""
@@ -125,7 +124,7 @@ CONFIGURE_ARGS+=--without-rlm_ldap
PLIST_SUB+= LDAP="@comment "
.endif
-.ifdef(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= YES
CONFIGURE_ARGS+=--with-rlm_sql_mysql
PLIST_SUB+= MYSQL=""
@@ -135,7 +134,7 @@ CONFIGURE_ARGS+=--without-rlm_sql_mysql
PLIST_SUB+= MYSQL="@comment "
.endif
-.ifdef(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= YES
CONFIGURE_ARGS+=--with-rlm_sql_postgresql
PLIST_SUB+= PGSQL=""
@@ -145,7 +144,7 @@ CONFIGURE_ARGS+=--without-rlm_sql_postgresql
PLIST_SUB+= PGSQL="@comment "
.endif
-.ifdef(WITH_UNIXODBC)
+.if ${PORT_OPTIONS:MUNIXODBC}
CONFIGURE_ARGS+=--with-rlm_sql_unixodbc
PLIST_SUB+= UNIXODBC=""
LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
@@ -154,7 +153,7 @@ CONFIGURE_ARGS+=--without-rlm_sql_unixodbc
PLIST_SUB+= UNIXODBC="@comment "
.endif
-.ifdef(WITH_FIREBIRD)
+.if ${PORT_OPTIONS:MFIREBIRD}
USE_FIREBIRD= YES
CONFIGURE_ARGS+=--with-rlm_sql_firebird
PLIST_SUB+= FIREBIRD=""
@@ -164,11 +163,11 @@ PLIST_SUB+= FIREBIRD="@comment "
.endif
# Firebird module is still experimental
-.if defined(WITH_FIREBIRD) && !defined(WITH_EXPERIMENTAL)
+.if ${PORT_OPTIONS:MFIREBIRD} && empty(${PORT_OPTIONS:MEXPERIMENTAL}
EXPM= yes
.endif
-.ifdef(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
CONFIGURE_ARGS+=--with-rlm_perl
PLIST_SUB+= RLMPERL=""
@@ -177,7 +176,7 @@ CONFIGURE_ARGS+=--without-perl --without-rlm_perl
PLIST_SUB+= RLMPERL="@comment "
.endif
-.ifdef(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
CONFIGURE_ARGS+=--with-rlm_python \
--with-rlm-python-lib-dir=${PYTHON_LIBDIR} \
@@ -188,7 +187,7 @@ CONFIGURE_ARGS+=--without-rlm_python
PLIST_SUB+= RLMPYTHON="@comment "
.endif
-.ifdef(WITH_RUBY)
+.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
CONFIGURE_ARGS+=--with-rlm_ruby
PLIST_SUB+= RLMRUBY=""
@@ -198,23 +197,23 @@ PLIST_SUB+= RLMRUBY="@comment "
.endif
# rlm_ruby module is still experimental
-.if defined(WITH_RUBY) && !defined(WITH_EXPERIMENTAL)
+.if ${PORT_OPTIONS:MRUBY} && empty(${PORT_OPTIONS:MEXPERIMENTAL})
EXPM= yes
.endif
-.ifdef(WITH_DHCP)
+.if ${PORT_OPTIONS:MDHCP}
CONFIGURE_ARGS+=--with-dhcp
.else
CONFIGURE_ARGS+=--without-dhcp
.endif
# DHCP is still experimental
-.if defined(WITH_DHCP) && !defined(WITH_EXPERIMENTAL)
+.if ${PORT_OPTIONS:MDHCP} && empty(${PORT_OPTIONS:MEXPERIMENTAL})
EXPM= yes
.endif
# No SMB option yet; rlm_smb is still unbuildable
-.ifdef(WITH_SMB)
+.if ${PORT_OPTIONS:MSMB}
LIB_DEPENDS= smbclient:${PORTSDIR}/net/samba-libsmbclient
CONFIGURE_ARGS+=--with-rlm_smb
CONFIGURE_ARGS+=--with-rlm-smb-lib-dir=${LOCALBASE}/lib
@@ -226,12 +225,12 @@ PLIST_SUB+= SMB="@comment "
.endif
# SMB module is still experimental
-.if defined(WITH_SMB) && !defined(WITH_EXPERIMENTAL)
+.if ${PORT_OPTIONS:MSMB} && empty(${PORT_OPTIONS:MSMB})
EXPM= yes
.endif
# Oracle support is experimental under FreeBSD
-.ifdef(WITH_OCI8)
+.if ${PORT_OPTIONS:MOCI8}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-exec.c
CONFIGURE_ENV= ORACLE_HOME="${ORACLE_HOME}"
ORACLE_HOME?= ${LOCALBASE}/oracle8-client
@@ -243,21 +242,21 @@ CONFIGURE_ARGS+=--without-rlm_sql_oracle
PLIST_SUB+= OCI8="@comment "
.endif
-.if defined(EXPM) || defined(WITH_EXPERIMENTAL)
+.if ${PORT_OPTIONS:MEXPERIMENTAL} || defined(EXPM)
CONFIGURE_ARGS+=--with-experimental-modules
PLIST_SUB+= EXPM=""
.else
PLIST_SUB+= EXPM="@comment "
.endif
-.ifdef(WITH_DEVELOPER)
+.if ${PORT_OPTIONS:MDEVELOPER}
CONFIGURE_ARGS+=--enable-developer
# Turn off compiler optimisations
CFLAGS!= ${ECHO} ${CFLAGS} | ${SED} -Ee 's:-O[0-9]?[[:space:]]*::g'
.endif
# Compile in UDPFROMTO support
-.ifdef(WITH_UDPFROMTO)
+.if ${PORT_OPTIONS:MUDPFROMTO}
CONFIGURE_ARGS+=--with-udpfromto
.endif
@@ -324,7 +323,7 @@ MAN5= acct_users.5 clients.conf.5 dictionary.5 radiusd.conf.5 \
rlm_sql_log.5 rlm_unix.5 unlang.5 users.5 checkrad.5
MAN8= radiusd.8 radmin.8 raddebug.8 radrelay.8 radsqlrelay.8 \
radwatch.8 rlm_ippool_tool.8 radconf2xml.8 radcrypt.8 \
- radsniff.8 rlm_dbm_cat.8 rlm_dbm_parse.8
+ radsniff.8 rlm_dbm_cat.8 rlm_dbm_parser.8
SUB_LIST+= REQUIRE="${_REQUIRE}"
@@ -349,13 +348,13 @@ post-patch:
-regex '.*/(bootstrap|Makefile)\.(orig|bak)$$' \
-delete
# If we're using Heimdal from base, alter the LIBS variable
-.if defined(WITH_HEIMDAL) && !defined(WITH_HEIMDAL_PORT)
+.if ${PORT_OPTIONS:MHEIMDAL} && empty(${PORT_OPTIONS:MHEIMDAL_PORT})
@${REINPLACE_CMD} -e 's|LIBS|KRB5LIBS|g' ${WRKSRC}/src/modules/rlm_krb5/configure
@${REINPLACE_CMD} -e 's|-lkrb5|$$(${KRB5_CONFIG})|g' \
${WRKSRC}/src/modules/rlm_krb5/configure
.endif
-# If DHCPis enabled, enable the DHCP dictionary
-.ifdef(WITH_DHCP)
+# If DHCP is enabled, enable the DHCP dictionary
+.if ${PORT_OPTIONS:MDHCP}
@${REINPLACE_CMD} -Ee 's:^#(.+ dictionary\.dhcp)$$:\1:g' \
${WRKSRC}/share/dictionary
# Clean up (so as not to get an unwanted file in share)
diff --git a/net/freeradius2/distinfo b/net/freeradius2/distinfo
index 91ec17cd8499..1191fc80ff7c 100644
--- a/net/freeradius2/distinfo
+++ b/net/freeradius2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freeradius-server-2.1.12.tar.bz2) = b66bb2935b656e19f2b725df1162e7ac160537e8ef8266c2447779bb7d113172
-SIZE (freeradius-server-2.1.12.tar.bz2) = 2670611
+SHA256 (freeradius-server-2.2.0.tar.bz2) = ad3e58fe2a723cbaafb8ca87677382a84bfb16e81b24f0d9ded71355a0218d35
+SIZE (freeradius-server-2.2.0.tar.bz2) = 2703349
diff --git a/net/freeradius2/files/patch-CVE-2012-3547 b/net/freeradius2/files/patch-CVE-2012-3547
deleted file mode 100644
index 59e80ad90be6..000000000000
--- a/net/freeradius2/files/patch-CVE-2012-3547
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/modules/rlm_eap/types/rlm_eap_tls/rlm_eap_tls.c.orig 2011-09-30 10:12:07.000000000 -0400
-+++ ./src/modules/rlm_eap/types/rlm_eap_tls/rlm_eap_tls.c 2012-09-11 07:28:34.000000000 -0400
-@@ -531,7 +531,7 @@
- */
- buf[0] = '\0';
- asn_time = X509_get_notAfter(client_cert);
-- if ((lookup <= 1) && asn_time && (asn_time->length < MAX_STRING_LEN)) {
-+ if ((lookup <= 1) && asn_time && (asn_time->length < sizeof(buf))) {
- memcpy(buf, (char*) asn_time->data, asn_time->length);
- buf[asn_time->length] = '\0';
- pairadd(&handler->certs,
diff --git a/net/freeradius2/files/patch-configure.in b/net/freeradius2/files/patch-configure.in
new file mode 100644
index 000000000000..b11d88b7e301
--- /dev/null
+++ b/net/freeradius2/files/patch-configure.in
@@ -0,0 +1,39 @@
+--- ./configure.in.orig 2012-09-10 18:53:25.000000000 -0400
++++ ./configure.in 2012-09-10 18:55:15.000000000 -0400
+@@ -443,6 +443,21 @@
+ AC_DEFINE(WITH_UDPFROMTO, [], [define if you want udpfromto])
+ fi
+
++dnl extra argument: --with-perl
++WITH_PERL=yes
++AC_ARG_WITH(perl,
++ [ --with-perl Enable Perl support. (default=yes)],
++ [ case "$withval" in
++ yes)
++ ;;
++ *)
++ WITH_PERL=no
++ esac ]
++ )
++if test "x$WITH_PERL" = "xno"; then
++ with_rlm_perl=no
++fi
++
+ dnl #############################################################
+ dnl #
+ dnl # 1. Checks for programs
+@@ -450,10 +465,14 @@
+ dnl #############################################################
+
+ CHECKRAD=checkrad.pl
++if test "x$WITH_PERL" = "xyes"; then
+ AC_PATH_PROG(PERL, perl, /usr/local/bin/perl)
+ if test "x$ac_cv_path_PERL" = "x"; then
+ AC_MSG_WARN(perl not found - Simultaneous-Use and checkrad.pl may not work)
+ fi
++else
++ AC_MSG_WARN(perl disabled - Simultaneous-Use and checkrad.pl may not work)
++fi
+ AC_PATH_PROG(SNMPGET, snmpget)
+ if test "x$ac_cv_path_SNMPGET" = "x"; then
+ AC_MSG_WARN(snmpget not found - Simultaneous-Use and checkrad.pl may not work)
diff --git a/net/freeradius2/files/patch-perl b/net/freeradius2/files/patch-perl
deleted file mode 100644
index d7634c087159..000000000000
--- a/net/freeradius2/files/patch-perl
+++ /dev/null
@@ -1,61 +0,0 @@
---- configure.in 2009-07-01 17:32:17.000000000 +0100
-+++ configure.in 2009-07-01 17:45:44.000000000 +0100
-@@ -409,6 +409,21 @@
- AC_DEFINE(WITH_UDPFROMTO, [], [define if you want udpfromto])
- fi
-
-+dnl extra argument: --with-perl
-+WITH_PERL=yes
-+AC_ARG_WITH(perl,
-+[ --with-perl Enable Perl support. (default=yes)],
-+[ case "$withval" in
-+ yes)
-+ ;;
-+ *)
-+ WITH_PERL=no
-+ esac ]
-+)
-+if test "x$WITH_PERL" = "xno"; then
-+ with_rlm_perl=no
-+fi
-+
- dnl #############################################################
- dnl #
- dnl # 1. Checks for programs
-@@ -416,10 +431,14 @@
- dnl #############################################################
-
- CHECKRAD=checkrad.pl
-+if test "x$WITH_PERL" = "xyes"; then
- AC_PATH_PROG(PERL, perl, /usr/local/bin/perl)
- if test "x$ac_cv_path_PERL" = "x"; then
- AC_MSG_WARN(perl not found - Simultaneous-Use and checkrad.pl may not work)
- fi
-+else
-+ AC_MSG_WARN(perl disabled - Simultaneous-Use and checkrad.pl may not work)
-+fi
- AC_PATH_PROG(SNMPGET, snmpget)
- if test "x$ac_cv_path_SNMPGET" = "x"; then
- AC_MSG_WARN(snmpget not found - Simultaneous-Use and checkrad.pl may not work)
---- src/modules/rlm_perl/configure.in 2009-07-01 17:58:23.000000000 +0100
-+++ src/modules/rlm_perl/configure.in 2009-07-01 20:09:39.000000000 +0100
-@@ -3,7 +3,18 @@
- AC_REVISION($Revision$)
- AC_DEFUN(modname,[rlm_perl])
-
--if test x$with_[]modname != xno; then
-+dnl extra argument: --with-perl
-+WITH_PERL=yes
-+AC_ARG_WITH(perl,
-+[ --with-perl Enable Perl support. (default=yes)],
-+[ case "$withval" in
-+ yes)
-+ ;;
-+ *)
-+ WITH_PERL=no
-+ esac ]
-+)
-+if test x$with_[]modname != xno && test x$WITH_PERL != xno; then
-
- AC_PROG_CC
- AC_PROG_CPP
diff --git a/net/freeradius2/files/patch-pthread b/net/freeradius2/files/patch-pthread
deleted file mode 100644
index 5cfc02d9ec9d..000000000000
--- a/net/freeradius2/files/patch-pthread
+++ /dev/null
@@ -1,147 +0,0 @@
---- configure.in Mon Aug 6 00:38:46 2007
-+++ configure.in Thu Sep 18 18:30:00 2008
-@@ -470,14 +470,25 @@
- dnl # On Some systems, we need extra pre-processor flags, to get them to
- dnl # to do the threading properly.
- dnl #
-- AC_CHECK_LIB(pthread, pthread_create,
-- [ CFLAGS="$CFLAGS -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS"
-- LIBS="$LIBS -lpthread" ],
-- AC_CHECK_LIB(c_r, pthread_create,
-- [ CFLAGS="$CFLAGS -pthread -D_THREAD_SAFE" ],
-- [ WITH_THREADS="no" ]
-- )
-- )
-+dnl # On FreeBSD, check the pthread_create function with -pthread in $CFLAGS
-+dnl # but WITHOUT -lpthread (see FreeBSD Porter's Handbook, section 12.12
-+dnl # at http://tinyurl.com/34cya8 )
-+ case "$build" in
-+ *-freebsd*)
-+ CFLAGS="$CFLAGS -pthread"
-+ AC_CHECK_FUNC(pthread_create, , [ WITH_THREADS="no" ])
-+ ;;
-+ *)
-+ AC_CHECK_LIB(pthread, pthread_create,
-+ [ CFLAGS="$CFLAGS -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS"
-+ LIBS="$LIBS -lpthread" ],
-+ AC_CHECK_LIB(c_r, pthread_create,
-+ [ CFLAGS="$CFLAGS -pthread -D_THREAD_SAFE" ],
-+ [ WITH_THREADS="no" ]
-+ )
-+ )
-+ ;;
-+ esac
- fi
-
- dnl #
---- src/modules/rlm_ldap/configure.in Fri Jul 27 17:51:33 2007
-+++ src/modules/rlm_ldap/configure.in Thu Sep 18 18:30:00 2008
-@@ -77,14 +77,27 @@
-
- dnl pthread stuff is usually in -lpthread
- dnl or in -lc_r, on *BSD
-+ dnl FreeBSD uses -pthread
- if test "x$rlm_ldap_with_threads" = "xyes"; then
-- AC_CHECK_LIB(pthread, pthread_create,
-- [ LIBS="-lpthread $LIBS" ],
-- AC_CHECK_LIB(c_r, pthread_create,
-- [ LIBS="-lc_r $LIBS" ],
-- [ rlm_ldap_with_threads="no" ]
-- )
-- )
-+ case "$build" in
-+ *-freebsd*)
-+ old_CFLAGS=$CFLAGS
-+ CFLAGS="$CFLAGS -pthread"
-+ AC_CHECK_FUNC(pthread_create, , [ rlm_ldap_with_threads="no" ])
-+ if test "x$rlm_ldap_with_threads" = "xno"; then
-+ CFLAGS=$old_CFLAGS
-+ fi
-+ ;;
-+ *)
-+ AC_CHECK_LIB(pthread, pthread_create,
-+ [ LIBS="-lpthread $LIBS" ],
-+ AC_CHECK_LIB(c_r, pthread_create,
-+ [ LIBS="-lc_r $LIBS" ],
-+ [ rlm_ldap_with_threads="no" ]
-+ )
-+ )
-+ ;;
-+ esac
- fi
-
- dnl Try only "-lldap_r" or "-lldap"
---- src/modules/rlm_sql/drivers/rlm_sql_mysql/configure.in Fri Nov 25 20:31:54 2005
-+++ src/modules/rlm_sql/drivers/rlm_sql_mysql/configure.in Thu Sep 18 18:30:00 2008
-@@ -61,14 +61,27 @@
-
- dnl pthread stuff is usually in -lpthread
- dnl or in -lc_r, on *BSD
-+ dnl FreeBSD uses -pthread
- if test "x$mysql_with_threads" = "xyes"; then
-- AC_CHECK_LIB(pthread, pthread_create,
-- [ LIBS="-lpthread $LIBS" ],
-- AC_CHECK_LIB(c_r, pthread_create,
-- [ LIBS="-lc_r $LIBS" ],
-- [ mysql_with_threads=no ]
-- )
-- )
-+ case "$build" in
-+ *-freebsd*)
-+ old_CFLAGS=$CFLAGS
-+ CFLAGS="$CFLAGS -pthread"
-+ AC_CHECK_FUNC(pthread_create, , [ mysql_with_threads="no" ])
-+ if test "x$mysql_with_threads" = "xno"; then
-+ CFLAGS=$old_CFLAGS
-+ fi
-+ ;;
-+ *)
-+ AC_CHECK_LIB(pthread, pthread_create,
-+ [ LIBS="-lpthread $LIBS" ],
-+ AC_CHECK_LIB(c_r, pthread_create,
-+ [ LIBS="-lc_r $LIBS" ],
-+ [ mysql_with_threads=no ]
-+ )
-+ )
-+ ;;
-+ esac
- fi
-
- if test "x$mysql_with_threads" = "xyes"; then
---- src/modules/rlm_python/configure.in Mon May 14 23:27:21 2007
-+++ src/modules/rlm_python/configure.in Thu Sep 18 18:30:00 2008
-@@ -85,6 +85,34 @@
- FR_SMART_CHECK_LIB(python${PY_VERSION}, Py_Initialize)
- LIBS=$old_LIBS
-
-+dnl # If that check fails, try it again having identified threading libraries
-+dnl # in case libpython is threaded
-+
-+ if test "x$smart_lib" = "x"; then
-+ AC_MSG_NOTICE([Checking to see if libpython needs -pthread.])
-+ libpython_with_threads="yes"
-+ case "$build" in
-+ *-freebsd*)
-+ old_CFLAGS=$CFLAGS
-+ CFLAGS="$CFLAGS -pthread"
-+ AC_CHECK_FUNC(pthread_create, , [ libpython_with_threads="no" ])
-+ if test "x$libpython_with_threads" = "xno"; then
-+ CFLAGS=$old_CFLAGS
-+ fi
-+ ;;
-+ *)
-+ ;;
-+ esac
-+
-+ if test "x$libpython_with_threads" = "xyes"; then
-+ old_LIBS=$LIBS
-+ LIBS="$LIBS $PY_LIB_LOC $PY_EXTRA_LIBS -lm"
-+ smart_try_dir=$PY_LIB_DIR
-+ FR_SMART_CHECK_LIB(python${PY_VERSION}, Py_Initialize)
-+ LIBS=$old_LIBS
-+ fi
-+ fi
-+
- eval t=\${ac_cv_lib_${sm_lib_safe}_${sm_func_safe}}
- if test "x$t" = "xyes"; then
- python_ldflags="$PY_LIB_LOC $PY_EXTRA_LIBS -lpython${PY_VERSION} -lm"
diff --git a/net/freeradius2/files/patch-src__include__sysutmp.h b/net/freeradius2/files/patch-src__include__sysutmp.h
deleted file mode 100644
index 1589ee1d283c..000000000000
--- a/net/freeradius2/files/patch-src__include__sysutmp.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./src/include/sysutmp.h.orig 2009-12-30 10:44:35.000000000 -0500
-+++ ./src/include/sysutmp.h 2010-03-06 09:32:13.075571526 -0500
-@@ -30,7 +30,7 @@
- # define UT_NAMESIZE 32
- # define UT_LINESIZE 32
- # define UT_HOSTSIZE 257
--#ifdef hpux
-+#if defined(hpux) || defined(__FreeBSD__)
- # define ut_name ut_user
- #endif
- #else
-@@ -43,7 +43,7 @@
- # define UT_HOSTSIZE 64
- #endif
-
--#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(bsdi) || defined(__OpenBSD__) || defined(__APPLE__)
-+#if (defined(__FreeBSD__) && !defined(HAVE_UTMPX_H)) || defined(__NetBSD__) || defined(bsdi) || defined(__OpenBSD__) || defined(__APPLE__)
- # ifndef UTMP_FILE
- # define UTMP_FILE "/var/run/utmp"
- # endif
diff --git a/net/freeradius2/files/patch-src__modules__rlm_perl__configure.in b/net/freeradius2/files/patch-src__modules__rlm_perl__configure.in
new file mode 100644
index 000000000000..dda2341761de
--- /dev/null
+++ b/net/freeradius2/files/patch-src__modules__rlm_perl__configure.in
@@ -0,0 +1,22 @@
+--- ./src/modules/rlm_perl/configure.in.orig 2012-09-10 18:55:42.000000000 -0400
++++ ./src/modules/rlm_perl/configure.in 2012-09-10 18:56:32.000000000 -0400
+@@ -3,7 +3,18 @@
+ AC_REVISION($Revision$)
+ AC_DEFUN(modname,[rlm_perl])
+
+-if test x$with_[]modname != xno; then
++dnl extra argument: --with-perl
++WITH_PERL=yes
++AC_ARG_WITH(perl,
++ [ --with-perl Enable Perl support. (default=yes)],
++ [ case "$withval" in
++ yes)
++ ;;
++ *)
++ WITH_PERL=no
++ esac ]
++ )
++if test x$with_[]modname != xno && test x$WITH_PERL != xno; then
+
+ AC_PROG_CC
+ AC_PROG_CPP
diff --git a/net/freeradius2/pkg-plist b/net/freeradius2/pkg-plist
index a33434e6fa37..8a731cf9be8e 100644
--- a/net/freeradius2/pkg-plist
+++ b/net/freeradius2/pkg-plist
@@ -9,6 +9,7 @@ bin/radsqlrelay
bin/radtest
bin/radwho
bin/radzap
+bin/rad_counter
bin/rlm_dbm_cat
bin/rlm_dbm_parser
bin/rlm_ippool_tool
@@ -39,6 +40,7 @@ bin/smbencrypt
%%EXAMPLESDIR%%/raddb/modules/always
%%EXAMPLESDIR%%/raddb/modules/attr_filter
%%EXAMPLESDIR%%/raddb/modules/attr_rewrite
+%%EXAMPLESDIR%%/raddb/modules/cache
%%EXAMPLESDIR%%/raddb/modules/chap
%%EXAMPLESDIR%%/raddb/modules/checkval
%%EXAMPLESDIR%%/raddb/modules/counter
@@ -46,6 +48,7 @@ bin/smbencrypt
%%EXAMPLESDIR%%/raddb/modules/detail
%%EXAMPLESDIR%%/raddb/modules/detail.example.com
%%EXAMPLESDIR%%/raddb/modules/detail.log
+%%EXAMPLESDIR%%/raddb/modules/dhcp_sqlippool
%%EXAMPLESDIR%%/raddb/modules/digest
%%EXAMPLESDIR%%/raddb/modules/dynamic_clients
%%EXAMPLESDIR%%/raddb/modules/echo
@@ -72,6 +75,7 @@ bin/smbencrypt
%%EXAMPLESDIR%%/raddb/modules/perl
%%EXAMPLESDIR%%/raddb/modules/policy
%%EXAMPLESDIR%%/raddb/modules/preprocess
+%%EXAMPLESDIR%%/raddb/modules/radrelay
%%EXAMPLESDIR%%/raddb/modules/radutmp
%%EXAMPLESDIR%%/raddb/modules/realm
%%EXAMPLESDIR%%/raddb/modules/redis
@@ -98,6 +102,7 @@ bin/smbencrypt
%%EXAMPLESDIR%%/raddb/sites-available/decoupled-accounting
%%EXAMPLESDIR%%/raddb/sites-available/default
%%EXAMPLESDIR%%/raddb/sites-available/dhcp
+%%EXAMPLESDIR%%/raddb/sites-available/dhcp.relay
%%EXAMPLESDIR%%/raddb/sites-available/dynamic-clients
%%EXAMPLESDIR%%/raddb/sites-available/example
%%EXAMPLESDIR%%/raddb/sites-available/inner-tunnel
@@ -123,6 +128,7 @@ bin/smbencrypt
%%EXAMPLESDIR%%/raddb/sql/mysql/cui.sql
%%EXAMPLESDIR%%/raddb/sql/mysql/dialup.conf
%%EXAMPLESDIR%%/raddb/sql/mysql/ippool.conf
+%%EXAMPLESDIR%%/raddb/sql/mysql/ippool-dhcp.conf
%%EXAMPLESDIR%%/raddb/sql/mysql/ippool.sql
%%EXAMPLESDIR%%/raddb/sql/mysql/nas.sql
%%EXAMPLESDIR%%/raddb/sql/mysql/schema.sql
@@ -197,6 +203,11 @@ bin/smbencrypt
%%LIBDIR%%/rlm_attr_rewrite.a
%%LIBDIR%%/rlm_attr_rewrite.la
%%LIBDIR%%/rlm_attr_rewrite.so
+%%LIBDIR%%/rlm_cache-%%PORTVERSION%%.la
+%%LIBDIR%%/rlm_cache-%%PORTVERSION%%.so
+%%LIBDIR%%/rlm_cache.a
+%%LIBDIR%%/rlm_cache.la
+%%LIBDIR%%/rlm_cache.so
%%EXPM%%%%LIBDIR%%/rlm_caching-%%PORTVERSION%%.la
%%EXPM%%%%LIBDIR%%/rlm_caching-%%PORTVERSION%%.so
%%EXPM%%%%LIBDIR%%/rlm_caching.a
@@ -497,11 +508,11 @@ bin/smbencrypt
%%LIBDIR%%/rlm_unix.a
%%LIBDIR%%/rlm_unix.la
%%LIBDIR%%/rlm_unix.so
-%%EXPM%%%%LIBDIR%%/rlm_wimax-%%PORTVERSION%%.la
-%%EXPM%%%%LIBDIR%%/rlm_wimax-%%PORTVERSION%%.so
-%%EXPM%%%%LIBDIR%%/rlm_wimax.a
-%%EXPM%%%%LIBDIR%%/rlm_wimax.la
-%%EXPM%%%%LIBDIR%%/rlm_wimax.so
+%%LIBDIR%%/rlm_wimax-%%PORTVERSION%%.la
+%%LIBDIR%%/rlm_wimax-%%PORTVERSION%%.so
+%%LIBDIR%%/rlm_wimax.a
+%%LIBDIR%%/rlm_wimax.la
+%%LIBDIR%%/rlm_wimax.so
@dirrm %%LIBDIR%%
sbin/checkrad
sbin/raddebug
@@ -584,7 +595,6 @@ include/freeradius/vqp.h
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2867.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2868.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2869.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2882.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2924.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3079.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3162.txt
@@ -593,6 +603,7 @@ include/freeradius/vqp.h
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3579.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3580.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3748.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc4282.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc4372.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc4590.txt
%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc4668.txt
@@ -679,8 +690,10 @@ include/freeradius/vqp.h
%%DATADIR%%/dictionary.bay
%%DATADIR%%/dictionary.bintec
%%DATADIR%%/dictionary.bristol
+%%DATADIR%%/dictionary.bt
%%DATADIR%%/dictionary.cablelabs
%%DATADIR%%/dictionary.cabletron
+%%DATADIR%%/dictionary.camiant
%%DATADIR%%/dictionary.chillispot
%%DATADIR%%/dictionary.cisco
%%DATADIR%%/dictionary.cisco.bbsm
@@ -698,6 +711,7 @@ include/freeradius/vqp.h
%%DATADIR%%/dictionary.ericsson
%%DATADIR%%/dictionary.erx
%%DATADIR%%/dictionary.extreme
+%%DATADIR%%/dictionary.f5
%%DATADIR%%/dictionary.fortinet
%%DATADIR%%/dictionary.foundry
%%DATADIR%%/dictionary.freeradius
@@ -739,9 +753,11 @@ include/freeradius/vqp.h
%%DATADIR%%/dictionary.ntua
%%DATADIR%%/dictionary.openser
%%DATADIR%%/dictionary.packeteer
+%%DATADIR%%/dictionary.paloalto
%%DATADIR%%/dictionary.patton
%%DATADIR%%/dictionary.propel
%%DATADIR%%/dictionary.prosoft
+%%DATADIR%%/dictionary.purewave
%%DATADIR%%/dictionary.quiconnect
%%DATADIR%%/dictionary.quintum
%%DATADIR%%/dictionary.redback
@@ -763,6 +779,7 @@ include/freeradius/vqp.h
%%DATADIR%%/dictionary.rfc4849
%%DATADIR%%/dictionary.rfc5090
%%DATADIR%%/dictionary.rfc5176
+%%DATADIR%%/dictionary.rfc5447
%%DATADIR%%/dictionary.rfc5580
%%DATADIR%%/dictionary.rfc5607
%%DATADIR%%/dictionary.rfc5904
@@ -781,6 +798,7 @@ include/freeradius/vqp.h
%%DATADIR%%/dictionary.t_systems_nova
%%DATADIR%%/dictionary.telebit
%%DATADIR%%/dictionary.telkom
+%%DATADIR%%/dictionary.terena
%%DATADIR%%/dictionary.trapeze
%%DATADIR%%/dictionary.tropos
%%DATADIR%%/dictionary.ukerna