aboutsummaryrefslogtreecommitdiff
path: root/net/geoclue/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/geoclue/Makefile')
-rw-r--r--net/geoclue/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/geoclue/Makefile b/net/geoclue/Makefile
index c83abb820aa9..dd5e6e086bc8 100644
--- a/net/geoclue/Makefile
+++ b/net/geoclue/Makefile
@@ -2,25 +2,28 @@
# $FreeBSD$
PORTNAME= geoclue
-PORTVERSION= 2.3.0
+PORTVERSION= 2.4.3
CATEGORIES= net devel gnome
MASTER_SITES= http://www.freedesktop.org/software/geoclue/releases/${PORTVERSION:R}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= D-Bus service that provides location information
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
+
LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
libsoup-2.4.so:devel/libsoup
-USES= gettext gmake gnome pathfix pkgconfig tar:xz
-USE_GNOME= glib20 intlhack
+USES= gettext gmake gnome libtool localbase pathfix \
+ pkgconfig tar:xz
+USE_GNOME= glib20 intlhack introspection:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-3g-source \
--disable-cdma-source \
--disable-nmea-source \
--disable-modem-gps-source
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
.include <bsd.port.mk>