aboutsummaryrefslogtreecommitdiff
path: root/net/gnomba/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnomba/Makefile')
-rw-r--r--net/gnomba/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/net/gnomba/Makefile b/net/gnomba/Makefile
index 15c972b44a2d..ce5e7580d703 100644
--- a/net/gnomba/Makefile
+++ b/net/gnomba/Makefile
@@ -13,16 +13,21 @@ MASTER_SITES= http://gnomba.darkcorner.net/tars/ \
MAINTAINER= dima@Chg.RU
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
+ s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
pre-configure:
- ${RM} ${WRKSRC}/config.cache
+ ${RM} ${WRKSRC}/config.cache
.include <bsd.port.mk>