aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-nettool/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnome-nettool/files')
-rw-r--r--net/gnome-nettool/files/patch-po_Makefile.in.in10
-rw-r--r--net/gnome-nettool/files/patch-src_info.c178
-rw-r--r--net/gnome-nettool/files/patch-src_netstat.c20
-rw-r--r--net/gnome-nettool/files/patch-src_nettool.c10
-rw-r--r--net/gnome-nettool/files/patch-src_utils.c11
5 files changed, 0 insertions, 229 deletions
diff --git a/net/gnome-nettool/files/patch-po_Makefile.in.in b/net/gnome-nettool/files/patch-po_Makefile.in.in
deleted file mode 100644
index 2c6b6128215e..000000000000
--- a/net/gnome-nettool/files/patch-po_Makefile.in.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- po/Makefile.in.in.orig Fri Aug 20 15:59:14 2004
-+++ po/Makefile.in.in Fri Aug 20 15:59:26 2004
-@@ -32,6 +32,7 @@
- gnulocaledir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/glib-2.0/gettext/po
- subdir = po
-+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
diff --git a/net/gnome-nettool/files/patch-src_info.c b/net/gnome-nettool/files/patch-src_info.c
deleted file mode 100644
index c4bd8e09b1b9..000000000000
--- a/net/gnome-nettool/files/patch-src_info.c
+++ /dev/null
@@ -1,178 +0,0 @@
---- src/info.c.orig Mon Jun 14 06:52:59 2004
-+++ src/info.c Fri Aug 20 15:52:34 2004
-@@ -37,6 +37,9 @@
- #include <sys/ioctl.h>
- #include <stdlib.h>
- #include <net/if.h>
-+#ifdef __FreeBSD__
-+#include <net/if_media.h>
-+#endif
-
- #include "info.h"
- #include "utils.h"
-@@ -97,9 +100,39 @@
- {
- gint i;
- gchar *path;
--
-+ gchar *dev_type = NULL;
-+#if defined(__FreeBSD__)
-+ int s;
-+ struct ifmediareq ifmr;
-+
-+ if ((s = socket (AF_INET, SOCK_DGRAM, 0)) > -1) {
-+
-+ (void) memset (&ifmr, 0, sizeof (ifmr));
-+ (void) strncpy (ifmr.ifm_name, dev_name, sizeof (ifmr.ifm_name));
-+
-+ if (ioctl (s, SIOCGIFMEDIA, (caddr_t) &ifmr) > -1) {
-+ switch (IFM_TYPE (ifmr.ifm_active)) {
-+ case IFM_ETHER:
-+ dev_type = "eth";
-+ break;
-+ case IFM_FDDI:
-+ case IFM_TOKEN:
-+ dev_type = "other_type";
-+ break;
-+ case IFM_IEEE80211:
-+ dev_type = "wlan";
-+ break;
-+ }
-+ }
-+ close (s);
-+ }
-+#endif /* defined(__FreeBSD__) */
-+
-+ if (!dev_type)
-+ dev_type = (gchar *) dev_name;
-+
- for (i = 0; info_iface_desc[i].name; i++)
-- if (strstr (dev_name, info_iface_desc[i].prefix) == dev_name) {
-+ if (strstr (dev_type, info_iface_desc[i].prefix) == dev_type) {
- (*iface) = g_strdup_printf ("%s (%s)", info_iface_desc[i].name, dev_name);
- if (info_iface_desc[i].pixbuf == NULL) {
- path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -187,17 +220,26 @@
- gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
- */
- gchar iface[30]; /*, flags[30]; */
-- gchar rx_bytes[16], rx_pkt[10], rx_error[10], rx_drop[10], rx_fifo[10];
-- gchar frame[10], compressed[10], multicast[10];
-- gchar tx_bytes[16], tx_pkt[10], tx_error[10], tx_drop[10], tx_fifo[10];
-+ gchar rx_bytes[16], rx_pkt[10], rx_error[10];
-+ gchar tx_bytes[16], tx_pkt[10], tx_error[10];
- gchar collissions[10];
-+#if defined(__linux__)
-+ gchar rx_drop[10], rx_fifo[10];
-+ gchar frame[10], compressed[10], multicast[10];
-+ gchar tx_drop[10], tx_fifo[10];
-+#elif defined(__FreeBSD__)
-+ char *p;
-+ gchar **tokens, **argv;
-+ int i;
-+ int pipe_out;
-+#endif
-
- GIOChannel *io = NULL;
- gchar *line;
- gboolean title = TRUE;
- const gchar *text;
- gchar *text_tx_bytes, *text_rx_bytes;
--
-+
- g_return_val_if_fail (info != NULL, FALSE);
-
- model = gtk_combo_box_get_model (GTK_COMBO_BOX (info->combo));
-@@ -206,21 +248,61 @@
- else
- return FALSE;
- /*text = gtk_entry_get_text (GTK_ENTRY (info->nic));*/
--
-+
- #if defined(__linux__)
- io = g_io_channel_new_file ("/proc/net/dev", "r", NULL);
--
-+#elif defined(__FreeBSD__)
-+ if (!g_shell_parse_argv ("/usr/bin/netstat -in -b -f link", NULL, &argv, NULL)) {
-+ return FALSE;
-+ }
-+ if (!g_spawn_async_with_pipes (NULL, argv, NULL, 0, NULL, NULL, NULL, NULL, &pipe_out, NULL, NULL)) {
-+ g_strfreev (argv);
-+ return FALSE;
-+ }
-+
-+ g_strfreev (argv);
-+
-+ io = g_io_channel_unix_new (pipe_out);
-+#endif /* defined(__linux__) */
-+
- while (g_io_channel_read_line (io, &line, NULL, NULL, NULL) == G_IO_STATUS_NORMAL) {
- if (title) {
- title = FALSE;
- g_free (line);
- continue;
- }
-+#if defined(__linux__)
- line = g_strdelimit (line, ":", ' ');
- sscanf (line, "%s %s %s %s %s %s %s %s %s %s %s %s %s %s %s", iface,
- rx_bytes, rx_pkt, rx_error, rx_drop, rx_fifo, frame,
- compressed, multicast,
- tx_bytes, tx_pkt, tx_error, tx_drop, tx_fifo, collissions);
-+#elif defined(__FreeBSD__)
-+ tokens = (gchar **) g_malloc0 (sizeof (gchar *) * 12);
-+ p = strtok (line, " \t\n");
-+ /* We only care about 11 fields for now */
-+ for (i = 0; i < 11 && p; i++, p = strtok (NULL, " \t\n")) {
-+ tokens[i] = g_strdup (p);
-+ }
-+
-+ if (i == 0 || i < 10) {
-+ g_free (line);
-+ g_strfreev (tokens);
-+ continue;
-+ }
-+
-+ g_strlcpy (iface, tokens[0], sizeof (iface));
-+
-+ g_strlcpy (collissions, tokens[--i], sizeof (collissions));
-+ g_strlcpy (tx_bytes, tokens[--i], sizeof (tx_bytes));
-+ g_strlcpy (tx_error, tokens[--i], sizeof (tx_error));
-+ g_strlcpy (tx_pkt, tokens[--i], sizeof (tx_pkt));
-+ g_strlcpy (rx_bytes, tokens[--i], sizeof (rx_bytes));
-+ g_strlcpy (rx_error, tokens[--i], sizeof (rx_error));
-+ g_strlcpy (rx_pkt, tokens[--i], sizeof (rx_pkt));
-+
-+ g_strfreev (tokens);
-+#endif /* defined(__linux__) */
-
- if (g_ascii_strcasecmp (iface, text) == 0) {
- /*
-@@ -248,7 +330,9 @@
- }
-
- g_io_channel_unref (io);
--#endif /* defined(__linux__) */
-+#if defined(__FreeBSD__)
-+ close (pipe_out);
-+#endif /* defined(__FreeBSD__) */
-
- return TRUE;
- }
-@@ -384,6 +468,7 @@
- mii_data_result data;
-
- getifaddrs (&ifa0);
-+ memset (&data, 0, sizeof (data));
-
- for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
- if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -429,7 +514,9 @@
- ifc.ifc_req = (struct ifreq *) buf;
- ioctl (sockfd, SIOCGIFCONF, &ifc);
-
-+#if defined(__linux__)
- data = mii_get_basic (nic);
-+#endif /* defined(__linux__) */
-
- for (ptr = buf; ptr < buf + ifc.ifc_len;) {
- ifr = (struct ifreq *) ptr;
diff --git a/net/gnome-nettool/files/patch-src_netstat.c b/net/gnome-nettool/files/patch-src_netstat.c
deleted file mode 100644
index 1eec8492793a..000000000000
--- a/net/gnome-nettool/files/patch-src_netstat.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/netstat.c.orig Tue Jul 6 13:55:25 2004
-+++ src/netstat.c Fri Aug 20 15:55:40 2004
-@@ -108,12 +108,17 @@
- g_return_val_if_fail (netinfo != NULL, NULL);
-
- if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (netinfo->routing))) {
-+#ifdef __FreeBSD__
-+ /* XXX We only support ipv4 now */
-+ option = g_strdup ("-rn -f inet");
-+#else
- /* Works for Solaris and Linux */
- if (netinfo_is_ipv6_enable ()) {
- option = g_strdup ("-rn -A inet -A inet6");
- } else {
- option = g_strdup ("-rn -A inet");
- }
-+#endif
-
- if (netinfo->stbar_text)
- g_free (netinfo->stbar_text);
diff --git a/net/gnome-nettool/files/patch-src_nettool.c b/net/gnome-nettool/files/patch-src_nettool.c
deleted file mode 100644
index 3319e36a70ae..000000000000
--- a/net/gnome-nettool/files/patch-src_nettool.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/nettool.c.orig Sun Jul 4 15:52:03 2004
-+++ src/nettool.c Sun Jul 4 15:53:11 2004
-@@ -21,6 +21,7 @@
- #include <gnome.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in.h>
- #include <signal.h>
- #include <errno.h>
- #include <sys/wait.h>
diff --git a/net/gnome-nettool/files/patch-src_utils.c b/net/gnome-nettool/files/patch-src_utils.c
deleted file mode 100644
index 0c8111ade4bf..000000000000
--- a/net/gnome-nettool/files/patch-src_utils.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/utils.c.orig Sun Jul 4 20:11:49 2004
-+++ src/utils.c Sun Jul 4 20:12:14 2004
-@@ -240,7 +240,7 @@
- const gchar *unit = "B";
- gchar *result;
-
-- sscanf (bytes, "%lld", &rx);
-+ rx = strtoull (bytes, (char **)NULL, 10);
- short_rx = rx * 10;
-
- if (rx > 1125899906842624ull) {